Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error on emerge gtk+
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
hfca
n00b
n00b


Joined: 18 Mar 2005
Posts: 16

PostPosted: Sun May 08, 2005 3:24 pm    Post subject: error on emerge gtk+ Reply with quote

Hello,

I' have an error on gdm, so i unmerged it and try to emerge it again, but when i was emerging it i had this error:

Quote:
configure: WARNING: If you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
In file included from gdk-pixbuf-i18n.h:4,
from gdk-pixbuf-private.h:32,
from io-jpeg.c:36:
../config.h:146:1: warning: "HAVE_STDLIB_H" redefined
In file included from /usr/include/jpeglib.h:24,
from io-jpeg.c:35:
/usr/include/jconfig.h:12:1: warning: this is the location of the previous definition
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../..//libglib-2.0.la' seems to be moved
grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la' is not a valid libtool archive
make[4]: *** [libpixbufloader-tiff.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

!!! ERROR: x11-libs/gtk+-2.6.4-r1 failed.
!!! Function src_compile, Line 84, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


I tried to emerge libstdc++ 3.3.4 but that didn't work.

Does somene hava a clue about this?
_________________
I'm very sorry for my english :S
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Sun May 08, 2005 3:39 pm    Post subject: Re: error on emerge gtk+ Reply with quote

hfca wrote:
Code:
/bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la' is not a valid libtool archive

https://forums.gentoo.org/viewtopic-t-318790.html
https://forums.gentoo.org/viewtopic-t-318791.html
https://forums.gentoo.org/viewtopic-t-324801.html
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
hfca
n00b
n00b


Joined: 18 Mar 2005
Posts: 16

PostPosted: Sun May 08, 2005 4:16 pm    Post subject: Reply with quote

Thanks.

The first worked well.
_________________
I'm very sorry for my english :S
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum