Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot install apache, being blocked by an unemerged apache
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
geoaxis
n00b
n00b


Joined: 08 Aug 2003
Posts: 72
Location: Abbottabad,Pakistan

PostPosted: Fri May 13, 2005 3:54 pm    Post subject: Cannot install apache, being blocked by an unemerged apache Reply with quote

this is happening rite now for emerge -pv apache
Code:
Calculating dependencies ...done!
[ebuild  N    ] net-www/apache-2.0.54-r2  +berkdb -debug +doc +gdbm -ipv6 -ldap +ssl -static +threads 0 kB

Total size of downloads: 0 kB


and for emerge -pv mod_php

Code:
[blocks B     ] >=net-www/apache-2.0.52-r3 (is blocking dev-php/mod_php-4.3.11)
[ebuild  N    ] net-www/apache-2.0.54-r2  +berkdb -debug +doc +gdbm -ipv6 -ldap +ssl -static +threads 0 kB
[ebuild  N    ] dev-php/mod_php-4.3.11  +X +apache2 +berkdb +crypt +curl -debug +doc -fdftk -firebird -flash -freetds -gd -gd-external +gdbm -gmp -hardenedphp -imap -informix -ipv6 +java +jpeg -kerberos -ldap -mcal -memlimit -mssql +mysql +nls -oci8 +odbc +pam +pdflib +png -postgres +qt -snmp +spell +ssl +tiff +truetype +xml2 -yaz 0 kB


As you can see that Apache 2.0.54-r2 is being blockecd by 2.0.52-r3. I have unemerged 2.0.53-r3

When i try to manully emerge 2.0.53-r3 i get this
Code:

*** You are emerging a masked package. It is MUCH better to use
*** /etc/portage/package.* to accomplish this. See portage(5) man
*** page for details.
>>> Waiting 10 seconds before starting...
>>> (Control-C to abort)...
Continuing... in: 10 9 8 7 6 5 4 3 2 1                                         -
!!! All ebuilds that could satisfy "net-www/gentoo-webroot-default" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-www/gentoo-webroot-default-0.1 (masked by: ~x86 keyword)
- net-www/gentoo-webroot-default-0.2 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "net-www/apache-2.0.52-r3" [ebuild])


I think there is some conf file left which is still bloking the new apache . How shall I proceed.
_________________
geoaxis
Back to top
View user's profile Send private message
Talrias
n00b
n00b


Joined: 23 May 2004
Posts: 32

PostPosted: Fri May 13, 2005 3:59 pm    Post subject: Reply with quote

Have a look at this thread. The general message is "wait a few days, it'll be fixed soon".

Chris
_________________
"if triangles had a god, He'd have three sides."
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri May 13, 2005 4:03 pm    Post subject: Reply with quote

Moved from Portage & Programming.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum