Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WoW install error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
kachaffeous
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2002
Posts: 86

PostPosted: Fri May 13, 2005 10:24 pm    Post subject: WoW install error Reply with quote

Hi all,

I finally decided to take the plunge and try WoW on linux and get rid of my XP box. When
I try to install WoW it errors out with:

wine /tmp/WoW Installer.exe ( a window pops up with Install WoW button)
click on button (nothing happens, following err on stdout)

err:win:CreateWindowExW bad class name L"RichEdit20A"



I've looked at the various post here and most of them deal with starting up the exe after it
is installed, but I can't get that far. This is what I have (done) so far:

emerged wine-20050111-r1
emerged ati-drivers (glxinfo |grep direct = direct rendering: Yes) (running in bigdesktop mode?)
glxgears = 19113 frames in 5.0 seconds = 3822.600 FPS
copied all 4 cd's to the /tmp/WoW
AMD64 (running 32bit Gentoo)
Radeon 9800

Thanks for any help, I would hate to reinstall windows to just load the game up and copy it
to my Linux partition.

EDIT:

I manually installed Wine CVS from today and can get a bit farther. I can click on Install and
a Licence Agreement Window pops up (it's blank though).
click on agree
Another window pops up called no name, and says installer can't be initialized.

STDOUT errors:
fixme:font:CreateScalableFontResourceW (1,0x6e3a6208,0x6e3a2388,(nil)): stub
fixme:richedit:RichEditANSIWndProc WM_SETFONT: stub
fixme:richedit:RichEditANSIWndProc EM_SETTEXTEX: stub
fixme:richedit:RichEditANSIWndProc WM_SETFONT: stub
fixme:richedit:RichEditANSIWndProc EM_GETOLEINTERFACE 0x77acf0d4: stub
fixme:richedit:IRichEditOle_fnGetClientSite stub 0x77c71bc0
fixme:ole:OleCreateStaticFromData (not shown), stub!
fixme:richedit:RichEditANSIWndProc EM_SETTEXTEX: stub
Back to top
View user's profile Send private message
teidon
Apprentice
Apprentice


Joined: 22 Apr 2005
Posts: 195
Location: Finland

PostPosted: Sat May 14, 2005 7:44 am    Post subject: Reply with quote

You need to have riched20.dll and riched32.dll in fake_c/windows/system to install WoW. You may have some more trouble patching WoW though. Look in this thread for further help.
Back to top
View user's profile Send private message
kachaffeous
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jun 2002
Posts: 86

PostPosted: Sun May 15, 2005 2:18 am    Post subject: Reply with quote

Quote:
You need to have riched20.dll and riched32.dll


Thanks Teidon, that was it.
Back to top
View user's profile Send private message
curtis119
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 2160
Location: Phoenix, AZ USA, North America, Earth, SOL System, Milky Way, The Universe, The Cosmos, and Beyond.

PostPosted: Wed Jun 15, 2005 6:18 pm    Post subject: Reply with quote

Moved from Gamers & Players to Duplicate Threads.

Please use the main WoW install and support thread. Thanks. https://forums.gentoo.org/viewtopic-t-246098.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum