Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless was working great, but then... [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nokilli
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 195

PostPosted: Fri May 13, 2005 10:51 pm    Post subject: Wireless was working great, but then... [SOLVED] Reply with quote

Wireless was working great, then all of the sudden it went flaky. Now I can't get it to work at all.

PowerBook Pismo 500MHz G3 w/512MB RAM. The Airport card is identified as eth1, so I symlink to /etc/init.d/net.eth0, and was able to start and stop using that script. I see how on the main wireless forums how everybody has a /etc/conf.d/wireless file, but emerging wireless-tools didn't give me one. I was however able to follow the PPC FAQ and got it working that way.

My connection lasted for about an hour last night before it gave out. Now I'm trying to get it going again and am having absolutely no success. I am repeating what I did last night EXACTLY. It isn't as if there's a lot to do. I am using a WEP key, if that matters, but I don't see how as IT WAS WORKING and the wireless access point requires the key.

The output iwconfig gives me is somewhat baffling. Sometimes it shows the address of the access point, other times it just gives me 44:44:44:44:44:44. The other interesting thing is that Link Quality is now zero (used to be around 70 I think). Now I have OS X on this machine and I just checked and the card is working there perfectly, so it's not like it just blew out or something like that.

Here is the output from iwconfig:

Code:
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11-DS  ESSID:"Fool on the Hill"  Nickname:"HERMES I"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 44:44:44:44:44:44
          Bit Rate:11 Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
          Retry limit:4   RTS thr:off   Fragment thr:off
          Encryption key:XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XX
          Power Management:off
          Link Quality=0/92  Signal level=134/153  Noise level=134/153
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

irlan0    no wireless extensions.


(of course I replaced my encryption key above with X's)

This is what ifconfig gives me:

Code:
eth1      Link encap:Ethernet  HWaddr 00:10:20:30:40:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:57


(again with a made-up HWaddr, I'm paranoid, what can I say?)

I have searched and searched and no one seems to be having this problem, once people get their wireless working they have no further issues. I have gone through all of the settings that iwconfig will accept, including setting sensitivity to all possible values as well as power management, rts, fragment. I have tried reducing the bit rate but it doesn't seem to take, that is, when I bring the interface down iwconfig will display the bit rate I set, but once I bring the interface up it goes back to 11MB.

Any ideas as all?

FWIW, the install on this machine is otherwise impeccible, except for alsa. Can't get that to work either, so I'm using oss.


Last edited by nokilli on Tue May 17, 2005 10:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Solra Bizna
n00b
n00b


Joined: 07 May 2005
Posts: 40

PostPosted: Tue May 17, 2005 4:30 pm    Post subject: Reply with quote

To get wireless working on my PowerBook, I added the following line to the net.eth1 rc script (which is a copy of net.eth0):
Code:
(sleep 1; /usr/sbin/iwconfig eth1 essid tejat enc0 [key removed]; route add default gw 192.168.0.1 dev eth1)
This goes immediately after the two ifconfig lines.
Also, sometimes I have to start up and stop eth0 and eth1 a few times in order to get them cooperating properly. /sbin/route is your friend.
-:sigma.SB
Back to top
View user's profile Send private message
nokilli
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 195

PostPosted: Tue May 17, 2005 7:15 pm    Post subject: Reply with quote

I did exactly what you said and now everything is working again!

Wow. I was just about to give up hope too.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum