Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of svgalib-1.9.19 fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Geministorm
n00b
n00b


Joined: 10 May 2005
Posts: 50
Location: Melbourne, FL USA

PostPosted: Mon May 16, 2005 2:02 pm    Post subject: emerge of svgalib-1.9.19 fails Reply with quote

Installing via Knoppix LiveCD onto an SATA drive. Stage2 install;

I follow the Alternate Installation method listed for using Knoppix and do a;

Code:
mount -o bind /proc /mnt/gentoo/proc


and then chroot into /mnt/gentoo, env-update and source /etc/profile, as mentioned in the handbook.

I follow with an emerge --sync and then update the USE variable in my /etc/make.conf.

I issue the emerge --emptytree system command but come to a grinding halt with;

Code:

emerge of svgalib-1.9.19 fails with

function kernel module configoption, line 114, exitcode 1
kernel has not been configured yet


Since the kernel hasn't been downloaded (gentoo-sources) and compiled yet, I'm wondering why I would be getting this error. Downloading and compiling the kernel is the next stage.....

Is there a way to overcome, bypass or solve this error?

-- BTW, I'm at work presently, so if anyone needs me to post more of the error or other diagnostic commands, I'll be available to do so at lunch....
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon May 16, 2005 2:07 pm    Post subject: Reply with quote

See here: https://forums.gentoo.org/viewtopic-t-310827-highlight-kernel+module+configoption.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Geministorm
n00b
n00b


Joined: 10 May 2005
Posts: 50
Location: Melbourne, FL USA

PostPosted: Mon May 16, 2005 2:13 pm    Post subject: Reply with quote

I had read that post when researching this problem...but didn't think it applied since I don't have a compiled kernel on the system yet.

Does this indicate that there will/should be a link between my Knoppix LiveCD /usr/src/ and my /mnt/gentoo/usr/src that is broken?

Thanks for the quick response. :)
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon May 16, 2005 2:20 pm    Post subject: Reply with quote

svga wants, for whatever reason, to read the kernel sources. Since it can't find those it complains. So, install the kernel sources first and possibly do a make mrproper and/or make menuconfig.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Geministorm
n00b
n00b


Joined: 10 May 2005
Posts: 50
Location: Melbourne, FL USA

PostPosted: Mon May 16, 2005 2:31 pm    Post subject: Reply with quote

nixnut,

Sounds reasonable. I'll just reverse the steps and download and configure the kernel first and then retry the, "emerge --emptytree system", unless someone sees a problem with taking that route...
Back to top
View user's profile Send private message
Geministorm
n00b
n00b


Joined: 10 May 2005
Posts: 50
Location: Melbourne, FL USA

PostPosted: Mon May 16, 2005 5:41 pm    Post subject: Reply with quote

Downloaded, configured and compiled 2.6.11-gentoo-r8, but it exited with an error.......hmmm, but the link was built in /usr/src/linux properly.

Did an "emerge --sync", and re-ran "emerge --emptytree system".....its currently working its way through the list. SVGAlib was item 22 of 124, so I had to head back to work and couldn't stay to find out if it worked or not.

If this doesn't work, I'm going to try another "work-around" that I saw;

Quote:

I have a better fix....

Code:
nano -w /usr/portage/media-libs/svgalib/svgalib-1.9.19-r3.ebuild


*find the line that says: sed -i '/^INSTALL_PROGRAM/s: -s :: ' Makefile.cfg
*change it to: sed -i '/^INSTALL_PROGRAM/s: -s:: ' Makefile.cfg

Code:
cd /usr/portage/media-libs/svgalib/
ebuild svgalib-1.9.19-r3.ebuild digest
emerge svgalib


of course for the emerge line, go ahead and emerge whatever it was that required svgalib. Dunno if this is a correct fix, as i know nothing of sed either, but it worked


And if that fails? Reformat, rebuild all of the disks and begin again. The weird thing is, the first time I went through this installation process, I got all of the way through, but installed Grub, and apparently didn't setup my SATA drive properly, as I got a kernel panic. Another re-install from scratch and I used LILO this time, but mis-labeled a drive and forgot to install WinXP first (silly me)....

If one of these works, I'll re-compile my kernel with the hopes that it doesn't return an error this time.
Back to top
View user's profile Send private message
curtis119
Bodhisattva
Bodhisattva


Joined: 10 Mar 2003
Posts: 2160
Location: Phoenix, AZ USA, North America, Earth, SOL System, Milky Way, The Universe, The Cosmos, and Beyond.

PostPosted: Mon May 16, 2005 5:41 pm    Post subject: Reply with quote

This topic has been covered so many times.

Pick one:

https://forums.gentoo.org/viewtopic-t-337952-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-310827-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-335135-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-334300-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-331550-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-332161-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-332655-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-332259-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-330843-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-299274-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-302982-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-130166-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-300460-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-300265-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-293346-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-292127-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-267135-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-247019-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-240844-highlight-svgalib.html
https://forums.gentoo.org/viewtopic-t-240710-highlight-svgalib.html
_________________
Gentoo: it's like wiping your ass with silk.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum