Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem emerging fam-2.7.0-r2 // ebuild broken ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
maxthree
n00b
n00b


Joined: 16 May 2005
Posts: 16

PostPosted: Tue May 17, 2005 6:05 pm    Post subject: problem emerging fam-2.7.0-r2 // ebuild broken ? Reply with quote

Hi,

I just installed gentoo on a new box.

Tried to emerge KDE.

During emerge of fam-2.7.0-r2 I get stuck in an infinite loop

<SNIP>
Waiting for fam.o.lock to be removed
Waiting for Client.o.lock to be removed
Waiting for fam.o.lock to be removed
Waiting for Client.o.lock to be removed
Waiting for fam.o.lock to be removed
Waiting for Client.o.lock to be removed
Waiting for fam.o.lock to be removed
<SNIP>


I found following in the newsgroups about this ....

[i]Scott Porter 15 jan 02:31 opties verbergen

Nieuwsgroepen: alt.os.linux.gentoo
Van: Scott Porter <incorr...@incorrect.invalid> - Berichten van deze auteur zoeken
Datum: Sat, 15 Jan 2005 01:31:45 +0000
Lokaal: za 15 jan 2005 02:31
Onderwerp: fam-2.7.0-r1 and fam-2.7.0-r2 ebuilds both broken.
Auteur beantwoorden | Doorsturen | Afdrukken | Afzonderlijk bericht | Origineel weergeven | Misbruik melden

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


These ebuilds are broken. While building, both end up in a loop waiting
for lock files (Client.o.lock and fam.o.lock) to be removed. Changing to
~ -j1 build results in infinite wait for Client.o.lock to be removed.
Also tried looking for these lock files, but none found in the entire
/var tree.


Presumably someone will actually test the -r3 ebuild to make sure it
works before release? ;-)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


iD8DBQFB6HKBlo3mAaHhimARAilWAJ­9kd6YR7s66r7H9Z/9Y5zlBnst93wCf­SBUR
tpVoQ/5bNZai5ATOPayAV1E=
=3q2g
-----END PGP SIGNATURE-----
[/i]


I found nothing relating to broken fam ebuild in the gentoo forums which is kinda strange.


Anyway, I'm stuck.

Can anybody tell me if there's a workaround for this prob ?
Back to top
View user's profile Send private message
maxthree
n00b
n00b


Joined: 16 May 2005
Posts: 16

PostPosted: Tue May 17, 2005 6:12 pm    Post subject: Reply with quote

some more info on this ...
OBITWO root # emerge --info fam
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11-gentoo-r8 i686)
=================================================================
System uname: 2.6.11-gentoo-r8 i686 AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 11 2005, 13:17:01)]
dev-lang/python: 2.3.4-r1
sys-apps/sandbox: [Not Present]
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils: 2.15.92.0.2-r1
sys-devel/libtool: 1.5.10-r4
virtual/os-headers: 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=i686 -pipe -02"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=i686 -pipe -02"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/mnt/cdrom"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups emboss encode foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl svga tcpd tiff truetype truetype-fonts type1-fonts vorbis xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Tue May 17, 2005 6:48 pm    Post subject: Reply with quote

Moved from Installing Gentoo. Please see and follow up to https://forums.gentoo.org/viewtopic-t-299454.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum