Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EBUILD] Error with app-editors/gedit-2.8.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
G F0rce 1
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2004
Posts: 115
Location: 51.418961, 5.500932

PostPosted: Sat May 21, 2005 7:17 am    Post subject: [EBUILD] Error with app-editors/gedit-2.8.3 Reply with quote

Hey guys,
My gentoo machine is up and running again but when updating world, I receive an error while emerging the new gedit. I uninstalled gedit so that I could continue updating but it still wants to update it. That's a strange thing isn't it?
Well the error is as following:
Quote:

/bin/sed: can't read /usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.4/libstdc++.la' is not a valid libtool archive

I really don't know what to do with this :( ...
_________________
Reinoud.net
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Sat May 21, 2005 11:51 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-318790.html
Back to top
View user's profile Send private message
G F0rce 1
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2004
Posts: 115
Location: 51.418961, 5.500932

PostPosted: Sat May 21, 2005 2:56 pm    Post subject: Reply with quote

Oh it doesn't work, i am trying the ohter solutions now but if i am right it should be this command:
Quote:

fix_libtool_files.sh /usr/${ERROR_ROOT_DIRECTORY}/${CHOST}/${GCC_VERSION}/libstdc++.la

Is that correct?
_________________
Reinoud.net
Back to top
View user's profile Send private message
G F0rce 1
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2004
Posts: 115
Location: 51.418961, 5.500932

PostPosted: Sun May 22, 2005 11:42 am    Post subject: Reply with quote

Can anybody help me out here, I really don't get it :) ...
_________________
Reinoud.net
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun May 22, 2005 11:54 am    Post subject: Reply with quote

Moved from Portage & Programming in favour of this FAQ: https://forums.gentoo.org/viewtopic-t-279020.html

In your case, I think the command you want to run is this:
Code:
fix_libtool_files.sh 3.3.4 --oldarch i386-pc-linux-gnu

_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum