Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xorg fails to build
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
TR08
n00b
n00b


Joined: 21 May 2005
Posts: 7

PostPosted: Sat May 21, 2005 6:59 pm    Post subject: [SOLVED] Xorg fails to build Reply with quote

I got distcc running after a clean restart, but I now run into the following problem:

When running emerge system, I get this message:

i686-pc-linux-gnu-gcc -o pswrap -O2 -march=pentium3 -fomit-frame-pointer -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w -L../../exports/lib main.o pswparser.o lexer.o pswdict.o pswfile.o systemnames.o psw.o pswstring.o pswsemantics.o -lfl -Wl,-rpath-link,../../exports/lib
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5-20050130/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lfl
collect2: ld returned 1 exit status
make[4]: *** [pswrap] Error 1
make[4]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config/pswrap'
make[3]: *** [../../config/pswrap/pswrap] Error 2
make[3]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib/dps'
make[2]: *** [includes] Error 2
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/lib'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2

My make.conf:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j12"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
FEATURES="distcc"
CCACHE_SIZE="512M"
USE="X gtk gnome alsa"k

emerge info:
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.10 i686)
=================================================================
System uname: 2.6.10 i686 Pentium III (Coppermine)
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.5 [2.3.5 (#1, May 21 2005, 15:55:21)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
dev-lang/python: 2.3.5
sys-apps/sandbox: [Not Present]
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.7.9-r1, 1.4_p6, 1.5, 1.9.5, 1.6.3, 1.8.5-r3
sys-devel/binutils: 2.15.92.0.2-r7
sys-devel/libtool: 1.5.16
virtual/os-headers: 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium3 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts crypt cups emboss encode foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl svga tcpd truetype truetype-fonts type1-fonts xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CBUILD, CTARGET, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

Does anyone know how to fix this, google is not getting me anywhere :roll:


Last edited by TR08 on Sat May 21, 2005 7:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Sat May 21, 2005 7:07 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-295915.html
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
TR08
n00b
n00b


Joined: 21 May 2005
Posts: 7

PostPosted: Sat May 21, 2005 7:20 pm    Post subject: Reply with quote

It seems I am missing flex, I am currently retrying to emerge sytem.
If this is the case, Flex should have been build/unpacked during stage 1 or the bootstrap process. I have filed a bug report about it :)
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Sat May 21, 2005 7:25 pm    Post subject: Reply with quote

No need to re-emerge system. Just
Code:
emerge --oneshot flex
and resume X.org.
It's already been bugreported a few times.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
TR08
n00b
n00b


Joined: 21 May 2005
Posts: 7

PostPosted: Sat May 21, 2005 7:31 pm    Post subject: Reply with quote

Probably the error was because I typed:
emerge system
Instead of:
emerge --emptytree system

I'm feeling a bit :oops: now

Ah well, there is a first time for everything.....
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Sun May 22, 2005 8:52 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Fresh Install, can't emerge xorg-x11! [SOLVED]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum