Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg rage128 troubles and mouse question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
fluffyzzz
n00b
n00b


Joined: 21 May 2005
Posts: 11

PostPosted: Tue May 24, 2005 5:17 am    Post subject: Xorg rage128 troubles and mouse question Reply with quote

Sorry to post a newb, getting-started, speed-bump problem, but I'm not sure in what direction to go from here.

And before anyone might make this suggestion, i'd rather not use genkernel, i'm more interested in learning how to set this straight.

When I run Xorg -config on my sawtooth G4 with rage128 pro I get expelled with

(EE) Failed to load module "fbdev" (once-only module, 0)
(++) Using config file: "/root/xorg.conf.new"
(EE) R128(0): Cannot read V_BIOS (5)

and also this

Xorg is not able to detect your mouse.
Edit the file and correct the Device.

As far as the R128 drivers go, they're definitely all switched on. I recently reviewed the config file for the liveCD genkernel, making sure I had everything turned on what I needed, but it's no good.

On a less important note, I can't for the life of me figure out how to get a plain 'ol usb mouse working.

thanks o mighty gentoo gods
Back to top
View user's profile Send private message
azlan
Guru
Guru


Joined: 11 Nov 2002
Posts: 381
Location: Seattle WA USA

PostPosted: Tue May 24, 2005 8:13 am    Post subject: Reply with quote

Nothing to worry about. Your FB (frame buffer device) is probably not configured in the kernel. Device drivers >> Graphics support >> support for frame buffer devices.

But to be hones you don't need that to get X going the frame buffer is a very low level driver for your graphics card. Just use xorgconfig as the command and follow the instructions. You may have to do it more than once and it isn't as easy but it will get you going. GL!
_________________
there is no crazy, only violet and non violet..
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue May 24, 2005 10:47 am    Post subject: Reply with quote

Check your mouse device in your xorg.conf. If you're using udev, the best way to make sure that any attached mice work is to have Xorg watch /dev/input/mice for input. As for the R128 support, check the FAQ and if you're still having problems, feel free ask here.

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum