Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pstoedit-3.40 compile error (x86) [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dmvianna
l33t
l33t


Joined: 22 Mar 2004
Posts: 742
Location: Down Underland

PostPosted: Thu May 26, 2005 4:55 am    Post subject: pstoedit-3.40 compile error (x86) [solved] Reply with quote

I'm emerging inkscape 0.41-r1 and pstoedit is a dependency. Actually, it is a plugin that I want to use. But I keep getting:

Code:
/bin/sh ../libtool --mode=link g++  -g   -o libp2edrvmagick++.la -rpath /usr/lib/pstoedit -no-undefi                                    ned -lMagick++ -lWand -lMagick -ltiff -lfreetype -ljpeg -lXext -lSM -lICE -lX11 -lXt -lbz2 -lz -lpth                                    read -lm -lpthread -L/usr/lib -L/usr/X11R6/lib -lfreetype -lz -L/usr/lib  -module drvmagick++.lo ini                                    tlibrary.lo -L. libpstoedit.la
grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or director                                    y
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la' is not a valid libtool archiv                                    e
make[1]: ** [libp2edrvmagick++.la] Erro 1
make[1]: Leaving directory `/var/tmp/portage/pstoedit-3.40/work/pstoedit-3.40/src'
make: ** [all-recursive] Erro 1

!!! ERROR: media-gfx/pstoedit-3.40 failed.
!!! Function src_compile, Line 49, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


Any ideas? I've tried to emerge (~x86) libstdc++-v3 to try to fix that, but it was useless. :?
_________________
Proprietary is theft. Pierre-Joseph Proudhon, if he had a chance
Powered by a MacBook Pro


Last edited by dmvianna on Thu May 26, 2005 7:27 am; edited 2 times in total
Back to top
View user's profile Send private message
hjnenc
Veteran
Veteran


Joined: 15 Aug 2004
Posts: 1599
Location: Vienna, Austria

PostPosted: Thu May 26, 2005 5:22 am    Post subject: Reply with quote

See this sticky thread https://forums.gentoo.org/viewtopic-t-278673.html (or one of the many others about this problem).
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Thu May 26, 2005 9:14 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads. Please see the thread mentioned above as well as the links in the first post.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum