Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iBook G3. Sound.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
llywelyn
n00b
n00b


Joined: 30 Sep 2004
Posts: 45

PostPosted: Sat May 28, 2005 12:14 am    Post subject: iBook G3. Sound. Reply with quote

Sound doesn't work correctly. :-(

It kinda works though. Most programs can use it, although there is no way to change the volume or mute it, using any control.

Also, xine won't play any sound, saying it I have no alsa cards, which is funny, because I don't have OSS support compiled in the kernel at all, but I have all the alsa options enabled.

Sound on Linux has always automagically worked, so I really don't have a clue what I'm doing.

I know that sound CAN work correctly, because on Yellow Dog Linux (with one singel config file hack) the sound worked just fine.

SO

I don't know how the sound configuration is defined on Linux (other than kernel config options), but I was wondering if it was possible for someone else, who has a similar iBook, and who has sound working pretty well, to post their config files (or whatever) so that I could clone their setup.

My iBook's model is listed (as well as I can define it) in my signature.


Thanks! :-)
_________________
Estoy apesadumbrado para mi Español ... estoy practicando ...
iBook Dual-USB G3/800MHz 640 MB RAM
OS 10.4 / Gentoo 2005.0 / NetBSD 2.1
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Mon May 30, 2005 12:33 am    Post subject: Reply with quote

I think you have to open amixer and unmute something; I forget what but change your levels in there. Maybe search these boards for 'alsa mute ppc' or something similar.
Back to top
View user's profile Send private message
psyfer
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2004
Posts: 99
Location: Novato, CA

PostPosted: Mon Jun 06, 2005 1:47 am    Post subject: Reply with quote

I had a problem where my sound wouldnt work at all and i emerge'd pbbuttonsd and was able to turn up the sound using the keyboard. That could be your problem.
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Wed Sep 07, 2005 9:28 pm    Post subject: Reply with quote

My ibook needs pbbbuttonsd running and also the module i2c_keywest in order to control the sound by the keyboard.

I would like to use this subject for general sound on iBookG3 question:
Which output module gives the best performance?
Neither gmplayer nor xine play fine with alsa. The sound is very choppy, too much to watch a movie. I noticed that esound (which I use now) gives a much better performance, also sdl. Why? Don't they use alsa themselves?
So far mplayer, xine and also xmms have support for esound. What about applications without support? I still have sound problems (alsa) with linphone, the only telephony solution for ppc so far.

Besides playing more than one source doesn't work.
mplayer -ao alsa:device=dmix alert.wav only plays noise.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
llywelyn
n00b
n00b


Joined: 30 Sep 2004
Posts: 45

PostPosted: Wed Sep 07, 2005 11:09 pm    Post subject: Reply with quote

I finally ended up going OSS all the way ... OSS works fine, although I think it also suffers from not being able to play more than one sound at a time. (I think ... that doesn't happen very often ...)

So far every media app I've used has worked with OSS, with the single exception of Timidity.
_________________
Estoy apesadumbrado para mi Español ... estoy practicando ...
iBook Dual-USB G3/800MHz 640 MB RAM
OS 10.4 / Gentoo 2005.0 / NetBSD 2.1
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Tue Sep 13, 2005 7:28 pm    Post subject: Reply with quote

Which "player" do you use for console output? kismet for example wants a /usr/bin/play, which is masked. So I was using mplayer. But since the last update, mplayer stops after playing 0.5 sec with "alsa-uninit: pcm closed". The same with -ao esd.
alsaplayer plays, but sounds awful.
Which player is there to use??

I also need more than one sources playing at the same time, in order to get kismet talking by festival and also making sounds.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
llywelyn
n00b
n00b


Joined: 30 Sep 2004
Posts: 45

PostPosted: Wed Sep 14, 2005 2:46 am    Post subject: Reply with quote

Hmmm ... I dunno what it does, but I seem to have a /usr/bin/play as well.

Dunno where it came from ... as a totally random guess, have you tried installing xine and xine-ui?
_________________
Estoy apesadumbrado para mi Español ... estoy practicando ...
iBook Dual-USB G3/800MHz 640 MB RAM
OS 10.4 / Gentoo 2005.0 / NetBSD 2.1
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Wed Sep 14, 2005 3:11 pm    Post subject: console play? Reply with quote

What is the name of the ebuild? splay is masked and plays only a click. plaympeg gives the error message Fatal signal: Segmentation Fault (SDL Parachute Deployed).
xine ist not the best for console sound.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
llywelyn
n00b
n00b


Joined: 30 Sep 2004
Posts: 45

PostPosted: Wed Sep 14, 2005 6:51 pm    Post subject: Reply with quote

I dunno where it came from ... it's just there ...
_________________
Estoy apesadumbrado para mi Español ... estoy practicando ...
iBook Dual-USB G3/800MHz 640 MB RAM
OS 10.4 / Gentoo 2005.0 / NetBSD 2.1
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Mon Nov 14, 2005 9:41 pm    Post subject: Reply with quote

Which is the best way now to play more than one source on my iBook?
artsd, esd, or even jackd? latency is not hat important but maybe jackd is eventhough a light weight daemon to do it? A german article in linux-magazin.
Not all applications have support for these daemons. I just want to hear signals from chat, im, ... while playing music
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
kludge
n00b
n00b


Joined: 11 Nov 2005
Posts: 8

PostPosted: Mon Nov 14, 2005 10:25 pm    Post subject: Reply with quote

the best way is to get sound running with alsa, make sure that alsa is configure with "dmix," and use that as the output device for your programs.

google "dmix", or just search these forums. you'll find what you're looking for. of course, not all programs play that nicely with dmix. for instance, i can't figure out where in thunderbird to tell it that i want it to use dmix and not pcm. but xmms and gaim play together quite nicely.
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Wed Jan 31, 2007 10:50 pm    Post subject: Reply with quote

Is this dmix config ok for the iBook?

Currently I have massiv problems with alsa sound on the iBook. Alsa was working but sometimes it crashed. Now even setting the volume by pbbuttonsd blocks the soundcard. aplay says:
Code:
ALSA lib pcm_dmix.c:864:(snd_pcm_dmix_open) unable to open slave


The FAQ tells to build the alsa module inside the kernel instead of modules. But as for modules I'm able to unload and reload them if alsa crashes (at least every day).
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
buddha007
n00b
n00b


Joined: 22 Jan 2007
Posts: 21
Location: London

PostPosted: Sun Feb 04, 2007 12:17 pm    Post subject: Reply with quote

have you followed the steps in http://www.gentoo.org/doc/en/alsa-guide.xml?

there's quite a few steps to follow, but for starters, try emerging alsa-utils
Code:
emerge alsa-utils
and run alsamixer
Code:
alsamixer

_________________
Windows?? I'd rather rub my nostrils down a cactus :)
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Sun Feb 04, 2007 1:10 pm    Post subject: Reply with quote

I figured out that gtkpbbuttonsd was the cause for the blockage.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum