Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
internet doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
BlackWolf2k5
n00b
n00b


Joined: 26 May 2005
Posts: 51

PostPosted: Sat May 28, 2005 4:31 pm    Post subject: internet doesn't work Reply with quote

hi,
i finally made it. i installed gentoo. now i want to install X but when i execute
emerge Xorg-X11
i get that error after a while:

make[5]: *** [geometry.dir] Illegal instruction
make[5]: *** Deleting file geometry.dir
make[5]: Leaving directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/programs/xbccomp/geometry'
make[4]: *** [all] Error 2
make[4]: Leaving directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/programs/xbccomp'
make[3]: *** [all] Error 2
make[3]: Leaving directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/programs'
make[2]: *** [all] Error 2
make[2]: Leaving directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make[1]: *** [World] Error 2
make[1]: Leaving directory '/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make : *** [World] Error 2
!!! Error: x11-base/xorg-x11-6.8.2-r1 failed
!!! Function build, Line 954, Exitcode 2
!!! make World failed

i also noticed that my internet doesn't work. after chrooting it worked fine but now it doesn't work. i also get this message when booting:
"Problem starting needed services: netmount was not started"
maybe that has something to do with that?
i should note that i have a router and that i do have installed DCHPCD.

please help
thx bw
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat May 28, 2005 4:36 pm    Post subject: Reply with quote

That's two problems.
About emerging xorg: post the output of emerge info, since that will tell us more about your system configuration.

The network problem:
Check you have the file /etc/resolv.conf (not resolve.conf)
What is the output of ifconfig -a?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
BlackWolf2k5
n00b
n00b


Joined: 26 May 2005
Posts: 51

PostPosted: Sat May 28, 2005 5:26 pm    Post subject: Reply with quote

ok, first: thanks for the fast reply.
second: /etc/resolv.conf does exist
then the output of emerge info:

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11-gentoo-r9 i686)
==================================================================
System uname: 2.6.11-gentoo-r9 i686 AMD Athlon(tm) Processor
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 10 2005, 20:47:05)]
dev-lang/python: 2.3.4-r1
sys-apps/sandbox: [Not present]
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.79-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils: 2.15.92.0.2-r1
sys-devel/libtool: 1.5.10-r4
virtual/os-headers: 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-match=athlon-xp -02 -mcpu=i686 -fomit-frame-pointer"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/shre/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS=-march=athlon-xp -02 -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portages"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups dvd emboss encode foomaticdb fortran gdbm gif gpm gtk2 imlib ipub jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python qt qucktime readline sdl spell ssl tcpd truetype truetype-fonts type1-fonts xml2 xmms xv 2lib userland_GNU kernel_linux elibc_glibc"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, CDFLAGS, LINGUAS, PORTDIR_OVERLAY

so *groan* ... and finally the output of ifconfig -a:
lo link encap: local loopbkack
inet addr: 127.0.0.1 Mask 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric: 1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0
RX bytes:0 (0.0b) TX bytes:0 (0.0b)
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat May 28, 2005 5:40 pm    Post subject: Reply with quote

Quote:
CFLAGS="-match=athlon-xp -02 -mcpu=i686 -fomit-frame-pointer"

Change -match in -march and make sure your athlon cpu is indeed an athlon-xp
Change the -02 in -O2

Network:
Looks like eth0 is not known so you probably are missing the driver for it in your kernel
Find out which device you have with lspci | grep eth and then enable the driver for it in your kernel:
# cd /usr/src/linux
# make menuconfig
enable the driver as a module and remember the name the module will have (look in the helps screen for the name)
# make modules
# make modules_install

or build it into the kernel:
# make
# mount /boot
# cp /usr/src/linux/arch/i386/bzImage /boot/kernel-2.6.11-whatever

If you just build it as a module you should be able to load it after modules_install with modprobe modulename
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
BlackWolf2k5
n00b
n00b


Joined: 26 May 2005
Posts: 51

PostPosted: Sat May 28, 2005 5:49 pm    Post subject: Reply with quote

first that 02 is an O2 i just typed it wrong :D
then: lspci | grep eth does not return anything.

i try emerge xorg-x11 at the moment (got a tip in another forum - i shall change -march=athlon-xp in -match=athlon) but when it's finished (or when it's not) i try activating the module in the kernel ... i will let you know the results.

edit: well, emerge xorg-x11 seems to work now. but the installer has to download some stuff and unfortunatly he can't do that because my internet still doesn't work ... where exactly do i have to look in the menuconfig-menu (2.6.x kernel)? that menu is so big it's really hard to find something if you dont know where to look.
Back to top
View user's profile Send private message
BlackWolf2k5
n00b
n00b


Joined: 26 May 2005
Posts: 51

PostPosted: Sat May 28, 2005 9:18 pm    Post subject: Reply with quote

usr/src/linux/arch/i386/bzImage
doesn't exists. does that have something to do with it?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun May 29, 2005 12:05 pm    Post subject: Reply with quote

BlackWolf2k5 wrote:
usr/src/linux/arch/i386/bzImage
doesn't exists. does that have something to do with it?

:oops: My mistake. Try cp /usr/src/linux/arch/i386/boot/bzImage /boot/kernel-2.6.11-r7 (if your current kernel is 2.6.11-r7 too)
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
BlackWolf2k5
n00b
n00b


Joined: 26 May 2005
Posts: 51

PostPosted: Sun May 29, 2005 3:12 pm    Post subject: Reply with quote

well thanks for the help i finally got it: it was a problem in the config-file i typed "dhcp " instead of "dhcp"
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Jul 14, 2005 1:50 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads in favour of https://forums.gentoo.org/viewtopic-t-332982.html
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum