Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wget resolves to 1.0.0.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
dirtboy
Apprentice
Apprentice


Joined: 12 Dec 2002
Posts: 263
Location: Pascagoula, MS

PostPosted: Sun May 29, 2005 6:11 pm    Post subject: wget resolves to 1.0.0.0 Reply with quote

I am having a weird problem here. I don't know exactly what is causing it, but the symptoms are that wget resolves any address to 1.0.0.0. This happens whe I am trying to emerge packages or when running mythfilldatabase from MythTV. The strange thing is that I can then ping the address that wget is trying to resolve and it will resolve the correct IP. wget will then be able to resolve that address for a little while, but it will eventually mess up again in a minute or two. Here's some output:

Code:
Fetching data for Thu Jun 9 2005
Retrieving datadirect data...
Grabbing data for Sun May 29 2005 offset 11
From : Thu Jun 9 05:00:00 2005 To : Fri Jun 10 05:00:00 2005 (UTC)
--12:59:28--  http://datadirect.webservices.zap2it.com/tvlistings/xtvdService
           => `-'
Resolving datadirect.webservices.zap2it.com... 206.18.98.160
Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Connecting to datadirect.webservices.zap2it.com[206.18.98.160]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/xml]

    [                         <=>                                                                                                                            ] 137,957       10.45K/s

12:59:55 (6.47 KB/s) - `-' saved [137,957]

Your subscription expires on 08/31/05 00:47:04
Grab complete.  Actual data from Thu Jun 9 05:00:00 2005 to Fri Jun 10 05:00:00 2005 (UTC)
Clearing data for source...
Clearing from Thu Jun 9 00:00:00 2005 to Fri Jun 10 00:00:00 2005 (localtime)
Data for source cleared...
Main temp tables populated.  Updating myth channels...
Updating icons for sourceid: 1
Channels updated..  Updating programs...
Fetching data for Fri Jun 10 2005
Retrieving datadirect data...
Grabbing data for Sun May 29 2005 offset 12
From : Fri Jun 10 05:00:00 2005 To : Sat Jun 11 05:00:00 2005 (UTC)
--13:00:03--  http://datadirect.webservices.zap2it.com/tvlistings/xtvdService
           => `-'
Resolving datadirect.webservices.zap2it.com... 1.0.0.0
Connecting to datadirect.webservices.zap2it.com[1.0.0.0]:80... failed: Connection timed out.
Retrying.

--13:03:14--  http://datadirect.webservices.zap2it.com/tvlistings/xtvdService
  (try: 2) => `-'
Connecting to datadirect.webservices.zap2it.com[1.0.0.0]:80...


Notice how wget is able to route to datadirect.webservices.zap2it.com, then it starts routing incorrectly. I can get around the problem in portage by using prozilla instead of wget, but I can't get around it in mythtv. This is over a wireless connection above, but the same thing happens over ethernet.

Since this only happens in wget, I think this is a problem with that program only, since ping and prozilla work fine. Anyone ever seen this before?
_________________
Your sig is better than my sig.
Homebrew everything!
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Mon May 30, 2005 4:39 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-2358802.html#2358802
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Sun Jul 03, 2005 8:01 am    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum