Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Does it work on a new PowerMac dual G5?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
bazzalisk
n00b
n00b


Joined: 30 May 2005
Posts: 7
Location: London, UK, EU

PostPosted: Mon May 30, 2005 1:03 pm    Post subject: Does it work on a new PowerMac dual G5? Reply with quote

I'm a long time Gentoo/x86 user considering buying a dual 2.3GHz PowerMac G5, and was wondering if Gentoo/PPC64 will support these?

(I did a websearch for "Linux PowerMac G5" and found amongst other things a yellowdog site claiming that some of the new G5 PowerMacs won't boot Linux - si this the case?)
_________________
James P. Barrett
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Mon May 30, 2005 1:23 pm    Post subject: Reply with quote

surfing the web to find consumation law in my country...i've find a news telling that linus has one
so it sould work also on gentoo(he has linux on it)
Back to top
View user's profile Send private message
bazzalisk
n00b
n00b


Joined: 30 May 2005
Posts: 7
Location: London, UK, EU

PostPosted: Mon May 30, 2005 4:57 pm    Post subject: Reply with quote

Near as I can tell Linus has Linux running on an older Dual G5, rather than one of the latest ones which Yellowdog seem to think there is an issue with.
_________________
James P. Barrett
Back to top
View user's profile Send private message
GNUtoo
Veteran
Veteran


Joined: 05 May 2005
Posts: 1919

PostPosted: Mon May 30, 2005 8:17 pm    Post subject: Reply with quote

a dual g5 2ghz is not so old
by the way has he bought also mac or is there a standard return procedure for this software
Back to top
View user's profile Send private message
mfproroc
n00b
n00b


Joined: 28 Oct 2004
Posts: 5

PostPosted: Tue May 31, 2005 4:30 pm    Post subject: Reply with quote

i have a dual 2.5 w/ the radeon 9600 and it's running fine - even have the sound sort of working. Bigest difficuly was getting the right version of X (6.8.2-r2) with the proper timings, etc for the apple 20 inch.

By far one of the nicest machines I've worked on on linux - the kernel is very stable (2.6.12-rc4 w/ udev) and I have been getting excellent performance for math and gcc out of it. I'd actually put it up there with (and possiply above) my xeons and opteron boxes.

The 512k cache per processor is the only thing that I'd like to see improved 1-4mb would be ideal.

If you need any help email me - mfproroc@sadminl.org and I can post some configs.

MFP
Back to top
View user's profile Send private message
justin_gentooing
n00b
n00b


Joined: 10 Jun 2005
Posts: 4

PostPosted: Fri Jun 10, 2005 10:13 pm    Post subject: Not working yet, but... Reply with quote

I have the new G5 2.3GHz, and no it doesnt work, the installer oopses, with Open Firmware issues.

I see this from yellowdog though -

http://lists.terrasoftsolutions.com/pipermail/yellowdog-announce/2005-June/000092.html

Anyone know how to get the source for their fixes?

Its kind of annoying, have had to port software to MacOS (which is good portability practise) and have managed to make the environment for Unixy, but I do want Linux running...
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Jun 10, 2005 10:26 pm    Post subject: Reply with quote

See this topic for a possible resolution: https://forums.gentoo.org/viewtopic-t-344776.html
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
justin_gentooing
n00b
n00b


Joined: 10 Jun 2005
Posts: 4

PostPosted: Fri Jun 10, 2005 10:39 pm    Post subject: I dont think its that Reply with quote

Will try shortly - look slike it is that (its at I2C init)
Back to top
View user's profile Send private message
justin_gentooing
n00b
n00b


Joined: 10 Jun 2005
Posts: 4

PostPosted: Fri Jun 10, 2005 11:11 pm    Post subject: that fixes it... Reply with quote

yes that great, boots fine now.

Time to install another hard drive and let the thing work at some compiling...

Thans very much for the link.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum