Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg, the .conf file and an ATI graphics card.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
richame
n00b
n00b


Joined: 16 Jun 2003
Posts: 9

PostPosted: Thu Jun 02, 2005 12:49 am    Post subject: Xorg, the .conf file and an ATI graphics card. Reply with quote

I'm getting desperate. I've got my first PPC Gentoo up and running. I am using a G4 Cube (with ATI Rage 128 video card) and an Apple Studio Diplay (17" CRT).

My (current) problem is centered around Xorg, the .conf file and the ATI graphics card.

I've read many X11 posts and recompiled my genkernel to include the ATI RAGE 128 (16mb) options. I've tried Xorg -configure & xorgconfig (it recomends: Horizonatl 78-82 and Vertical 60-60). If I accept the default device driver in my xorg.conf - fbdev, it doesn't run, but if I knock it's recommended 16 bit default back to 8 bit I can get startx to run .

When I change the device driver to r128 (or ati or radeon), it freezes (black screen).

I've also read:

Gentoo 2005.0 Handbook - ppc version
&
Gentoo Linux/PowerPC Frequently Asked Questions
including the "How can I enable Direct Rendering (DRM) on rage128 or radeon cards?" (i edited my genkernel)
&
The X Server Configuration HOWTO
&
Gentoo Linux ATI FAQ

Still no luck.

Any help would be great,
Matt
Back to top
View user's profile Send private message
kcy29581
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 284
Location: England

PostPosted: Thu Jun 02, 2005 1:19 am    Post subject: Reply with quote

I'm not sure how to help exactly... but if I'm right you have a serious mistke when choosing the Vertical parameters as 60-60. That's basically not giving it a range.

If you don't have a manual, the way I figure out my rates is with a knoppix cd. Always detects things perfectly
_________________
There is no spoon...

Oh, and it's WINDOWS not Winblowz for those who can't spell
Back to top
View user's profile Send private message
richame
n00b
n00b


Joined: 16 Jun 2003
Posts: 9

PostPosted: Thu Jun 02, 2005 1:51 am    Post subject: Reply with quote

The timing I used were generated by xorgconfig.

I've tried Ubuntu (prefer Gnome) on my Mac laptop - works great, but it doesn't work on the G4 cube. The screen goes blank after the kernel (?) is chosen (default - live).

I haven't hunted for a ppc Knoppix in a while, I'll check it out and get back.

Thanks for the post - BTW I had a similar idea when I tried Ubuntu

Matt
Back to top
View user's profile Send private message
orvtech
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2004
Posts: 115
Location: US. Florida

PostPosted: Tue Jun 03, 2008 2:08 pm    Post subject: Reply with quote

sorry for bumping this but can you post your xorg.conf ?
_________________
http://orvtech.com
http://www.linuxevolution.org
Back to top
View user's profile Send private message
oswaldkelso
n00b
n00b


Joined: 15 Feb 2007
Posts: 10

PostPosted: Fri Jun 06, 2008 7:14 pm    Post subject: Reply with quote

Not sure if this will help but it may give you some pointers

http://ubuntuforums.org/showthread.php?t=3723
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Jun 07, 2008 4:27 am    Post subject: Reply with quote

Have you tried xac? Emerge xac and try that, it should help you setup X.org for all PPC Macs.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum