Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerging errors while migrating to 2005.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
XXD
n00b
n00b


Joined: 11 Jul 2003
Posts: 33

PostPosted: Sun Jun 05, 2005 2:00 pm    Post subject: Emerging errors while migrating to 2005.0 Reply with quote

Hello all,

I started migrating my old 2004.x gentoo system to 2005.0 by following the instructions. I upgraded portaged first and then I was doing emerge system with,

Code:
USE="-fortran unicode sftplogging" emerge --verbose system


and when I came back my system was bork with the following error on screen.

Code:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/libtool-1.5.16/work/libtool-1.5.16/config.log

!!! ERROR: sys-devel/libtool-1.5.16 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.


And I can't even use emerge anymore. When I just type emerge or emerge system, I get this error.

Code:
/usr/bin/python: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory


Any ideas on how to fix this? Thanks a lot,
XXD
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sun Jun 05, 2005 2:02 pm    Post subject: Reply with quote

Hi.

You should search the forums before posting!
If you look a few posts before yours, you'll see several references to this problem and its solution.
Back to top
View user's profile Send private message
XXD
n00b
n00b


Joined: 11 Jul 2003
Posts: 33

PostPosted: Sun Jun 05, 2005 2:14 pm    Post subject: Reply with quote

Yeah I did search, but I was searching for "libstdc++.so.5" which didn't bring up the answer because these folks were having the same problem with "libstdc++.so.6" instead. But thanks, I found it and it seems to have fixed it.
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sun Jun 05, 2005 2:18 pm    Post subject: Reply with quote

OK.

Sometimes it helps looking at the first page of the forum when the search doesn't find anything useful.
If your problem has been solved, please add [solved] to the title of the thread.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Sun Jun 05, 2005 4:03 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic-t-345046.html

Moved from Installing Gentoo.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum