Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
evolution and acess violations
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rikell42
Tux's lil' helper
Tux's lil' helper


Joined: 25 Aug 2004
Posts: 88
Location: portland orgeon

PostPosted: Mon Jun 06, 2005 5:30 am    Post subject: evolution and acess violations Reply with quote

please help with this annoying problem. I have tryed deleating the tmp file that is listed at the end of this file and that did not work. The file just made another copy of itself.

Code:

  usr/lib/evolution/2.2/evolution-addressbook-importers/libevolution-addressboo
k-ldif-importer.so
   usr/lib/evolution/2.2/evolution-addressbook-importers/libevolution-addressboo
k-vcard-importer.so
   usr/lib/evolution/2.2/libevolution-mail-importers.so.0.0.0
   usr/libexec/evolution/2.2/evolution-addressbook-export
   usr/libexec/evolution/2.2/evolution-alarm-notify
   usr/libexec/evolution/2.2/killev
>>> Completed installing evolution-2.2.1.1 into /var/tmp/portage/evolution-2.2.1
.1/image/

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-mail-client_-_evolution-2.2.1.1-21256.log"

open_wr:   /var/lib/scrollkeeper/scrollkeeper_docs
open_wr:   /var/lib/scrollkeeper/scrollkeeper_docs
--------------------------------------------------------------------------------
Back to top
View user's profile Send private message
rikell42
Tux's lil' helper
Tux's lil' helper


Joined: 25 Aug 2004
Posts: 88
Location: portland orgeon

PostPosted: Mon Jun 06, 2005 5:44 am    Post subject: Reply with quote

I found out that evolution is now broken.
Code:
bash-2.05b# evolution
evolution: error while loading shared libraries: libecal.so.6: cannot open shared object file: No such file or directory


I tryed remergeing evolution 2.0.4 and got this error.

Code:
checking EVOLUTION_LIBS... -pthread -Wl,--export-dynamic -lgthread-2.0 -lgal-2.2
 -lgal-a11y-2.2 -lgnomecanvas-2 -lglade-2.0 -lgnomeprint-2-2 -lpangoft2-1.0 -lgt
k-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -
lart_lgpl_2 -lxml2 -lpthread -lz -lm -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ld
l -lglib-2.0 
checking for libegroupwise-1.0 >= 1.0.4... Package libegroupwise-1.0 was not fou
nd in the pkg-config search path.
Perhaps you should add the directory containing `libegroupwise-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libegroupwise-1.0' found

configure: error: Library requirements (libegroupwise-1.0 >= 1.0.4) not met; con
sider adjusting the PKG_CONFIG_PATH environment variable if your libraries are i
n a nonstandard prefix so pkg-config can find them.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/evolution-2.0.4/work/evolution-2.0.4/config.log

!!! ERROR: mail-client/evolution-2.0.4 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.



so a bit more info hopefully this will help
Back to top
View user's profile Send private message
rikell42
Tux's lil' helper
Tux's lil' helper


Joined: 25 Aug 2004
Posts: 88
Location: portland orgeon

PostPosted: Mon Jun 06, 2005 6:19 am    Post subject: Reply with quote

I got evolution running again by downgrading evolution-data-server to 1.0.4

upgrading to that new evolution 2.2.1.1 is still underway. let you know how it goes
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Jun 06, 2005 10:44 am    Post subject: Reply with quote

hum .... got that exact same problem, i tried other thing i tried changing perms on it i now left it compiling had to go to school but in case it work / doesnt work ill post the result of it later , btw wich evolution version did you ended up with ??
2.2.1.1 ? ?
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
tuxian
l33t
l33t


Joined: 26 Jan 2004
Posts: 766
Location: Austria

PostPosted: Mon Jun 06, 2005 12:32 pm    Post subject: Reply with quote

I've the same problem after updating many gnome-ebuilds.

evolution-2.2.1.1 won't compile.
Back to top
View user's profile Send private message
jrabid
n00b
n00b


Joined: 06 Jun 2005
Posts: 1

PostPosted: Mon Jun 06, 2005 12:34 pm    Post subject: Reply with quote

I had a similar error report compiling a2ps.
My solution was to turn off one of the USE flags for that package - tetex.
You might try turning off the flags one by one in package.use until find the abusing one.
It could be something else.
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Jun 06, 2005 12:51 pm    Post subject: Reply with quote

ok the perms didnt do anything , i am now trying other thing meanwhile here is the potential vause of it !
https://bugs.gentoo.org/show_bug.cgi?id=92920

Please guys test and then report !!
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
Baal Sebub
n00b
n00b


Joined: 29 Oct 2004
Posts: 3

PostPosted: Mon Jun 06, 2005 12:52 pm    Post subject: Reply with quote

This is a manifestation of bug #92920

https://bugs.gentoo.org/show_bug.cgi?id=92920
Back to top
View user's profile Send private message
tuxian
l33t
l33t


Joined: 26 Jan 2004
Posts: 766
Location: Austria

PostPosted: Mon Jun 06, 2005 7:22 pm    Post subject: Reply with quote

tuxian wrote:
I've the same problem after updating many gnome-ebuilds.

evolution-2.2.1.1 won't compile.


Code:
SANDBOX_DISABLED=1 emerge foomatic


This solved my problem ;)
Back to top
View user's profile Send private message
mascanho
Veteran
Veteran


Joined: 21 Dec 2004
Posts: 1241
Location: On my Bmx Bike on a Concrete Park Flatlanding ...

PostPosted: Mon Jun 06, 2005 8:32 pm    Post subject: Reply with quote

Code:

emerge sync

solved it it was an ebuild error !! ( i think )
_________________
Flatland Life is a Choice !
emerge avatar
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Tue Jun 07, 2005 10:30 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of https://forums.gentoo.org/viewtopic-t-346138.html as it doesn't contain any advice on disabling the sandbox even if the sandbox is far from perfect.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum