Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Why did emerging start becoming so painful?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
monkeyhead
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2004
Posts: 97
Location: hella-where?

PostPosted: Mon Jun 06, 2005 6:59 pm    Post subject: Why did emerging start becoming so painful? Reply with quote

So first off... No offense to the developers and contributors that work so hard on gentoo. I've been happily using gentoo for about 2 years now and appreciate all your hard work. It's by far my favorite distro....

but...

the quality control seems to have gone way downhill in the last six months or so. I dread updating my system now because there's always something wrong. package conflicts, a recent rash of sandbox errors, strange compilation errors. randomly broken stuff.

am i just not devoting enough energy, or are others seeing this as well? I used to excitedly "emerge sync; emerge -u world" once a week. lately i put it off for 2-4 weeks because it seems like there's a hassle just waiting to happen. I wouldn't care if this was a hobby box, but it's not. It's basically my production box and I need it running and don't have the time i wish i did to tinker around with it. I avoid unstable packages and try to keep up on the routine maintenance.

if this is just straight up whining tell me to shut the hell up, but if others are seeing this as well i'd be curious to know what changed.
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Mon Jun 06, 2005 7:08 pm    Post subject: Reply with quote

I haven't had any problems the last couple of weeks. I just thought it had become bettr than before :). I assume you are not running a ~x86 system. You might try to rebuild some things. Maybe startoff with a
Code:
emerge --newuse world
revdep-rebuild -p
revdep-rebuild
Also check that gcc doesn't give a problem. I had a couple of problem until I ran fix_libtool_files.sh. gcc-config -l to see which version you have installed.
Back to top
View user's profile Send private message
loki99
Advocate
Advocate


Joined: 10 Oct 2003
Posts: 2056
Location: Vienna, €urope

PostPosted: Mon Jun 06, 2005 7:13 pm    Post subject: Reply with quote

i only had a few "hick-ups" in the last couple of months. all of them were resolved within half an hour, but i didn't update world as often as i used to. perhaps once a month!

there are people complaining, even long term users, and there are some things going on, that i do not understand.

so actually i don't know! :?
Back to top
View user's profile Send private message
monkeyhead
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2004
Posts: 97
Location: hella-where?

PostPosted: Mon Jun 06, 2005 8:40 pm    Post subject: Reply with quote

alright... it's probably something i'm doing then. thanks for the tips.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Tue Jun 07, 2005 2:15 am    Post subject: Reply with quote

Complain here.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum