Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] !!! ERROR: app-pda/pilot-link-0.11.8 failed
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Mon Jun 06, 2005 8:22 pm    Post subject: [SOLVED] !!! ERROR: app-pda/pilot-link-0.11.8 failed Reply with quote


I am on AMD64 trying to install kde-meta.
The installation got stuck at this point, and I am unable to figure out how to solve it.

I ask for your help, please.

Here is my configuration:
Emerge Info wrote:
Portage (default-linux/amd64/2005.0, gcc-3.4.3, glibc-, 2.6.11-gentoo-r7 x86_64)
System uname: 2.6.11-gentoo-r7 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.5 [2.3.5 (#1, Jun 6 2005, 00:01:45)]
dev-lang/python: 2.3.5
sys-apps/sandbox: [Not Present]
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.5, 1.8.5-r3, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.5
sys-devel/libtool: 1.5.16
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
USE="amd64 3ds X a52 aac acl acpi activefilter adns aim alsa altcolors apm arts audiofile avantgo avi bcmath bdf berkdb bitmap-fonts bmp bootsplash bzlib ccs cdda cdinstall cdparanoia cdr cdrom cgi chroot clamav clamd cle266 clflush client cmov codecs crypt cups curl curlwrappers custom-cflags cx8 dba dbase de dga directfb dnd dnsdb doc dpms dts dv dvb dvd dvdr dvdread dxr3 edl encode esd examples exif extensions faad fam fax fb fbcon fbdev ffmpeg flac font-server foomaticdb fortran fpu freetype ftp fxsr fxsr_opt gd gdbm gif gimp gimpprint ginac gkrellm glut gphoto2 gpm gsl gtk gtk2 hal hbci http icq ieee1394 imagemagick imap imlib ipv6 irc jack java javascript jp2 jpeg jpeg2k kcal kde kdepim lahf_lm lcd lcms libcaca libclamav libwww lm lm_sensors logitech-mouse lzw lzw-tiff mad mca mcal mce md5sum messages mikmod mime mixer mjpeg monkey motif mozilla moznoirc moznomail moznoxft mozsvg mp3 mpeg mpeg4 mpi mplayer msn msr mtrr music nagios-dns nagios-ntp nagios-ping nagios-ssh nas ncurses network nls nntp nptl nvidia nx odbc ogg opengl oss pae pam pat pda pdf pdfkit pdflib perl pge php pic png pni pnp ppds print procmail pse pse36 python qt quicktime readline real rplay rss rtc samba sasl sblive scanner screenshot sdl sep server skk smime sndfile sounds spell ssl syscall tcltk tcpd tcpmd5 tiff transcode truetype truetype-fonts tsc type1 type1-fonts unicode usb userlocales v4l v4l2 vcd videos vidix vim virus-scan vme vnc vorbis xchattext xine xml xml2 xmms xosd xpm xprint xrandr xscreensaver xv xvmc yahoo zlib linguas_en userland_GNU kernel_linux elibc_glibc"

Here is the error:
creating reminders
perl ietf2datebook.PL > ietf2datebook
chmod +x ietf2datebook
perl pilot-undelete.PL > pilot-undelete
chmod +x pilot-undelete
perl sync-plan.PL > sync-plan
chmod +x sync-plan
make[3]: Leaving directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/src'
make[2]: Leaving directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/src'
Making all in bindings
make[2]: Entering directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/bindings'
Making all in Java
make[3]: Entering directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/bindings/Java'
/opt/blackdown-jdk- -d . ./org/gnu/pilotlink/               ./org/gnu/pilotlink/                ./org/gnu/pilotlink/         ./org/gnu/pilotlink/            ./org/gnu/pilotlink/              ./org/gnu/pilotlink/             ./org/gnu/pilotlink/              ./org/gnu/pilotlink/                 ./org/gnu/pilotlink/               ./org/gnu/pilotlink/                    ./
x86_64-pc-linux-gnu-g++ -I../../include                         -I ../../include                -I ../../include              -I /opt/blackdown-jdk-                  -I /opt/blackdown-jdk-  -L ../../libpisock/.libs -lpisock -shared -o ./libjpisock.c
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: /var/tmp/portage/pilot-link-0.11.8/temp/ccjiCHoq.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/var/tmp/portage/pilot-link-0.11.8/temp/ccjiCHoq.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [java_lib] Error 1
make[3]: Leaving directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/bindings/Java'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8/bindings'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/pilot-link-0.11.8/work/pilot-link-0.11.8'
make: *** [all-recursive-am] Error 2

!!! ERROR: app-pda/pilot-link-0.11.8 failed.
!!! Function src_compile, Line 57, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

I found this at bugzilla but am unable to understand if it was solved or not and how. If you understand it and its the solution, please let me know. Thank you.

Also I noticed that inside the error report I found this: blackdown-jdk-
I wish to make you aware that I had only 1 issue with java, when running revdep-rebuild. Here is the error and here is the thread.
Checking dynamic linking consistency...
  broken /opt/blackdown-jre- (requires
  broken /opt/blackdown-jdk- (requires

Thank you a lot.

Last edited by SAngeli on Tue Jun 07, 2005 7:44 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Tue Jun 07, 2005 7:44 am    Post subject: Reply with quote

I solved (with the help of people on chat) the issue.

Here is the solution:
Add to /etc/portage/package.use this line
>=app-pda/pilot-link-0.11.8 -java

This will allow you to succesfully compile pilot-link

Here is the bug # 66087 reported at:

Hope this helps...
Back to top
View user's profile Send private message

Joined: 18 Sep 2004
Posts: 27

PostPosted: Fri Jun 10, 2005 3:59 pm    Post subject: Reply with quote

Thanks SAngeli,
this helped me too :)

Back to top
View user's profile Send private message

Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Jul 12, 2005 4:30 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads in favour of
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum