Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Totem crashes at startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rjmckee
n00b
n00b


Joined: 27 Jan 2004
Posts: 9
Location: Vidalia

PostPosted: Tue Jun 07, 2005 9:57 am    Post subject: Totem crashes at startup Reply with quote

totem crashes at startup: I do not understand the error; any help? Please....
I get this message set:

ray@ladyvic-1 ray $ totem

(totem:14887): GModule-CRITICAL **: g_module_close: assertion `module != NULL' failed
/usr/share/themes/Nuvola/gtk-2.0/iconrc:23: Unable to locate image file in pixmap_path: "stock_stock.svg"
/usr/share/themes/Nuvola/gtk-2.0/iconrc:54: Unable to locate image file in pixmap_path: "stock_ok.svg"

** (totem:14887): CRITICAL **: how to remove plugins?

(totem:14887): GStreamer-CRITICAL **: Factory for `osssink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'ossaudio' and is expected in file '/usr/lib/gstreamer-0.8/libgstossaudio.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'

** (totem:14887): CRITICAL **: how to remove plugins?

(totem:14887): GStreamer-CRITICAL **: Factory for `osssink' has no type. This probably means the plugin wasn't found because the registry is broken. The plugin GStreamer was looking for is named 'ossaudio' and is expected in file '/usr/lib/gstreamer-0.8/libgstossaudio.so'. The registry for this plugin is located at '/var/lib/cache/gstreamer-0.8/registry.xml'

** (totem:14887): WARNING **: No GConf default audio sink key and osssink doesn't work
** Message: failed to render default audio sink from gconf
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Jun 07, 2005 10:11 am    Post subject: Reply with quote

hi,

try the command revdep-rebuild (which belongs to the gentoolkit package)

HTH.
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
St. Joe
Apprentice
Apprentice


Joined: 13 Apr 2005
Posts: 242
Location: USA

PostPosted: Tue Jun 07, 2005 10:15 am    Post subject: Reply with quote

You could try adding this line to your package.use file:

Code:
media-video/totem -gstreamer
Back to top
View user's profile Send private message
rjmckee
n00b
n00b


Joined: 27 Jan 2004
Posts: 9
Location: Vidalia

PostPosted: Tue Jun 07, 2005 9:03 pm    Post subject: Reply with quote

Merci, but non; ;-)
I did the revdep-rebuild and that did not help. I'll next try the next suggestion...
Thank you and regards,
Ray
Back to top
View user's profile Send private message
LordZero
n00b
n00b


Joined: 17 Nov 2004
Posts: 14

PostPosted: Mon Sep 26, 2005 10:09 am    Post subject: Reply with quote

I had the same trouble on my Notebook - running Gnome 2.10.2!
I found out, that the Gnome Multimedia System still uses the osssink instead of the nex alsasink. So i reselecte Alsa Sound in the Multimedia System an now it works fine...
It looks that my Gnome System still used the old oss instructions which were set last year when i used oss...

So try to change the settings in the Multimedia System and it should work...

Greets
Werner
Back to top
View user's profile Send private message
danf_1979
n00b
n00b


Joined: 25 Sep 2005
Posts: 16

PostPosted: Wed Sep 28, 2005 7:34 pm    Post subject: Reply with quote

Many thanks for that tip. It worked for me too Lorzero
_________________
emerge this!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Jan 04, 2006 8:34 pm    Post subject: Reply with quote

Moved from Multimedia to Duplicate Threads in favour of "No GConf default audio sink key and osssink doesn't work".
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum