Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"slotmove" not recognized while emerge -u portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
selim
Apprentice
Apprentice


Joined: 14 Apr 2004
Posts: 219

PostPosted: Thu Jun 09, 2005 10:32 am    Post subject: "slotmove" not recognized while emerge -u portage Reply with quote

I've a server system which was not update since 2003 I think it's an old 1.4 gentoo version.
After I did an emerge sync I tried an emerge -u portage but I got this:

Performing Global Updates: /usr/portage/profiles/updates/1Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
...................portage: Update type "slotmove" not recognized.
.....................


Performing Global Updates: /usr/portage/profiles/updates/1Q-2005
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
..............................................portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
....portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
....portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
...................................................portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
.portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
.......................portage: Update type "slotmove" not recognized.
.....................................................................................portage: Update type "slotmove" not recognized.
...............


Performing Global Updates: /usr/portage/profiles/updates/2Q-2005
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
............................................portage: Update type "slotmove" not recognized.
..............portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
.........................................


Performing Global Updates: /usr/portage/profiles/updates/3Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
..portage: Update type "slotmove" not recognized.
.portage: Update type "slotmove" not recognized.
.portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
........................................portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
.............................................................................................................portage: Update type "slotmove" not recognized.
portage: Update type "slotmove" not recognized.
...................portage: Update type "slotmove" not recognized.
...............


Performing Global Updates: /usr/portage/profiles/updates/4Q-2004
(Could take a couple minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
.portage: Update type "slotmove" not recognized.
...................................portage: Update type "slotmove" not recognized.
....portage: Update type "slotmove" not recognized.
..........................................................................................................................................................................................................................
!!! No profile directory; system mode unavailable.

I've search here on the board after some solutions but nothing seems to fit for my problem.
Can anyone help me with this?
Back to top
View user's profile Send private message
Karsten from Berlin
Guru
Guru


Joined: 28 Feb 2004
Posts: 446
Location: Berlin/Germany

PostPosted: Thu Jun 09, 2005 11:57 am    Post subject: Reply with quote

Maybe try to change first to the actual profile. In /etc

Code:

lrwxrwxrwx   1 root root      46 11. Apr 13:01 make.profile -> /usr/portage/profiles/default-linux/x86/2005.0


Then do an

Code:

emerge --sync && env-update && source /etc/profile && env-update && emerge -u portage && env-update && source /etc/profile && env-update


If you are successful, you will still have a lot of work to get everything going again. After such a long time your whole world will update, btw such new things like udev/hotplug must be integrated by you. So I would tend to install a fresh Gentoo. It will take less time than manually correct the whole system and it will definetely save you some loss of lifetime and nerves. :D
_________________
Heaven: The police are British, the chefs Italian, the mechanics German, the lovers French and it's organized by the Swiss.
Hell: The police are German, the chefs British, the mechanics French, the lovers Swiss and it's organized by the Italians.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Thu Jun 09, 2005 12:07 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads. Please see https://forums.gentoo.org/viewtopic-p-2393476.html#2393476
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum