Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pbbuttonsd.conf problems?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Fri Jun 10, 2005 8:07 pm    Post subject: pbbuttonsd.conf problems? Reply with quote

for some reason my pbbuttonsd wont read in the keys and understand the hotkeys. i used xev to get the keycodes needed to perform things like snd up snd down, brightness up and down, but alsa to no avail nothin. anyone have an idea why?

im using a ibook g3 300 graphite clamshell

any help is appericated
thx in advance.
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Fri Jun 10, 2005 8:13 pm    Post subject: Reply with quote

hold down the fn key, do they work now?

Check KBDMode in pbbuttonsd.conf and set it to fkeyslast if you would rather have hotkeys by default instead of function keys.
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Fri Jun 10, 2005 8:15 pm    Post subject: Reply with quote

cyberb0b wrote:
hold down the fn key, do they work now?

Check KBDMode in pbbuttonsd.conf and set it to fkeyslast if you would rather have hotkeys by default instead of function keys.


i didnt use the Fn keys with the keycodes i used, and the KBDMode is fkeyslast what does that do? everything else seems to work, my computer does go to sleep and what not. so im confused why the keys dont work :(
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Fri Jun 10, 2005 8:20 pm    Post subject: Reply with quote

i just noticed something odd about my keyboard, in order to get to any F# keys even with pbbuttonsd killed i need to press Fn, numlock on my keyboard is set where the F5 key is but now in order to get it i need to hit Fn+F5 to turn on numlock, i found that odd.
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Fri Jun 10, 2005 8:24 pm    Post subject: Reply with quote

Not sure about the clamshells, but on my iBook G4 the F1 key also adjusts the brightness. In pbbuttonsd.conf, KBDMode=fkeysfirst means press the button for F1, hold Fn and press to adjusts the brightness down. fkeyslast mode makes it do brightness down, holding Fn to get F1.

What key codes are you trying? What does that part of your pbbuttonsd.conf look like? Did you restart pbbuttonsd?
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Fri Jun 10, 2005 8:31 pm    Post subject: Reply with quote

here is my pbbuttonsd.conf file

http://aculei.net/~echo/pbbuttonsd.conf

what do you mean what keycodes am i using? where can i find this? if its in xorg.conf here is my xorg.conf file. i need to go get ready for my uncles b-day dinner so i wont reply so i hope this information is helpful :)

http://aculei.net/~echo/xorg.conf

here is my kernel .config if anyone cares to take a look

http://aculei.net/~echo/.config
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.


Last edited by nenn on Fri Jun 10, 2005 9:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
cyberb0b
n00b
n00b


Joined: 09 Mar 2005
Posts: 22

PostPosted: Fri Jun 10, 2005 8:40 pm    Post subject: Reply with quote

nenn wrote:
i just noticed something odd about my keyboard, in order to get to any F# keys even with pbbuttonsd killed i need to press Fn, numlock on my keyboard is set where the F5 key is but now in order to get it i need to hit Fn+F5 to turn on numlock, i found that odd.


In your pbbuttonsd.conf file the next to last line is:

Code:
KBDMode               = fkeysfirst

Change this to fkeyslast to reverse the behavior, i.e. in order to get help to appear (F1) you have to press Fn + F1.
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Fri Jun 10, 2005 9:02 pm    Post subject: Reply with quote

well that changed that little problem but my sound still is quite low, i cant change it in aumix, or any mixer for that matter, which might be why i cant do anything, but the brightness is still a problem so im confused :(
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Jun 10, 2005 10:04 pm    Post subject: Reply with quote

On my PB G4 500, I have the brightness keys set to:
Code:
LCD_IllumUpKey      = 225
LCD_IllumDownKey      = 224


With the KBDMode set to "fkeysfirst", I press the fn + F1 for brightness level down, and fn + F2 for brightness up.
Your kernel looks like it was configured correctly for LCD dimming, so that shouldn't be a problem.

As an aside, you most likely have a Rage128 based video card, you should enable the DRI/DRM module for R128 and use dri in Xorg. Also, disable all of the other FB devices except for the one you're using, as sometimes using the OpenFirmware Framebuffer prevents dimming.

For your sound issue, first of all, you've got both ALSA and OSS in your kernel. Remove
Code:
CONFIG_DMASOUND_PMAC=y
and try again. (Yes, this is wrong in the FAQ, I'm fixing it. ;) )

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Sat Jun 11, 2005 1:19 am    Post subject: Reply with quote

fixed the audio, just made it the same as another .config i had using modules, didnt want to but w/e its working, but something akward is happening, when i have pbbuttonsd running i cant change the brightness or sound ( i found out, its not reading my keycodes properly ) so as i was about to restart it, i pressed the brightness down key ( in my case, the same as my F1 key) and my screen seemed dimmer, as it turns out, it will dim and brighten up my lcd, now this is only when pbbuttonsd isnt running, im not sure about the sound yet, but when i restarted pbbuttonsd i cant dim my screen, whats up with that?!
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Jun 11, 2005 1:57 am    Post subject: Reply with quote

Well, did you try any of the things I suggested above?

Also, are you perhaps using a different keyboard layout?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nenn
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 95
Location: NYC, NY

PostPosted: Sat Jun 11, 2005 3:05 am    Post subject: Reply with quote

as the things youve suggested above

regarding the framebuffer, i dont really know which one to use. when i made the kernel using genkernel they were all in there and everything seemed to work, except (which really pisses me off) using any sort of framebuffer video/image viewing outside of X ie using mplayer.
Code:
mplayer -vo vesa ...

if you know how i can fix this i would LOVE an answer :)
and no im not using any different keyboard layout im using the QWERTY layout here is what the keyboard looks like.
http://www.powerbookmedic.com/xcart1/files/details/t_16235_01.jpg
_________________
Who says i cant grow up to become a robot?
They all just want to crush my dreams damnit.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Jun 11, 2005 3:33 am    Post subject: Reply with quote

For the mplayer issue, emerge mplayer with the fbcon use flag, then use mplayer -vo fbdev. Works for me. :)

For the frame buffer, at least try adding append="video=atyfb128" to the image section of your yaboot.conf. This should force it to use the r128 framebuffer.

Also, try removing the macintosh from your XKB rules, it's not needed and could be screwing things up. Did you set macintosh keyboard types anywhere else like /etc/conf.d/keymaps? Don't do that. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
soongjason
n00b
n00b


Joined: 25 May 2005
Posts: 35

PostPosted: Mon Jun 20, 2005 10:15 pm    Post subject: Trying to be informative. Reply with quote

Do you press the "fn" with the sound up / sound down key?

8O
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum