Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
delete /var, help with emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Piaga
n00b
n00b


Joined: 22 Aug 2004
Posts: 31

PostPosted: Mon Jun 13, 2005 5:49 pm    Post subject: delete /var, help with emerge Reply with quote

Hi all,

In a dark and cold nigt I deleted the /var directory (Yes, I know how much stupid I am..)

now I've got (obbiusly) an error while try to emerge any kind of package

Code:

emerge -pv world

These are the packages that I would merge, in order:

Calculating world dependencies   
*** Package in world file is not installed: net-dialup/minicom

*** Package in world file is not installed: app-pda/gtkpod

*** Package in world file is not installed: sys-libs/gpm

*** Package in world file is not installed: media-libs/libungif

*** Package in world file is not installed: app-cdr/dvd+rw-tools

*** Package in world file is not installed: media-sound/alsa-utils

*** Package in world file is not installed: x11-misc/bubblemon

*** Package in world file is not installed: sys-fs/reiserfsprogs

*** Package in world file is not installed: x11-plugins/wmmemmon

etc etc...


Can I resolv this issue without re-emerge everything?
If I have to re-emerge, have I to save all my programs configuration files?

Really thanx.

D.P.
:cry:
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Jun 13, 2005 5:53 pm    Post subject: Reply with quote

try emerge --metadate first
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Piaga
n00b
n00b


Joined: 22 Aug 2004
Posts: 31

PostPosted: Mon Jun 13, 2005 6:06 pm    Post subject: Reply with quote

Code:

emerge --metadata
skipping sync

>>> Updating Portage cache:  100%



 * An update to portage is available. It is _highly_ recommended
 * that you update portage now, before any other packages are updated.
 * Please do so and then update ALL of your configuration files.


but the problem still remain
Thanx again :(
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Jun 13, 2005 6:14 pm    Post subject: Reply with quote

Maybe this helps: https://forums.gentoo.org/viewtopic-t-337129-highlight-deleted+var.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jun 13, 2005 6:31 pm    Post subject: Reply with quote

Please see https://forums.gentoo.org/viewtopic.php?t=171015

Moved from Installing Gentoo to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum