Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge gentoo-sources failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
prometheanfire
Developer
Developer


Joined: 21 Apr 2005
Posts: 87
Location: San Antonio, TX USA

PostPosted: Tue Jun 14, 2005 6:37 am    Post subject: Emerge gentoo-sources failed Reply with quote

It failed while emerging the svga stuff so I am currently skipping that and compiling everything else on the list.
The exact object that it was trying to emerge was
Code:
emerge svgalib-1.9.19-r3
I read around on the internet about this problem and found a similiar one for emerge
Code:
svgalib-1.9.17-r3
but the way the it is solved is by disabling a patch for kernel 2.6 and using the object on 2.4. Unfortunatly I am using 2.6. I would appreciate any help that any of you could offer on the mater.

Thankyou
Back to top
View user's profile Send private message
zmedico
Developer
Developer


Joined: 02 Jan 2004
Posts: 337
Location: California USA

PostPosted: Tue Jun 14, 2005 7:58 am    Post subject: Reply with quote

Was the problem with gentoo-sources or svgalib? Did you get an error message?
_________________
Zac
Back to top
View user's profile Send private message
prometheanfire
Developer
Developer


Joined: 21 Apr 2005
Posts: 87
Location: San Antonio, TX USA

PostPosted: Tue Jun 14, 2005 7:52 pm    Post subject: Reply with quote

The problem is with svgalibs. the exact error that I get is
Code:
!!! Error: media-libs/svgalib-1.9.19-r3 failed
!!! Function kernel-mod_configoption_builtin, Line 114, Exitcode 1
!!! Kernel has not been configured yet
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Jun 14, 2005 7:56 pm    Post subject: Reply with quote

See https://forums.gentoo.org/viewtopic-t-247019.html or https://forums.gentoo.org/viewtopic-t-292127.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
zmedico
Developer
Developer


Joined: 02 Jan 2004
Posts: 337
Location: California USA

PostPosted: Tue Jun 14, 2005 8:13 pm    Post subject: Reply with quote

I would just add USE="-svga" to make.conf because I
don't need svgalib.

If you want to compile it then you need the kernel
source and .config in /usr/src/linux. If you've lost
your .config then maybe you can do "gzip -dc
/proc/config.gz > /usr/src/linux/.config". Then run
the following commands:

cd /usr/src/linux
make oldconfig
make modules_prepare

That should configure the sources sufficiently for you
to compile modules.
_________________
Zac
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Tue Jun 14, 2005 9:56 pm    Post subject: Reply with quote

nixnut wrote:
See https://forums.gentoo.org/viewtopic-t-247019.html or https://forums.gentoo.org/viewtopic-t-292127.html



Moved to Dups.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum