Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SIP client on PPC [partially solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Tue Jun 14, 2005 11:06 pm    Post subject: SIP client on PPC [partially solved] Reply with quote

Hi,

Is anybody using a SIP client on PPC? I have tried linphone and kphone, which build fine and also connect fine to SIP servers and stuff. Problem is, they both seem to have (what I believe to be) indianness issues--in that they produce white noise as output (in the linphone case this also happens with the test of the ringer).

So is anybody using any of the two applications (or some other) with more success than me? Thanks in advance.
_________________
Quid latine dictum sit altum videtur


Last edited by bruda on Thu Jun 16, 2005 7:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Thu Jun 16, 2005 4:17 pm    Post subject: Reply with quote

FYI, linphone's endianness issues are fixed with the ALSA driver by changing the line 64 of file linphone-0.12.2/mediastreamer/alsacard.c to contain "SND_PCM_FORMAT_S16_BE" instead of "SND_PCM_FORMAT_S16_LE". The OSS part is not fixed by this.

I still seem to have some issues with actual conversations though. I find it sort of strange that nobody has used SIP clients on PPC, please share your experience.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Tue Jun 21, 2005 1:04 pm    Post subject: Reply with quote

Can you get kphone corrected with such a hack? Because debug output of kphone tells something about s16, s32 when I try to use Alsa.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Tue Jun 21, 2005 2:40 pm    Post subject: Reply with quote

The problem with kphone is that I have no means to test it except bother my friends. That's why I worked with linphone, it allows you to play the ring tone so that it is pretty easy to figure out whether your sound is working without placing any call. ;-) I'll take a look at kphone too, but don't hold your breath.

By the way I would much prefer OSS emulation, ALSA by itself plays it kind of choppy on my system, it was always like this (but I cannot seem to find such an easy fix on the OSS side in linphone). How does your ALSA system behave? Mine is a Powermac "Snapper" on a Tibook rev IV currently running Linux 2.6.10-gentoo-r6.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Tue Jun 21, 2005 3:11 pm    Post subject: Reply with quote

For testing reasons my provider sipgate.de has a number for. Under 1000 there is a test call, but I only get white noise. I know how to use kphone on x86.
Maybe you can just have another sipaccount running on a different computer for testing?

I haven't compared alsa with oss on my iBook G3-600. xmms runs fine now with xmms-alsa, although it had some problems with playbackspeed at the beginning. Other sound applications I haven't tested yet. mixxx takes a lot of cpu-power (for my G3), the same with xine and mplayer. But I was able to watch a movie with mplayer and alsa.

About linphone: It emerged without any GUI, although I have use=gtk, but -gnome. Is that right?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Tue Jun 21, 2005 8:34 pm    Post subject: Reply with quote

I emerged the new 4.1.1
There is a file called dspoutalsa.cpp, which has the same entry.
I changed that to S16_BE too. Alsa don't crashes but no sound at all.
And OSS makes no noise in this version, but no sound.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Thu Jul 28, 2005 7:08 pm    Post subject: Reply with quote

The new kphone 4.2 doesn't play noise anymore, but plays nothing at all.
I also tried your patch towards S16_BL.
I tried OSS and Alsa.
Curious that if I call the sipclient from outside, I hear the ring as usual, so kphone should know the sound device.

With linphone I still fail to build the UI with. I have a USE gtk but -gnome.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
meyerm
Veteran
Veteran


Joined: 27 Jun 2002
Posts: 1311
Location: Munich / Germany

PostPosted: Tue Aug 02, 2005 3:51 pm    Post subject: Reply with quote

Just tried kcall on PPC. Also noise...
Back to top
View user's profile Send private message
gnomeza
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2003
Posts: 97

PostPosted: Wed Aug 03, 2005 10:40 am    Post subject: Reply with quote

linphone-1.0.1 is working very well for me with ALSA - no patching necessary.
This is as long as I let linphone have sole access to ALSA (it uses the plughw:0,0 ALSA device by default).

Configuring ALSA dmix & dsnoop (ALSA software mixing) and adding
Code:
alsadev=my_dmix_dsnoop_duplex_dev
to linphone config, the buffer parameters linphone selects don't agree with the Powermac Snapper driver and produce choppy audio as a result.
But fix these settings and I'll have a nice PPC VoIP setup for my powerbook ...
_________________
http://markferry.net
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Wed Aug 03, 2005 2:52 pm    Post subject: Reply with quote

I still don't know how to get the gui of linphone. It compiles for textonly.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
gnomeza
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2003
Posts: 97

PostPosted: Wed Aug 03, 2005 11:07 pm    Post subject: Reply with quote

My version of linphone is emerged with the following flags:
Code:
net-misc/linphone-1.0.1  +alsa +gnome +ipv6 +xv

The +xv isn't really used since I don't think video is implemented yet.
So +gnome is what you're missing then...
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Thu Aug 04, 2005 7:59 am    Post subject: Reply with quote

I have gtk gtk2 -gnome, because I have no gnome. gtk should be enough. How can I just tell linphone the use +gnome?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Sun Aug 07, 2005 12:12 pm    Post subject: Reply with quote

echo "net-misc/linphone gnome" >> /etc/portage/package.use
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Fri Sep 02, 2005 5:11 pm    Post subject: Reply with quote

linphone works now. Sound works also on the G3iBook. It seems as if the new source is already fixed.

But the sound quality is very jumpy, too much to use it properly. It is the same problem as with the mplayer or xine.
There I can use "esound" which is far better. By the way, what is esound? Is it usable for applications which don't have support?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Sun Oct 09, 2005 5:37 pm    Post subject: Reply with quote

Since some updates and a new kernel, linphone plays fine (also realplayer has no sound problems anymore).
But now I just don't get the microphone activated.
Increasing monitor level just gives me a feedback, but internally the digital input source is muted I think.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Mon Nov 14, 2005 9:29 pm    Post subject: Reply with quote

Curiously the microphone works now, I just can't find a slider for micfrophone volume in alsamixer.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum