Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I need to emerge gcc-2.95!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Fri Jul 01, 2005 4:13 pm    Post subject: I need to emerge gcc-2.95! Reply with quote

I need to emerge gcc-2.95 because I'm using an old application that use it, but when I try emerge it
Code:
# emerge -va =sys-devel/gcc-2.95.3-r9

These are the packages that I would merge, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "=sys-devel/gcc-2.95.3-r9" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/gcc-2.95.3-r9 (masked by: profile)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.

My /etc/portage/package.unmask
Code:
[...]
=sys-devel/gcc-2.95.3-r9


Where is the mistake?
Of course I want to use gcc-2.95 ONLY for the application, I suppose that I can use gcc-config with it
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Fri Jul 01, 2005 5:14 pm    Post subject: Reply with quote

Respecting portage manual, I've added a profile packages file overlay
Code:
# cat /etc/portage/profile/packages
=sys-devel/gcc-2.95.3-r9


But nothing has changed, If I want to emerge gcc-2.95 I must comment the gcc entry into /etc/make.profile/packages
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Fri Jul 01, 2005 5:57 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads. Please see https://forums.gentoo.org/viewtopic.php?t=253718&highlight=override+profile (towards the end)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum