Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to open device /dev/root
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
verruckt
Apprentice
Apprentice


Joined: 22 Sep 2003
Posts: 169
Location: missing Hörvelsingen...

PostPosted: Sat Jul 02, 2005 3:24 am    Post subject: Failed to open device /dev/root Reply with quote

I just finished my install of gentoo (stage 3, 2.6.11) and on my first reboot I get this error...

Code:

*Checking root filesystem...
Failed to open the device '/dev/ROOT': No such file or directory

*Filesystem couldn't be fixed :(



What the hell?? I've done this successfully several times before. Anyone have an idea what this might be, and how I go about fixing it? Could I have made an error in my fstab? both my boot and root filesystems are Reiserfs. Thanks ahead of time.
Back to top
View user's profile Send private message
geniux
Veteran
Veteran


Joined: 19 Feb 2004
Posts: 1400
Location: /home

PostPosted: Sat Jul 02, 2005 3:36 am    Post subject: Reply with quote

Well, check your fstab, looks like you've done a classic :wink:
_________________
AMD Athlon64 X2 4200+ AM2
MSI K9N SLI Platinum, Enermax Liberty 500W
1GB RAM Crucial DDR2 667MHz, MSI nVidia 7600GS 256MB
400GB + 250GB Samsung SATAII HDD
Gentoo - BeyondSources 2.6.19-20
Back to top
View user's profile Send private message
Headrush
Watchman
Watchman


Joined: 06 Nov 2003
Posts: 5597
Location: Bizarro World

PostPosted: Sat Jul 02, 2005 3:47 am    Post subject: Reply with quote

many people have had this mistake.

You entries in /etc/fstab are wrong, you need to replace things like /dev/ROOT with your correct partition eg /dev/hda

You will have to boot off LiveCD, mount your partition and make the changes to /etc/fstab.

There are several threads on this already.
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Jul 02, 2005 1:07 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads, please see this topic:

https://forums.gentoo.org/viewtopic-t-8351.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum