Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO : gfxmenu on patched grub [tested on amd64]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Jun 17, 2007 9:08 pm    Post subject: Re: new gentoo theme Reply with quote

cato` wrote:
sethleon wrote:
I just downloaded the SuSE theme version 3.3.24,
and modified the pictures (just put Gentoo Logos and fonts).

Thanks, mirrored it http://folk.ntnu.no/myhre/gfxboot-theme-gentoo_3.3.24.tar.bz2 for easier downloading.


there's a permission problem with your file (+r missing) :roll:

thanks for that mirror, so in case I lose that file & rapidshare is down :wink:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cato`
Guru
Guru


Joined: 03 Jun 2002
Posts: 430
Location: Norway, Trondheim

PostPosted: Sun Jun 17, 2007 9:11 pm    Post subject: Re: new gentoo theme Reply with quote

kernelOfTruth wrote:

there's a permission problem with your file (+r missing)

Fixed!
_________________
Don't mess with the Penguin.
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Mon Jun 18, 2007 5:12 am    Post subject: Reply with quote

I used:
gfxboot-3.3.24-11.src.rpm
grub-0.97-r3 with patches from the bug report

You also could rebuild the boot-message file.
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Mon Jun 18, 2007 5:31 am    Post subject: Reply with quote

hmm i also used the same except for gfxboot was 3.3.24.26,
also i rebuild the message file before putting it and using it, still i have corrupted graphics.
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Mon Jun 18, 2007 8:40 am    Post subject: Reply with quote

Is it only the graphics, or the text as well ?
Maybe the graphic is too large or has too many colors for your configuration ?
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Mon Jun 18, 2007 9:13 am    Post subject: Reply with quote

Actually I am not getting to the the graphics screen
I see the loading stage 1.5 message and with that on the right top corner theres a box like the ones in the PC initialization screen with some odd text and message. The box extends upto half of the screen vertically and 1/3rd vertically and after waiting some time i get a graphics initilization failed message

I tried rebuilding gfxboot, didn't help.
I have a 17" CRT Monitor
I can take a picture of the screen and the error and upload it if that would help.
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Mon Jun 18, 2007 5:36 pm    Post subject: Reply with quote

How about the packages around gfxboot,
have you followed the instructions mentioned in Bug as follows?
Bug #103272 Description 0 (Bugs.Gentoo.org)
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Mon Jun 18, 2007 8:33 pm    Post subject: Reply with quote

Yes the I followed the instructions as given there.
To double check i removed and redid it. Didn't work.
The default Suse theme from the gfxboot package is working for me.
Compiled grub and gfxboot without any useflags.

Stil getting the error.
http://img236.imageshack.us/img236/2545/dsc006811if5.jpg
after pressing esc
http://img502.imageshack.us/img502/439/dsc00678cj2.jpg
The message in the second picture is graphics initialization failed

Heres my grub.conf
Code:
default 0

#timeout 30
splashimage=(hd0,6)/boot/grub/splash.xpm.gz
#gfxmenu (hd0,6)/boot/message

title=Gentoo Linux
root (hd0,6)
kernel /boot/bzImage-2.6.20-gentoo-r8 splash=silent,fadein,theme:livecd-2007.0 video=intelfb:1024x768-32@60,mtrr,ywrap quiet CONSOLE=/dev/tty1 root=/dev/hda9
initrd (hd0,6)/boot/fbsplash-livecd-2007.0-1024x768

title=Gentoo Linux (rescue)
root (hd0,6)
kernel /boot/bzImage-2.6.20-gentoo-r8 root=/dev/hda9 init=/bin/bb

title=Windows Vista Ultimate
rootnoverify (hd0,0)
makeactive
chainloader +1


Still your theme is not working for me.
I extract it to my home directory make it and copy the message file to /boot
Is it working for others?
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Wed Jun 20, 2007 11:57 am    Post subject: Reply with quote

shaumux wrote:
Yes the I followed the instructions as given there.
To double check i removed and redid it. Didn't work.
The default Suse theme from the gfxboot package is working for me.
Compiled grub and gfxboot without any useflags.

Stil getting the error.
http://img236.imageshack.us/img236/2545/dsc006811if5.jpg
after pressing esc
http://img502.imageshack.us/img502/439/dsc00678cj2.jpg
The message in the second picture is graphics initialization failed

Still your theme is not working for me.
I extract it to my home directory make it and copy the message file to /boot
Is it working for others?
Exactly the same here ... :?
Untarred on my home directory, copied to the gfxboot theme path, changing default language and removing english from Makefile (error comes probably from here). Compiled fine but it produces the same error showed in picture.

Someone can help us please ? :roll:
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Wed Jun 20, 2007 6:07 pm    Post subject: Reply with quote

Ok using the SuSe theme coming from gfxboot and he pictures from sethleon's theme
I created another one, I just copied the pictures from one to another Thas all and now its working for me
Here it is http://www.mediafire.com/?bxdsgnovxrl
Back to top
View user's profile Send private message
cato`
Guru
Guru


Joined: 03 Jun 2002
Posts: 430
Location: Norway, Trondheim

PostPosted: Thu Jun 21, 2007 9:10 am    Post subject: Reply with quote

shaumux wrote:
Ok using the SuSe theme coming from gfxboot and he pictures from sethleon's theme
I created another one, I just copied the pictures from one to another Thas all and now its working for me
Here it is http://www.mediafire.com/?bxdsgnovxrl

Mirrored for easier downloading ;)
_________________
Don't mess with the Penguin.
Back to top
View user's profile Send private message
yoyo
Bodhisattva
Bodhisattva


Joined: 04 Mar 2003
Posts: 4273
Location: Lyon - France

PostPosted: Mon Jun 25, 2007 7:54 am    Post subject: Reply with quote

shaumux wrote:
Ok using the SuSe theme coming from gfxboot and he pictures from sethleon's theme
I created another one, I just copied the pictures from one to another Thas all and now its working for me
Here it is http://www.mediafire.com/?bxdsgnovxrl
Thanks a lot ! It works with your version ! Looks pretty nice :wink:

Thanks @cato` too for hosting files.

Enjoy !

PS : If someone can explain why it doesn't work with @sethleon version ...
_________________
La connaissance s'accroît quand on la partage.
JCB
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Mon Jun 25, 2007 2:51 pm    Post subject: Reply with quote

I don't know why but the file generated by his version is quite smaller than the other ones.
Back to top
View user's profile Send private message
sethleon
Guru
Guru


Joined: 14 Dec 2003
Posts: 394
Location: Germany

PostPosted: Sat Jun 30, 2007 9:15 pm    Post subject: Reply with quote

Maybe because the difference from version gfxboot-3.3.24-11.src.rpm to yours
has some tiny stupid changes that make it not really usable. :x
Same as problems earlier mentioned in this topic.
_________________
Mess with the best, die like the rest.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Mon Jul 02, 2007 8:54 am    Post subject: Reply with quote

just updated gfxboot ebuild in overlay on bugzilla
works fine for me

now compilation will be more fast
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Wed Jul 18, 2007 11:18 pm    Post subject: Reply with quote

hi, is there any way to decompile a file created with mkbootmsg? I'd like to use this theme but I want to have a gentoo logo instead of the debian one.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Thu Jul 19, 2007 1:31 am    Post subject: Reply with quote

Xaero, message file is cpio archive. so you can unpack it, exchange pictures and pack again
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Thu Jul 19, 2007 2:11 am    Post subject: Reply with quote

Rion wrote:
Xaero, message file is cpio archive. so you can unpack it, exchange pictures and pack again
ahh, many thanks! :)
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Thu Jul 19, 2007 3:27 am    Post subject: Reply with quote

Xaero wrote:
hi, is there any way to decompile a file created with mkbootmsg? I'd like to use this theme but I want to have a gentoo logo instead of the debian one.


thats weird, neither theme will work, the original or the modified one...on boot they both say "invalid file format". What could be causing this?
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 226
Location: Clarkston, Michigan

PostPosted: Thu Jul 19, 2007 4:46 am    Post subject: Reply with quote

Xaero wrote:
Xaero wrote:
hi, is there any way to decompile a file created with mkbootmsg? I'd like to use this theme but I want to have a gentoo logo instead of the debian one.


thats weird, neither theme will work, the original or the modified one...on boot they both say "invalid file format". What could be causing this?

I fixed it :) I unmerged grub and gfxboot and installed Ubuntu's grub-gfxboot package via dpkg and now it works.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 376
Location: Ekaterinburg, Russia

PostPosted: Thu Jul 19, 2007 1:19 pm    Post subject: Reply with quote

Xaero wrote:
I fixed it :) I unmerged grub and gfxboot and installed Ubuntu's grub-gfxboot package via dpkg and now it works.
i'll ivestigate this problem and probably make new patchset
i guess this is because of gfxboot ebuild from my overlay use latest nightly source packages. but maybe i'm wrong
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Hamsterkill
Tux's lil' helper
Tux's lil' helper


Joined: 01 Apr 2006
Posts: 81

PostPosted: Mon Aug 13, 2007 10:51 pm    Post subject: Reply with quote

So, I seem to have gfxboot working, however, I want to be able to have the penguins boot screen that comes with the Suse themes. I realized that when I try to remake the Suse installed themes, the gfxboot.cfg is not included in the message archive, nor are the penguins images. Anyone been able to enable this bootscreen in gfxboot yet or what?
Back to top
View user's profile Send private message
infinity9
n00b
n00b


Joined: 07 Jul 2006
Posts: 44
Location: Atlanta, GA

PostPosted: Sat Aug 18, 2007 9:18 pm    Post subject: Reply with quote

got gfxboot working--currently using the openSuSE theme for the time being.

does anyone know how to change the aspect ratio? my screen is 1680x1050, and GRUB would look noticeably better if i could change to that resolution.
_________________
"You cheese-eating...sideways monkeys!" -Jeremy Clarkson
Back to top
View user's profile Send private message
n3Cre0
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2007
Posts: 129

PostPosted: Mon Sep 17, 2007 10:40 am    Post subject: Reply with quote

Xaero wrote:
Xaero wrote:
hi, is there any way to decompile a file created with mkbootmsg? I'd like to use this theme but I want to have a gentoo logo instead of the debian one.


thats weird, neither theme will work, the original or the modified one...on boot they both say "invalid file format". What could be causing this?


Same problem here, I had to reinstall gentoo, and when setting up this gfxboot it also gave me "INVALID FILE FORMAT". I guess it's because I'm using the latest version (gfxboot-3.3.37-2.src.rpm), that it uses a new format and breaks the older themes?

Installing it now with the .deb from ubuntu (using alien and rpm, dpkg gives me an error...).
Error dpkg wrote:
# dpkg -i grub-gfxboot_0.97-5_i386.deb
dpkg: failed to open package info file `/var/lib/dpkg/available' for reading: No such file or directory


EDIT: Even installing the rpm doesn't work :(
Error rpm wrote:
# alien -r grub-gfxboot_0.97-5_i386.deb
grub-gfxboot-0.97-6.i386.rpm generated
# rpm -Uhv grub-gfxboot-0.97-6.i386.rpm
error: Failed dependencies:
/bin/sh is needed by grub-gfxboot-0.97-6.i386
libc.so.6 is needed by grub-gfxboot-0.97-6.i386
libc.so.6(GLIBC_2.0) is needed by grub-gfxboot-0.97-6.i386
libc.so.6(GLIBC_2.1) is needed by grub-gfxboot-0.97-6.i386
libc.so.6(GLIBC_2.2) is needed by grub-gfxboot-0.97-6.i386
libc.so.6(GLIBC_2.3) is needed by grub-gfxboot-0.97-6.i386
libncurses.so.5 is needed by grub-gfxboot-0.97-6.i386


EDIT#2: My bad, this worked
rpm installing wrote:
# rpm -Uvh --nodeps grub-gfxboot-0.97-6.i386.rpm
Preparing... ########################################### [100%]
1:grub-gfxboot ########################################### [100%]


EDIT#3: I rebooted and still got the same problemn, grrrr
Can anyone please, please post a working gfxboot-src?? I really want to get this working again
_________________
OS: Linux 2.6.26 i686 Gentoo v2.0.0 Sound: HDA Intel
CPU: Intel(R) Pentium(R) M processor 1.73GHz (GenuineIntel)
Disk: 95.23GB Video: ATI Radeon Mobility X700 XL with Catalyst 8.08 RAM: 1011MB
Back to top
View user's profile Send private message
Sno
n00b
n00b


Joined: 07 Mar 2005
Posts: 29

PostPosted: Thu Sep 20, 2007 4:26 am    Post subject: Reply with quote

you can't decompile but you can extract the jpegs to use on your own.

http://schmidt.devlib.org/software/jpeg-extractor.html

Works perfectly for me.

Edit: I found out how to decompile a gfxboot message file.

Quote:
mkdir /home/name/whatever
cpio -i < /boot/grub/message.suse # replace it by the name of you message
edit the pictures
sudo ls . |cpio -o > /boot/grub/message.new
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum