Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] MOL says "File is too large" & OSX 10
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mattdenner
n00b
n00b


Joined: 01 Feb 2005
Posts: 16

PostPosted: Mon Jul 04, 2005 3:15 pm    Post subject: [SOLVED] MOL says "File is too large" & OSX 10 Reply with quote

Final update on my progress with this: I got MacOSX 10.3.7 to install!

Here's what I did:

I was kindly given a new /usr/share/mol/0.9.7/drivers/bootx file by a guy on the MOL mailing list. Using this got me past the complaint about the file being too large but I still wasn't able to install MacOSX as it complained about "Bundled Software cannot be installed on this computer".

So I took an extreme approach and copied the DVD to a file on my harddisk:

Code:
dd if=/dev/cdroms/cdrom0 of=MacOSInstall.img


It's a DVD so be prepared, if you're mad enough to try this, and ensure you have enough disk space. I then mounted the file image:

Code:
mount -o loop --type=hfsplus MacOSInstall.img /mnt/macosx


And editted the following files:

    System/Installation/Packages/Bundled Software.mpkg/Contents/Info.plist
    System/Installation/Packages/.packages/CPU Help Files.mpkg/Contents/Info.plist
    System/Installation/Packages/.packages/AppleWorks Languages.mpkg/Contents/Info.plist


These files are XML and I removed the '<key>IFRequirementDicts</key>' and the element that immediately follows it. This seems to be controlling what the package needs from the hardware (Powerbook5,1 through to Powerbook5,7 on my OSX DVD), and by removing them I get to install them.

Then I had to make sure that my partition I wanted to install MacOSX on had the '-boot' parameter in /etc/mol/molrc.osx, and that the MacOSInstall.img file was the next blkdev (with options '-ro -force'). That way the MacOSX installer doesn't complain about not being able to install to the partition you want because you can't boot from it.

Anyway, I'm off for a play!

Matt

Old Post:

I've editted this post and kept the old one at the bottom. To cut a fairly long story short, it would appear that the problem lies with MOL, and particularly the /usr/share/mol/0.9.71pre1/drivers/bootx file. According to Mattias Nissler, on the MOL mailing list, it would appear that Apple changed their bootx loader to use 96MB of RAM rather than the 32MB they were using. Mattias kindly provided me with an updated version of this file that allows me to boot the OSX CD but, unfortunately, I'm now seeing "Bundled Software cannot be installed on this computer" in the OSX installer (so close!). I'm waiting to hear back from the MOL mailing list people to see if this can be worked around. I'll keep you all posted.

Matt

Old Old Post:

Hi,

I'm trying to get maconlinux to work on one of these new Powerbooks (the recent ones, Powerbook5,6) but I'm having a hell-of-a-time and I need some help. I'm running 2.6.12 kernel, mol 0.9.71pre1, and trying to install Mac OS version 10.3.7 (according to the CD, I've not had a full install of MacOSX since this Powerbook turned up and didn't keep it when I installed Gentoo). I'm trying to boot the CD to install MacOSX into a file based partition, /usr/share/mol/drives/macosx.img, that I've prepared with dd and hformat and is currently 256MB. As far as I can tell mol I've got mol configured to boot with this configuration:

Code:
Mac-on-Linux 0.9.71-pre1 [Jul 4 2005 15:37]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 1
Running in PowerPC 7400 mode, 512 MB RAM
Timebase: 18.43 MHz, Bus: 73.72 MHz, Clock: 1666 MHz
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Could not open '/var/lib/mol/x11.kbd'
Video driver(s): [xvideo]

     640* 480, depth 8,32   { 0.0 } Hz
     800* 600, depth 8,32   { 0.0 } Hz
    1024* 768, depth 8,32   { 0.0 } Hz
    1152* 864, depth 8,32   { 0.0 } Hz
    1280*1024, depth 8,32   { 0.0 } Hz
    1600*1200, depth 8,32   { 0.0 } Hz

DHCP nameserver exported: 212.42.162.1
Ethernet Interface 'tun-<tun1>' @ 00:00:0D:EA:DB:EE

    ip/mask: 192.168.41.2/255.255.255.0  gw: 192.168.41.1
    broadcast: 192.168.41.255  nameserver: 192.168.41.1


    CD    /dev/cdrom       CD/DVD         <read-only>   ------ BOOT1
    HFS   /usr/share/mol.. MacOSX Disk    <rw>  256 MB

SCSI devices:

    [SCSI auto-probing disabled]

    Generic SCSI for CD/DVDs disabled
    <No SCSI Devices>

>> ==================================================
>> MacOS X Boot Loader 0.9.70
>> Candidate boot volume: /mol-blk@0/disk@1:3
>> /mol-blk@0/disk@1:3,\mach_kernel (3867776 bytes)
>> /mol-blk@0/disk@1:3,\System\Library\Extensions.mkext
>> File is too large.
>> Failed to load mkext!
>> Loading from /mol-blk@0/disk@1:3,\System\Library\
>> ==================================================

X connection to :0.0 broken (explicit kill or server shutdown).
cleaning up...
Terminating threads...
DONE


But you can see my problem: there, at the bottom of the output, you see it says "File is too large" and "Failed to load mkext".

Can someone please help me out with getting this to work, or at least telling me with any confidence that it's something to do with the fact that this is a new Powerbook, because I see loads of people raving about having mol installed and yet I can't!

Matt

Update: Hmm, maybe it's the same problem seen in MOL: File too large, failed to load mkext ERROR? as I would assume that the Mac Mini and the new Powerbook share the same MacOSX install media?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum