Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sommige apps emergen geeft een segfault [OPGELOST]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Fri Jul 15, 2005 7:11 am    Post subject: sommige apps emergen geeft een segfault [OPGELOST] Reply with quote

als ik grote spullen (zoals KDE of PHP (is nu ook niet ZO groot)) emerge geven die snel een foutje en kan ik opnieuw beginnen
het rare is dat als ik naar de directory zelf ga een 'make all' doe dat ze ni zo makkelijk een segfault geven
ik heb al de temperatures van m'n pc nagekeken, er is geen deel da overhit ofzo
Gentoo loopt ook rap vast als ik in X zit, meestal terwijl ik iets aan het emergen ben
nu dat dit enorm lastig is weet ik wel, anders kom ik da hier ni posten
maar weet iemand hoe dit zou kunnen komen en me hieruit kunne helpen?

(emerge log : )
Code:
gcc -DSUPPORT_UTF8 -DSUPPORT_UCP -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10 -DMATCH_LIMIT=10000000 -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/pcrelib -Iext/pcre/ -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/ -DPHP_ATOM_INC -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/include -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/main -I/var/tmp/portage/php-4.4.0/work/php-4.4.0 -I/usr/include/libxml2 -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/mbregex -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/libmbfl -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/libmbfl/mbfl -I/usr/include/pspell -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/xml/expat -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/TSRM -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/Zend    -O2 -march=athlon-xp -fomit-frame-pointer  -c /var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/pcrelib/study.c -o ext/pcre/pcrelib/study.o  && echo > ext/pcre/pcrelib/study.lo
gcc -DSUPPORT_UTF8 -DSUPPORT_UCP -DLINK_SIZE=2 -DPOSIX_MALLOC_THRESHOLD=10 -DMATCH_LIMIT=10000000 -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/pcrelib -Iext/pcre/ -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/ -DPHP_ATOM_INC -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/include -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/main -I/var/tmp/portage/php-4.4.0/work/php-4.4.0 -I/usr/include/libxml2 -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/mbregex -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/libmbfl -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/mbstring/libmbfl/mbfl -I/usr/include/pspell -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/xml/expat -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/TSRM -I/var/tmp/portage/php-4.4.0/work/php-4.4.0/Zend    -O2 -march=athlon-xp -fomit-frame-pointer  -c /var/tmp/portage/php-4.4.0/work/php-4.4.0/ext/pcre/pcrelib/pcre.c -o ext/pcre/pcrelib/pcre.o  && echo > ext/pcre/pcrelib/pcre.lo
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.
make: *** [ext/pcre/pcrelib/pcre.lo] Error 1

!!! ERROR: dev-php/php-4.4.0 failed.
!!! Function php-sapi_src_compile, Line 521, Exitcode 2
!!! compile problem
!!! If you need support, post the topmost build error, NOT this status message.



Last edited by GuntherDW on Fri Jul 29, 2005 9:53 am; edited 1 time in total
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Fri Jul 15, 2005 8:59 am    Post subject: Reply with quote

Klinkt als een hardware probleem (die komen meestal boven bij grote compiles). Ik raad je aan om memtest voor een nachtje te runnen ofzo. Memtest staat op de livecd.
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Fri Jul 15, 2005 11:09 am    Post subject: Reply with quote

kan, kan ook een gcc probleem zijn, of te agressieve CFLAGS / LDFLAGS in je make.conf

post je emerge info eens?
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Fri Jul 15, 2005 4:14 pm    Post subject: Reply with quote

kgebruik default flags van een stage3 install
(buiten ACCEPT_KEYWORD="~x86")

kheb memtest al een paar uurtjes laten draaien, en em kwam met niets naar boven
hoe lang zou ik da moeten laten runnen? (kheb 786 MB DDR 266Mhz)
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Jul 15, 2005 4:32 pm    Post subject: Reply with quote

memtest moet je iedere test minimaal 3 keer laten uitvoeren wil je een beetje zekerheid hebben.
Controleer ook even hoeveel swap je hebt en hoeveel er gebruikt wordt.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
garo
Bodhisattva
Bodhisattva


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Fri Jul 15, 2005 5:50 pm    Post subject: Reply with quote

Er is een groot nadeel aan memtest: je kan er mee bewijzen dat geheugen stuk is maar je kan er niet mee bewijzen dat het perfect werkt. :(
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Sat Jul 16, 2005 1:27 pm    Post subject: Reply with quote

ik heb 512 MB swap enabled staan
nu zit ik wel in sunparcs en kan ik ni aan m'n pc thuis
ik ben aanstaande vrijdag thuis, maar dan zal ik zeker deze thread nog eens bekijken :)
(belgacom hotspot en laptopje met wireless onboard)
Back to top
View user's profile Send private message
Braempje
l33t
l33t


Joined: 31 Jan 2003
Posts: 748

PostPosted: Fri Jul 22, 2005 2:09 pm    Post subject: Reply with quote

Dat is gegarandeerd een hardwareprobleem. Ik gok op een processor die last heeft gekregen van de warmte, geloof me zulke dingen gebeuren :?
_________________
Dictionary of the Flemish Sign Language - Woordenboek Vlaamse Gebarentaal
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Fri Jul 22, 2005 4:42 pm    Post subject: Reply with quote

maar em gaat tot max 48C° stressed
meestal is het maar 42C°
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Fri Jul 22, 2005 11:30 pm    Post subject: Reply with quote

doeme, nu heeft em het weer voor

Code:
  transformation: 0.003000, building DFA: 0.004000
  DFA minimization: 0.000000, making insn equivalence: 0.000000
 all automaton generation: 0.004999, output: 0.005999
/bin/sh /var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/move-if-change tmp-attrtab.c insn-attrtab.c
echo timestamp > s-attrtab
stage1/xgcc -Bstage1/ -B/usr/i686-pc-linux-gnu/bin/    -O2 -march=athlon-xp -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wtraditional -pedantic -Wno-long-long   -DHAVE_CONFIG_H    -I. -I. -I/var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/gcc -I/var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/. -I/var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/config -I/var/tmp/portage/gcc-3.3.6/work/gcc-3.3.6/gcc/../include -c insn-attrtab.c \
  -o insn-attrtab.o
insn-attrtab.c: In function `internal_dfa_insn_code':
insn-attrtab.c:6390: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [insn-attrtab.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/gcc-3.3.6/work/build/gcc'
make[1]: *** [stage2_build] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-3.3.6/work/build/gcc'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-3.3.6 failed.
!!! Function gcc_do_make, Line 1214, Exitcode 2
!!! emake failed with bootstrap-lean
!!! If you need support, post the topmost build error, NOT this status message.

linuxbox1 apache2 # sensors
w83697hf-isa-0290
Adapter: ISA adapter
VCore:     +1.74 V  (min =  +1.71 V, max =  +1.89 V)             
+3.3V:     +2.69 V  (min =  +3.14 V, max =  +3.47 V)             
+5V:       +4.54 V  (min =  +4.76 V, max =  +5.24 V)             
+12V:     +11.19 V  (min = +10.82 V, max = +13.19 V)             
-12V:      +0.22 V  (min = -13.18 V, max = -10.80 V)             
-5V:       +1.53 V  (min =  -5.25 V, max =  -4.75 V)             
V5SB:      +5.30 V  (min =  +4.76 V, max =  +5.24 V)       ALARM 
VBat:      +0.00 V  (min =  +2.40 V, max =  +3.60 V)             
fan1:     5400 RPM  (min = 112500 RPM, div = 2)              ALARM 
fan2:        0 RPM  (min = 168750 RPM, div = 2)                     
temp1:       +34 C  (high =   +12 C, hyst =   +24 C)   sensor = PII/Celeron diode           
temp2:     +38.5 C  (high =  +120 C, hyst =  +120 C)   sensor = PII/Celeron diode


(temp2 = cpu)
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Jul 23, 2005 8:48 am    Post subject: Reply with quote

Post de output van emerge info eens
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Sat Jul 23, 2005 12:29 pm    Post subject: Reply with quote

wauw, systeem van je loopt lekker koel...

temperature: 46 C

in idle stand.... Atlhon denk ik...

Maar voor je probleem... Ik ben bang dat je iets hebt wat men een "b0rked toolchain" noemt.

Probeer in ieder geval eens de toolchain te her-emergen.

zie https://forums.gentoo.org/viewtopic-t-282474.html
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Sun Jul 24, 2005 10:21 pm    Post subject: Reply with quote

het lag toch zoals ik al van het begin eigenlijk vermoedde aan m'n harde schijft

(ik heb 120GB + 250GB)
die van 120 GB is nu uit m'n pctje en ligt hier in de kast :p
maar da voelt ge imo toch wel ff ze , 120 GB minder :)

nu loopt ie stabiel :)

(HD maakte luide 'tik' als ie een spinup moest doen of bij opstarten (bioscheck))
Back to top
View user's profile Send private message
chratnox
n00b
n00b


Joined: 04 Aug 2004
Posts: 11
Location: Netherlands

PostPosted: Mon Jul 25, 2005 3:33 am    Post subject: Reply with quote

Een schijf die een 'tik' maakt is sowieso niet bepaald goed, heb je geen garantie meer op dat ding? Zo ja, terugbrengen die hap.. de schijf is kapot of staat op het punt je meer problemen te geven dan ie al deed :)
Back to top
View user's profile Send private message
racoontje
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1290

PostPosted: Thu Jul 28, 2005 8:09 am    Post subject: Reply with quote

Krijgen we nog een emerge --info of hoe zit dat?

BTW, hoge temperatuur kan wel instabiliteit tot gevolg hebben, maar instabiliteit is niet noodzakelijk het gevolg van hoge temperatuur :-)
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Fri Jul 29, 2005 9:45 am    Post subject: Reply with quote

m'n partitie is een paar dagen geleden fubar gegaan, em eeft zowa 3/4 dage aan een fsck bezig gezeten, om uiteindelijk te zien da alles in lost+found zat :(
kheb gewoon een nieuwe format erop gezwierd (mkfs.ext3), en nu loopt ie goe stabiel :))
ma kben wel alles kwijt :(

edit : ge wou een emerge --info?

Code:
bash-2.05b# emerge --info
Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.12.3 i686)
=================================================================
System uname: 2.6.12.3 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 11 2005, 00:07:42)]
dev-lang/python:     2.3.4-r1
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts crypt cups emboss encode fam foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imlib ipv6 jpeg kde libg++ libwww mad mikmod motif mp3 mpeg ncurses nls ogg oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl spell ssl tcpd tiff truetype truetype-fonts type1-fonts vorbis xml2 xmms xv zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

bash-2.05b#
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Fri Jul 29, 2005 5:59 pm    Post subject: Reply with quote

GuntherDW wrote:
m'n partitie is een paar dagen geleden fubar gegaan, em eeft zowa 3/4 dage aan een fsck bezig gezeten, om uiteindelijk te zien da alles in lost+found zat :(
kheb gewoon een nieuwe format erop gezwierd (mkfs.ext3), en nu loopt ie goe stabiel :))
ma kben wel alles kwijt :(

Ik zou je harde schijf maar eens controleren op bad sectors: e2fsck -c /dev/hdaX, waarbij X een partitienummer is.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
GuntherDW
n00b
n00b


Joined: 20 Nov 2003
Posts: 32
Location: Belgium

PostPosted: Sat Jul 30, 2005 3:07 am    Post subject: Reply with quote

da haddek al gedaan, die gaf geen bad blocks weer :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum