Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]xterm, macmini and cflags
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ErniBrown
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 276
Location: Seconda stella a destra e poi dritto fino al mattino...

PostPosted: Sat Jul 16, 2005 10:42 am    Post subject: [SOLVED]xterm, macmini and cflags Reply with quote

On my macmini everything compiled well, but when i try to compile xterms:
Code:
gcc -I. -I. -DHAVE_CONFIG_H  -I/usr/include -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include  -DNARROWPROTO=1 -DFUNCPROTO=15 -DOSMAJORVERSION=2 -DOSMINORVERSION=6  -D_GNU_SOURCE -DXTSTRINGDEFINES  -O2 -mcpu=7450 -maltivec -mabi=altivec -mpowerpc-gfxopt -pipe -W -Wall -Wbad-function-cast -Wcast-align -Wcast-qual -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wshadow -Wstrict-prototypes -Wundef -c ./data.c
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
cc1: error: invalid option `altivec'
cc1: error: invalid option `abi=altivec'
cc1: error: invalid option `powerpc-gfxopt'
./cursor.c:1: error: bad value (7450) for -mtune= switch
distcc[11601] ERROR: compile ./cursor.c on 192.168.0.2/5 failed
make: *** [cursor.o] Error 1
make: *** Waiting for unfinished jobs....
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
cc1: error: invalid option `altivec'
cc1: error: invalid option `abi=altivec'
cc1: error: invalid option `powerpc-gfxopt'
./data.c:1: error: bad value (7450) for -mtune= switch
distcc[11603] ERROR: compile ./data.c on 192.168.0.2/5 failed
make: *** [data.o] Error 1
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
cc1: error: invalid option `altivec'
cc1: error: invalid option `abi=altivec'
cc1: error: invalid option `powerpc-gfxopt'
./charsets.c:1: error: bad value (7450) for -mtune= switch
distcc[11600] ERROR: compile ./charsets.c on 192.168.0.2/5 failed
make: *** [charsets.o] Error 1

Maybe my cflags are wrong? This is what i get from /proc/cpuinfo:
Code:
Lucy erni # cat /proc/cpuinfo
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1249MHz
revision        : 1.2 (pvr 8003 0102)
bogomips        : 1245.18
machine         : PowerMac10,1
motherboard     : PowerMac10,1 MacRISC3 Power Macintosh
detected as     : 287 (Unknown Intrepid-based)
pmac flags      : 00000000
L2 cache        : 512K unified
memory          : 512MB
pmac-generation : NewWorld

and this is my make.conf
Code:
Lucy erni # cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -mpowerpc-gfxopt -pipe"
CHOST="powerpc-unknown-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"
FEATURES="distcc"
USE="X altivec cdr cups dvd java kde nptl nptlonly usb -ipv6 -gnome -gtk"
GENTOO_MIRRORS="http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gentoo"
PORTDIR_OVERLAY=/usr/local/portage
DISTDIR="/var/tmp/portage/distfiles"

_________________
There are 10 kind of people:
those who understand binaries and
those who don't.


Last edited by ErniBrown on Sat Jul 16, 2005 11:07 am; edited 1 time in total
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Sat Jul 16, 2005 10:55 am    Post subject: Reply with quote

Code:
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.


i saw that new stages use mtune, have a try.
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
ErniBrown
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 276
Location: Seconda stella a destra e poi dritto fino al mattino...

PostPosted: Sat Jul 16, 2005 11:06 am    Post subject: Reply with quote

same error, but I was able to compile disabling distcc 8O

Why distcc can't use those cflags ONLY for xterm?!
_________________
There are 10 kind of people:
those who understand binaries and
those who don't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum