Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Portage suddenly won't compile anything
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Jul 19, 2005 12:14 am    Post subject: [SOLVED] Portage suddenly won't compile anything Reply with quote

I don't know what the reason for this is, but all of the sudden, Portage won't install anything. It either hangs after unpacking the source files, or after adding the patches. When I run 'top' it shows me a process called 'powerpc-unknown' that uses 100% CPU, but this proces is niced so the system is still responsive and I can kill Portage with crtl+c. Here's my emerge info:

Code:

Portage 2.0.51.22-r1 (default-linux/ppc/2005.0, gcc-3.4.4, glibc-2.3.5-r0, 2.6.11-gentoo-r10 ppc)
=================================================================
System uname: 2.6.11-gentoo-r10 ppc 7447A, altivec supported
Gentoo Base System version 1.6.12
powerpc-unknown-linux-gnu-gcc (GCC) 3.4.4 (Gentoo 3.4.4, ssp-3.4.4-1.0, pie-8.7.8) [enabled]
dev-lang/python:     2.3.5, 2.4.1
sys-apps/sandbox:    1.2.8
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=7400 -mtune=G4 -maltivec -mabi=altivec -ffast-math -mpowerpc-gfxopt -fomit-frame-pointer -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=7400 -mtune=G4 -maltivec -mabi=altivec -ffast-math -mpowerpc-gfxopt -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distcc distlocks nodoc noinfo"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="ppc X alsa altivec arts cdr crypt cups dbus dv dvd exif flac gif gphoto2 hal java jpeg kde kdeenablefinal mad mp3 mpeg nptl ogg oggvorbis opengl pic png ppds qt qt-mt quicktime samba ssl tiff truetype unicode usb vorbis xine xv xvid linguas_de userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LDFLAGS


I first thought it was my kernel, 2.6.12-r6, but I reverted back to the old 2.6.11-r10 and it's still the same. This happens to all packages, big one, small ones - everything! I'm really lost, what could I do???


Tom


Last edited by fourhead on Tue Jul 19, 2005 9:42 am; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jul 19, 2005 1:27 am    Post subject: Reply with quote

Well, that process is probably gcc, it's real name is your CHOST powerpc-unknown-linux-gnu and the name of the application, like gcc. So it's powerpc-unknown-linux-gnu-gcc for instance.

I'm not sure why it's locking up on you, are there any errors in dmesg?
How about incorrect permissions on /dev/null?
Is there anything in your overlay directory that's screwing things up? (profiles?)
Can you compile applications outside of portage?
Are you using a shell other than bash?

These are only a few ideas, it's hard to say without more information.

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Jul 19, 2005 9:03 am    Post subject: Reply with quote

Hi, okay I checked all your suggestions:

/dev/null is chowned root:root and has 666 permissions.
There are no errors in dmesg
I don't have anything in the overlay directory on this computer
I'm using bash :-(

I'll try to compile a little program for myself and see if that works. Is there anything that you would need to know to find out more about this?


Thanks so far!

Tom
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Jul 19, 2005 9:07 am    Post subject: Reply with quote

Hmm well at least I can compile a very simple main.c that I just wrote. I'll see if I find something more complex which I can quickly try to compile ...


Tom
Back to top
View user's profile Send private message
fourhead
l33t
l33t


Joined: 03 Sep 2003
Posts: 875
Location: Cologne, Germany

PostPosted: Tue Jul 19, 2005 9:41 am    Post subject: Reply with quote

Damn, I 'solved' it. Distcc was the bad guy, I disabled it and now it works. I had set up distcc between my ppc and my amd64 box, but crossdev did never manage to compile gcc on the ppc box, so the whole crossdev toolchain was broken, and distcc didn't like that obviously.


Thanks for your help though!


Tom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum