Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with a block [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Fri Jul 22, 2005 7:57 pm    Post subject: Problem with a block [SOLVED] Reply with quote

What to do? :oops:

Code:
# emerge -upD world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!

[blocks B     ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.7-r3)


Last edited by zeuz on Fri Jul 22, 2005 10:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
LoDown
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 189
Location: Louisville, Ky

PostPosted: Fri Jul 22, 2005 8:03 pm    Post subject: Reply with quote

What I have done in a similar situation in the past is to unmerge the file that is blocking.
Code:
emerge --unmerge pam-login

HOWEVER, I am not sure if this is the best plan of action, it is just what has worked for me. Also, doing this could seriously break other things that rely on the package you unmerge.
_________________
Please remember to add [SOLVED] to your topic subject line when it is solved.


Last edited by LoDown on Fri Jul 22, 2005 8:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43016
Location: 56N 3W

PostPosted: Fri Jul 22, 2005 8:05 pm    Post subject: Reply with quote

zeuz

Code:
emerge -C sys-apps/pam-login -p
and check that only sys-apps/pam-login will be removed.
Now di it with out the -p to remove it.
Do not logout until you have completed the emerge of sys-apps/shadow.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Fri Jul 22, 2005 8:09 pm    Post subject: Reply with quote

That solved it, thanks. :)
Back to top
View user's profile Send private message
LoDown
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 189
Location: Louisville, Ky

PostPosted: Fri Jul 22, 2005 8:18 pm    Post subject: Reply with quote

Could you put [SOLVED] in the subject line then? That way it will help people find solutions easier when they search...(if they search, which most people don't)
_________________
Please remember to add [SOLVED] to your topic subject line when it is solved.
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Fri Jul 22, 2005 10:34 pm    Post subject: Reply with quote

This is just my luck...

I ran the emerge -uD world on this box trough ssh and it crashed! Now i can't log in to the gentoo box! :lol: :cry: Is there any other way than re-installing gentoo to solve this?
Back to top
View user's profile Send private message
LoDown
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 189
Location: Louisville, Ky

PostPosted: Fri Jul 22, 2005 10:45 pm    Post subject: Reply with quote

Get the liveCD, and boot that way. Then 'chroot' into your existing installation, and you can emerge --update world (hopefully). If not, you will still be able to access your installation through the LiveCD, and fix all the problems until you can log in normally again. So no, you woulda had to screwed up REALLY badly to need to re-install...
_________________
Please remember to add [SOLVED] to your topic subject line when it is solved.
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Fri Jul 22, 2005 10:51 pm    Post subject: Reply with quote

Thanks again! :)
Back to top
View user's profile Send private message
zeuz
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 140
Location: Sweden

PostPosted: Fri Jul 29, 2005 10:24 am    Post subject: Reply with quote

Solved it, but while running emerge -u system the last few hundred megs of space got used up. What can i clean in order to get space? I know some logs thats getting big in /var/log and what about the directory that holds the emerge files?

Even after checking https://forums.gentoo.org/viewtopic-t-30547.html It's still at 100% usage...
Back to top
View user's profile Send private message
LoDown
Apprentice
Apprentice


Joined: 26 Oct 2004
Posts: 189
Location: Louisville, Ky

PostPosted: Fri Jul 29, 2005 4:44 pm    Post subject: Reply with quote

You can clean out /var/portage if there is anything in there....
_________________
Please remember to add [SOLVED] to your topic subject line when it is solved.
Back to top
View user's profile Send private message
meta
n00b
n00b


Joined: 22 Aug 2003
Posts: 45
Location: Cambridge MA

PostPosted: Wed Aug 31, 2005 5:22 pm    Post subject: I had this problem, and lived Reply with quote

It's worth pointing out that you should unmerge pam-login, emerge shadow, then emerge pam-login again.

Pretty nerve-wracking, as I'm in Austin TX and the machine with the problem was in Cambridge MA, so rebooting with a live CD wouldn't have been a very workable option...
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1497
Location: Oxfordshire, UK

PostPosted: Wed May 31, 2006 3:39 pm    Post subject: Re: I had this problem, and lived Reply with quote

meta wrote:
It's worth pointing out that you should unmerge pam-login, emerge shadow, then emerge pam-login again.


Not from what I can see......

When you try and emerge pam-login after shadow you get:

Code:
# emerge pam-login -av

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] >=sys-apps/shadow-4.0.14-r2 (is blocking sys-apps/pam-login-4.0.14)
[ebuild  N    ] sys-apps/pam-login-4.0.14  -livecd +nls (-selinux) -skey 1,217 kB

Total size of downloads: 1,217 kB
Back to top
View user's profile Send private message
AnalogKid
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jan 2006
Posts: 83

PostPosted: Wed May 31, 2006 4:23 pm    Post subject: Reply with quote

I had this same issue this morning.
I unmerged pam-login, then emerged sys-apps/shadow <-- no problems so far.

Then I went to emerge pam-login again and get this:
Quote:
# emerge pam-login -p

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] >=sys-apps/shadow-4.0.14-r2 (is blocking sys-apps/pam-login-4.0.14)
[ebuild N ] sys-apps/pam-login-4.0.14
Back to top
View user's profile Send private message
electrofreak
l33t
l33t


Joined: 30 Jun 2004
Posts: 713
Location: Ohio, USA

PostPosted: Wed May 31, 2006 7:55 pm    Post subject: Reply with quote

great, I'm faced with this problem right now, and I didn't read through all this post. What do I do if that happens to me? I'm emerging shadow right now.

This whole thing seems like a problem...

Edit, yeah... it just happened. Crap, what do I do!?
_________________
Desktop: ABit AN8, Athlon64 X2 4400+ 939 2.75GHz, 2x1GB Corsair XMS DDR400, 2x160GB SATA RAID-0, 2x20"W, Vista Ultimate x64
Laptop: 15.4" MacBook Pro 2.4Ghz, 2x1GB RAM, 160GB, Mac OS X 10.5.1
Server: PIII 550Mhz, 3x128MB RAM, 160GB, Ubuntu Server 7.10
Back to top
View user's profile Send private message
ikshaar
Veteran
Veteran


Joined: 23 Jul 2002
Posts: 1339
Location: Baltimore, MD

PostPosted: Wed May 31, 2006 8:11 pm    Post subject: Reply with quote

Can someone confirm that pam-login should be definitively remove and that it's ok ?

I am a bit nervous...
_________________
"May God stands between you and harm in all the empty places where you must walk" - Babylon 5
Back to top
View user's profile Send private message
electrofreak
l33t
l33t


Joined: 30 Jun 2004
Posts: 713
Location: Ohio, USA

PostPosted: Wed May 31, 2006 8:21 pm    Post subject: Reply with quote

I just asked on IRC and people say to remove shadow, update portage (sync), and emerge pam-login, and I guess it will emerge shadow again...

I'm working on syncing right now. I'm basically committed at this point, so I definitely need to get it all working.
_________________
Desktop: ABit AN8, Athlon64 X2 4400+ 939 2.75GHz, 2x1GB Corsair XMS DDR400, 2x160GB SATA RAID-0, 2x20"W, Vista Ultimate x64
Laptop: 15.4" MacBook Pro 2.4Ghz, 2x1GB RAM, 160GB, Mac OS X 10.5.1
Server: PIII 550Mhz, 3x128MB RAM, 160GB, Ubuntu Server 7.10
Back to top
View user's profile Send private message
ikshaar
Veteran
Veteran


Joined: 23 Jul 2002
Posts: 1339
Location: Baltimore, MD

PostPosted: Wed May 31, 2006 8:39 pm    Post subject: Reply with quote

Was there any update done in last hour ? cause I just sync my tree... and I am still stuck.

I removed old shadow and pam-login, emerge new shadow... and now I cannot emerge pam-login. And emerging pam-login without shadow was blocked too. So I don't see much solution in their recommendation.
_________________
"May God stands between you and harm in all the empty places where you must walk" - Babylon 5
Back to top
View user's profile Send private message
electrofreak
l33t
l33t


Joined: 30 Jun 2004
Posts: 713
Location: Ohio, USA

PostPosted: Wed May 31, 2006 9:44 pm    Post subject: Reply with quote

darn it... thanks for the warning...

I really need to get this fixed tonight. I don't want the chance of it crashing then screwing me, because it's located at my brother's place which isn't all so close.
_________________
Desktop: ABit AN8, Athlon64 X2 4400+ 939 2.75GHz, 2x1GB Corsair XMS DDR400, 2x160GB SATA RAID-0, 2x20"W, Vista Ultimate x64
Laptop: 15.4" MacBook Pro 2.4Ghz, 2x1GB RAM, 160GB, Mac OS X 10.5.1
Server: PIII 550Mhz, 3x128MB RAM, 160GB, Ubuntu Server 7.10
Back to top
View user's profile Send private message
andyrewbobb
n00b
n00b


Joined: 27 Jun 2005
Posts: 14
Location: Missouri, US

PostPosted: Thu Jun 01, 2006 2:27 am    Post subject: Reply with quote

Code:
emerge -C pam-login

it has worked for me so far...
I can log in/out normally, no problems...
Back to top
View user's profile Send private message
CrazyTerabyte
Apprentice
Apprentice


Joined: 30 Dec 2004
Posts: 192
Location: Brazil

PostPosted: Thu Jun 01, 2006 3:03 am    Post subject: Reply with quote

Watch out! Unmerging pam-login won't work! Read this another forum topic.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Jun 01, 2006 4:54 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See https://forums.gentoo.org/viewtopic-t-443022.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum