Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't emerge kde-base/kxsldt-3.4.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Guinpen
Guru
Guru


Joined: 08 Dec 2004
Posts: 393

PostPosted: Sat Jul 23, 2005 10:29 pm    Post subject: Can't emerge kde-base/kxsldt-3.4.1 Reply with quote

Hi,
Attempting to emerge kxsldt fails with:
Code:

/bin/sh ../../../libtool --silent --mode=compile --tag=CXX i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../..  -DDOCS_PATH=\"/usr/kde/3.4/doc/xsldbg\" -I.. -I/usr/include/libxml2 -I/usr/kde/3.4/include -I/usr/qt/3/include -I.  -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentium-m -mtune=pentium-m -pipe -ftracer -fomit-frame-pointer -ffast-math -momit-leaf-frame-pointer -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DENABLE_CVSSERVICE  -c -o xsldbgthread.lo `test -f 'xsldbgthread.cpp' || echo './'`xsldbgthread.cpp
In file included from xsldbgthread.cpp:20:
xsldbg.h:59:9: #error "WITH_DEBUGGER MACRO not defined in libxslt maybe you've disable debugger in libxslt." "if your are sure then disable this check by defining WITH_FORCE_DEBUGGER. eg.\n" "\nmake CFLAGS=\"$CFLAGS -D FORCE_DEBUGGER\""
make[4]: *** [xsldbgthread.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/kxsldbg-3.4.1/work/kxsldbg-3.4.1/kxsldbg/kxsldbgpart/libxsldbg'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kxsldbg-3.4.1/work/kxsldbg-3.4.1/kxsldbg/kxsldbgpart'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kxsldbg-3.4.1/work/kxsldbg-3.4.1/kxsldbg'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kxsldbg-3.4.1/work/kxsldbg-3.4.1'
make: *** [all] Error 2

!!! ERROR: kde-base/kxsldbg-3.4.1 failed.
!!! Function kde_src_compile, Line 164, Exitcode 2
!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, NOT this status message.


How could I fix the problem? Thanks!
Back to top
View user's profile Send private message
jmbsvicetto
Moderator
Moderator


Joined: 27 Apr 2005
Posts: 4734
Location: Angra do Heroísmo (PT)

PostPosted: Sun Jul 24, 2005 2:15 am    Post subject: Reply with quote

Hi.

First, you don't have a problem with kxsldt but with kxsldbg.
Second, if you searched this forum for an error with this package, you'd find this thread.
Does this help?

PS - I'm going to ask a moderator to move this thread to the Duplicate Threads forum.
_________________
Jorge.

Your twisted, but hopefully friendly daemon.
AMD64 / x86 / Sparc Gentoo
Help answer || emwrap.sh
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Sun Jul 24, 2005 7:13 am    Post subject: Reply with quote

Thanks jmbsvicetto!

Please follow up to the above mentioned thread.

Moved from Portage & Programming to Duplicate Threads.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum