Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache2 can't load mod_php [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Mon Jul 25, 2005 2:34 pm    Post subject: Apache2 can't load mod_php [SOLVED] Reply with quote

Here is the error I'm getting error_log:
Syntax error on line 6 of /usr/lib/apache2/conf/modules.d/70_mod_php.conf:
Cannot load /usr/lib/apache2/extramodules/libphp4.so into server: /usr/X11R6/lib/libjpeg.so.62: R_PPC_REL24 relocation at 0x0cfed1fc for symbol `memset' out\
of range

I've tried unmerging and re-merging and no luck. I found an old PPC mod_php bug in Bugzilla with a similar error, but the resolution was to remove imap from the USE flags. I don't have imap enabled. I did try removing jpeg support from mod_php since the error refers to a jpeg library, but no luck. Anyone with ideas, please speak up.
TIA
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Tue Jul 26, 2005 2:16 pm    Post subject: Reply with quote

I tried re emerging mod_php, apache and php, but I kept getting the same error. So after doing some googling, I found some old posts on the php web site that suggested compiler flags were the issue and that -fPIC should be used for PPC builds of mod_php. After rebuilding mod_php using that additional flag, things still did not work, and I got a similar error, this time pointing to libfreetype as the culprit and malloc being the function that was out of range. So next I look through make.conf and read the comments more carefully and so I removed -fPIC from the flags and changed flags altogether. I was using
CFLAGS="-O2 -pipe -mcpu=750"

but switched to
CFLAGS="-O2 -pipe -mmultiple -mstring"

Then I re emerged freetype and now things are good.
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum