Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Yet another NETMOUNT // DHCP problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mrfinch
n00b
n00b


Joined: 14 Mar 2005
Posts: 11
Location: Bristol, England

PostPosted: Mon Jul 25, 2005 3:38 pm    Post subject: Yet another NETMOUNT // DHCP problem Reply with quote

Hey!

Decided to install gentoo (2.6.12-r6) on my desktop, managed to get as far as rebooting after sorting out grub, all ofcourse with working Internet access.

Went to emerge KDE and I got errors and abortion. After looking around the forums I found out my Internet was not being detected.

I didn't notice the following until I rebooted:

Quote:
Starting ETH0
Bringing up ETH0
DHCP - Running DHCPCD ...
No loaded modules provide "dhcp" (dhcp_start)
ERROR: Problem starting needed services.
"Netmount" was not started.


In my /etc/conf.d/net I have the following:

Quote:
#config_eth0=("dhcp")
iface_eth0="dhcp"

dhcpcd_eth0="-HD"
dhcpcd_eth0="-N"


Commented 'config_eth0' as I read that using iface_eth0 was a better method, kept it in there just in case.

I have emerged dhcpcd whilst in the LiveCD environment, just in case you want to know.


In the /etc/modules.autoload.d/kernel-2.6 I have added 'natsemi' and '8139too' - although I don't know which to use, I added these by reading through this HOWTO, scroll down to find Praxxis' 'make menuconfig' post, I tried that with no joy.


I am very new (few hours into it) to Linux and Gentoo, so any commands I may need to use will have to be told to me in ultimate newbie terms!

If it helps, the ethernet card I am using is a Realtek SemiConducter, pretty common I think.

Oh, and ifconfig outputs:

Quote:
lo
Link Encap: Local Loopback
inet addr:127.0.0.1 - Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX Packets/etc/etc/etc:0
TX Packets/etc/etc/etc:0


No mention of eth0 as it does in the LiveCD environment.


Thanks for advance for any help.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Jul 25, 2005 4:25 pm    Post subject: Reply with quote

Please follow up here: https://forums.gentoo.org/viewtopic-t-332982.html

Moved from Installing Gentoo to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum