Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ext3 can't load, superblock corrupt?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
jessicavampirehunter
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2005
Posts: 79
Location: Portland, OR

PostPosted: Tue Jul 26, 2005 5:41 pm    Post subject: ext3 can't load, superblock corrupt? Reply with quote

So I installed Gentoo on my laptop, fixing things that went wrong, and everything seemed OK (except for the installation docs being out of date), but when I rebooted, it got as far as checking the filesystems and failed. I've been looking around the forums, and the consensus solution to this problem seems to be "your fstab is wrong" or "your grub.conf is wrong", but both of those things seem to be OK to me...

The error message:

Checking root filesystem...ok
fsck.ext3: No such file or directory while trying to open /dev/ROOT
/dev/ROOT:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

*Filesystem couldn't be fixed :( [!!]
Give root password for maintenance
(or type Control-D to continue):

Does "a correct ext2 filesystem" refer to ext2 only or ext3 too (since it's basically ext2 + journal)?

When I boot off a LiveCD and tell the system "mount /dev/hda3 /mnt/gentoo", it complains:
EXT2-fs warning (device hda3): ext2_fill_super: mounting ext3 filesystem as ext2

My fstab:
/dev/BOOT /boot ext2 noauto,noatime 1 2
/dev/ROOT / ext3 noatime 0 1
/dev/SWAP none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,ro,user 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

#glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
#POSIX shared memory (shm_open, shm_unlink).
#(tmpfs is a dynamically expandable/shrinkable ramdisk, and will
#use almost no memory if not populated with files)
#Adding the following line to /etc/fstab should take care of this:

none /dev/shm tmpfs defaults 0 0

(things that seem like they might be problems: having that last line twice, maybe? It's not having problems, ext3 is, but still. Also is it confusing to have auto in type and noauto as an option? Do these contradict each other or do they mean different things by auto?)

Does anyone see what is wrong? I set everything up exactly as the default in the installation docs, with hda1 as boot, hda2 as swap, and hda3 as root. I used genkernel.
_________________
She's a fluffy psychic physicist with a deep-seated love of David Bowie. Her girlfriend's a semi-devout pagan linguistics major who loves sex like whoa. They fight crime!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Jul 26, 2005 6:44 pm    Post subject: Reply with quote

Please see this thread: https://forums.gentoo.org/viewtopic-t-153836.html

Moved from Installing Gentoo to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum