Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Getting DRI working with Intel Sonoma (i915GM) chipset
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sat Oct 29, 2005 1:14 am    Post subject: Reply with quote

@ bdz: I have vesafb (vanilla-sources) working in 1280x800 without messing up the console. This is the line in grub.conf:

Code:
kernel /linux-2.6.12.5-hdparm-1005 root=/dev/sda6 vga=0x364 splash=silent,fadein
,theme:widescreen quiet CONSOLE=/dev/tty1


Last edited by seppelrockt on Sun Oct 30, 2005 10:32 am; edited 1 time in total
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sat Oct 29, 2005 9:04 am    Post subject: Reply with quote

seppelrockt wrote:
@ bdz: I have vesafb (vanilla-sources) working in 1280x800 without messing up the console. This is the line iun grub.conf:

Code:
... vga=0x364 splash=silent,fadein,theme:widescreen...

Where did you get that video mode??
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sat Oct 29, 2005 12:07 pm    Post subject: Reply with quote

VinzC wrote:
seppelrockt wrote:
@ bdz: I have vesafb (vanilla-sources) working in 1280x800 without messing up the console. This is the line iun grub.conf:

Code:
... vga=0x364 splash=silent,fadein,theme:widescreen...

Where did you get that video mode??


Sorry, I don't know the source anymore. I googled a lot and found it somewhere in the www ...

EDIT: If you ask because of your 1600x1050 (?) resolution, I admit that this resolution was not in the table where I get the video mode for 1280x800. I'm sorry.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sat Oct 29, 2005 12:32 pm    Post subject: Reply with quote

seppelrockt wrote:
Sorry, I don't know the source anymore. I googled a lot and found it somewhere in the www ...

EDIT: If you ask because of your 1600x1050 (?) resolution, I admit that this resolution was not in the table where I get the video mode for 1280x800. I'm sorry.

No problem, it's far more than nothing at all. If I enable screen scaling with that mode the result is the same as if I had found the mode for 1680x1050. Only the ratio truely matters. I'm going to try ASAP :). Thanks.

P.S.: if you happen to get back to the place where you found that mode maybe it's worth asking the author for other resolutions, just in case...
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Dumbkiwi
n00b
n00b


Joined: 30 Jan 2005
Posts: 45

PostPosted: Sat Oct 29, 2005 10:59 pm    Post subject: Reply with quote

I've got dri working using the patches/instructions in this thread, however I'm having trouble with the framebuffer. I've enabled vesafb-tng and just plain vesafb, and I get the same result with both. When X starts in the boot process, the screen goes black, and that's it - reboot required. I've tried both framebuffers in 24bit and 16 bit mode. Can anyone suggest how I might be able to fix this?

Thanks
_________________
Cheers

Matt
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Oct 30, 2005 10:33 am    Post subject: Reply with quote

Dumbkiwi wrote:
I've got dri working using the patches/instructions in this thread, however I'm having trouble with the framebuffer. I've enabled vesafb-tng and just plain vesafb, and I get the same result with both. When X starts in the boot process, the screen goes black, and that's it - reboot required. I've tried both framebuffers in 24bit and 16 bit mode. Can anyone suggest how I might be able to fix this?

Thanks

Have you tried to start X while your kernel had no framebuffer support - i.e. remove framebuffer support from your kernel and start X?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sun Oct 30, 2005 10:37 am    Post subject: Reply with quote

VinzC wrote:
seppelrockt wrote:
Sorry, I don't know the source anymore. I googled a lot and found it somewhere in the www ...

EDIT: If you ask because of your 1600x1050 (?) resolution, I admit that this resolution was not in the table where I get the video mode for 1280x800. I'm sorry.

No problem, it's far more than nothing at all. If I enable screen scaling with that mode the result is the same as if I had found the mode for 1680x1050. Only the ratio truely matters. I'm going to try ASAP :). Thanks.

P.S.: if you happen to get back to the place where you found that mode maybe it's worth asking the author for other resolutions, just in case...


I remembered that I already wrote the hind down in the Dell I6000 thread and when I reread my post there it turned out that I "stole" the VGA mode from a SuSE Live CD. You can try the following:

Burn a SuSE Live CD. Boot from the Live CD - in the boot menu you can look whether your resolution is supported (1280x800 was). Choose your resolution, than go into grub console mode by pressing "q" and look at the vga mode offered in the kernel boot line (pressing "e").

You don't even have to boot that, well - "other" distro ;-)
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Oct 30, 2005 11:00 am    Post subject: Reply with quote

seppelrockt wrote:
I remembered that I already wrote the hind down in the Dell I6000 thread and when I reread my post there it turned out that I "stole" the VGA mode from a SuSE Live CD. You can try the following:

Burn a SuSE Live CD. Boot from the Live CD - in the boot menu you can look whether your resolution is supported (1280x800 was). Choose your resolution, than go into grub console mode by pressing "q" and look at the vga mode offered in the kernel boot line (pressing "e").

You don't even have to boot that, well - "other" distro ;-)

Good. There is also another way, much longer I presume: do the same with grub, i.e. edit the line in grub that sets the video mode, vga=xxx and try other video modes. This is what I did to check whether 0x364 worked on my system - and it did.

Since I expect the video mode to be like 0x36[n] or something, one could have a chance to get to the corret video mode for 1680x1050. But I'll try booting with SuSe anyway.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!


Last edited by VinzC on Sun Oct 30, 2005 6:12 pm; edited 2 times in total
Back to top
View user's profile Send private message
bdz
Apprentice
Apprentice


Joined: 15 Jul 2005
Posts: 237
Location: Montpellier (France)

PostPosted: Sun Oct 30, 2005 11:24 am    Post subject: Reply with quote

seppelrockt wrote:
@ bdz: I have vesafb (vanilla-sources) working in 1280x800 without messing up the console. This is the line in grub.conf:

Code:
kernel /linux-2.6.12.5-hdparm-1005 root=/dev/sda6 vga=0x364 splash=silent,fadein
,theme:widescreen quiet CONSOLE=/dev/tty1


I tried this vga mode and it is not working on my laptop. I still have the console messed up when I switch back from xorg.
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sun Oct 30, 2005 11:38 am    Post subject: Reply with quote

bdz wrote:
seppelrockt wrote:
@ bdz: I have vesafb (vanilla-sources) working in 1280x800 without messing up the console. This is the line in grub.conf:

Code:
kernel /linux-2.6.12.5-hdparm-1005 root=/dev/sda6 vga=0x364 splash=silent,fadein
,theme:widescreen quiet CONSOLE=/dev/tty1


I tried this vga mode and it is not working on my laptop. I still have the console messed up when I switch back from xorg.


If you have VBERestore in your xorg.conf, then comment it out - it is not needed and messes up the console in this case.
Back to top
View user's profile Send private message
bdz
Apprentice
Apprentice


Joined: 15 Jul 2005
Posts: 237
Location: Montpellier (France)

PostPosted: Sun Oct 30, 2005 3:42 pm    Post subject: It's working!!! Reply with quote

@seppelrockt: Thank you very much to remember me that VBERestore option. It made the difference. I played with it some weeks ago and I forgot it was in my xorg.conf.

After more that 20 reboots I also found other working vga modes and some interesting information.
I tried other vga modes in the same range as 0x364. It turns out that I can use any mode from 0x360 to 0x36b. They all give me 120x800 resolution with 8, 16 or 32 color depth.

And after some googling I tried to use vbetest from the sys-libs/lrmi package.
On my laptop its output is the following:
Code:
quasar ~ # vbetest
VBE Version 3.0
Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
[352] 1280x800 (256 color palette)
[353] 1280x800 (5:6:5)
[354] 1280x800 (8:8:8)
[355] 1280x800 (256 color palette)
[356] 1280x800 (5:6:5)
[357] 1280x800 (8:8:8)
[358] 1280x800 (256 color palette)
[359] 1280x800 (5:6:5)
[360] 1280x800 (8:8:8)
[361] 1280x800 (256 color palette)
[362] 1280x800 (5:6:5)
[363] 1280x800 (8:8:8)
[261] 1024x768 (256 color palette)
[279] 1024x768 (5:6:5)
[280] 1024x768 (8:8:8)
[274] 640x480 (8:8:8)
[276] 800x600 (5:6:5)
[277] 800x600 (8:8:8)
[257] 640x480 (256 color palette)
[259] 800x600 (256 color palette)
[273] 640x480 (5:6:5)
Type a mode number, or 'q' to quit - q

If you take the numbers of the 1280x800 resolutions (352 to 363) and you convert them to hex it gives 0x160 to 0x16b. Add 0x200 to that and you have the vga modes I found by trying all the numbers around 0x364.

Another place where I found my modes is in xorg log:
Code:
quasar ~ # grep '(1280x800)' /var/log/Xorg.0.log
Mode: 60 (1280x800)
Mode: 61 (1280x800)
*Mode: 62 (1280x800)
Mode: 63 (1280x800)
Mode: 64 (1280x800)
*Mode: 65 (1280x800)
Mode: 66 (1280x800)
Mode: 67 (1280x800)
*Mode: 68 (1280x800)
Mode: 69 (1280x800)
Mode: 6a (1280x800)
*Mode: 6b (1280x800)
Back to top
View user's profile Send private message
Dumbkiwi
n00b
n00b


Joined: 30 Jan 2005
Posts: 45

PostPosted: Sun Oct 30, 2005 5:38 pm    Post subject: Reply with quote

VinzC wrote:
Dumbkiwi wrote:
I've got dri working using the patches/instructions in this thread, however I'm having trouble with the framebuffer. I've enabled vesafb-tng and just plain vesafb, and I get the same result with both. When X starts in the boot process, the screen goes black, and that's it - reboot required. I've tried both framebuffers in 24bit and 16 bit mode. Can anyone suggest how I might be able to fix this?

Thanks

Have you tried to start X while your kernel had no framebuffer support - i.e. remove framebuffer support from your kernel and start X?


Yes, X works fine with dri and xv if I don't specify fb support in my kernel parameters in grub.conf. But I'd like to get both fb support and X working.
_________________
Cheers

Matt
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Oct 30, 2005 9:00 pm    Post subject: Re: It's working!!! Reply with quote

bdz wrote:
@seppelrockt: Thank you very much to remember me that VBERestore option. It made the difference. I played with it some weeks ago and I forgot it was in my xorg.conf.

After more that 20 reboots I also found other working vga modes and some interesting information.
I tried other vga modes in the same range as 0x364. It turns out that I can use any mode from 0x360 to 0x36b. They all give me 120x800 resolution with 8, 16 or 32 color depth.

And after some googling I tried to use vbetest from the sys-libs/lrmi package.
On my laptop its output is the following:
Code:
quasar ~ # vbetest
VBE Version 3.0
Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
[352] 1280x800 (256 color palette)
[353] 1280x800 (5:6:5)
[354] 1280x800 (8:8:8)
[355] 1280x800 (256 color palette)
[356] 1280x800 (5:6:5)
[357] 1280x800 (8:8:8)
[358] 1280x800 (256 color palette)
[359] 1280x800 (5:6:5)
[360] 1280x800 (8:8:8)
[361] 1280x800 (256 color palette)
[362] 1280x800 (5:6:5)
[363] 1280x800 (8:8:8)
[261] 1024x768 (256 color palette)
[279] 1024x768 (5:6:5)
[280] 1024x768 (8:8:8)
[274] 640x480 (8:8:8)
[276] 800x600 (5:6:5)
[277] 800x600 (8:8:8)
[257] 640x480 (256 color palette)
[259] 800x600 (256 color palette)
[273] 640x480 (5:6:5)
Type a mode number, or 'q' to quit - q

If you take the numbers of the 1280x800 resolutions (352 to 363) and you convert them to hex it gives 0x160 to 0x16b. Add 0x200 to that and you have the vga modes I found by trying all the numbers around 0x364.

Another place where I found my modes is in xorg log:
Code:
quasar ~ # grep '(1280x800)' /var/log/Xorg.0.log
Mode: 60 (1280x800)
Mode: 61 (1280x800)
*Mode: 62 (1280x800)
Mode: 63 (1280x800)
Mode: 64 (1280x800)
*Mode: 65 (1280x800)
Mode: 66 (1280x800)
Mode: 67 (1280x800)
*Mode: 68 (1280x800)
Mode: 69 (1280x800)
Mode: 6a (1280x800)
*Mode: 6b (1280x800)

Goddamn! had I known it before I wouldn't have banged my head against the wall for so long! ;)

You know that just works!? I ran vbetest on my machine and I got these modes:
Code:
$ sudo vbetest
Password:
VBE Version 3.0
Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS
[352] 1680x1050 (256 color palette)
[353] 1680x1050 (5:6:5)
[354] 1680x1050 (8:8:8)
[355] 1280x800 (256 color palette)
[356] 1280x800 (5:6:5)
[357] 1280x800 (8:8:8)
[263] 1280x1024 (256 color palette)
[282] 1280x1024 (5:6:5)
[283] 1280x1024 (8:8:8)
[261] 1024x768 (256 color palette)
[279] 1024x768 (5:6:5)
[280] 1024x768 (8:8:8)
[274] 640x480 (8:8:8)
[276] 800x600 (5:6:5)
[277] 800x600 (8:8:8)
[257] 640x480 (256 color palette)
[259] 800x600 (256 color palette)
[273] 640x480 (5:6:5)
Type a mode number, or 'q' to quit - q

I added 0x200 to the hex value of 353. Why that mode? It corresponds to a 16-bit framebuffer console. So does 0x364 on my machine (i.e. mode 356). I used the mode with my kernel and that did the trick. Thanks a lot for the hint.

EDIT: typo... 353 and not 354!
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!


Last edited by VinzC on Tue Nov 01, 2005 8:42 am; edited 2 times in total
Back to top
View user's profile Send private message
bdz
Apprentice
Apprentice


Joined: 15 Jul 2005
Posts: 237
Location: Montpellier (France)

PostPosted: Sun Oct 30, 2005 9:50 pm    Post subject: Reply with quote

Glad to know it is also working for you.

But isn't your 354 mode 32 bits and not 16 bits?
Code:
[352] 1680x1050 (256 color palette)
[353] 1680x1050 (5:6:5)
[354] 1680x1050 (8:8:8)

352 : 256 colors = 8 bits palette
353 : 5+6+5 = 16 bits true color
354 : 8+8+8 = 32 bits true color
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Oct 30, 2005 10:15 pm    Post subject: Reply with quote

seppelrockt wrote:
Burn a SuSE Live CD.

Well, you should have said "Live DVD" for SuSe Live is now available only on DVD; and I have no VDD burner as I chose the CD-writer combo. Nevermind I figured out the video mode anyway.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Tue Nov 01, 2005 8:34 am    Post subject: Reply with quote

bdz wrote:
Glad to know it is also working for you.

But isn't your 354 mode 32 bits and not 16 bits?
Code:
[352] 1680x1050 (256 color palette)
[353] 1680x1050 (5:6:5)
[354] 1680x1050 (8:8:8)

352 : 256 colors = 8 bits palette
353 : 5+6+5 = 16 bits true color
354 : 8+8+8 = 32 bits true color

:oops: typo... I did use 353 indeed.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Kalmairn
n00b
n00b


Joined: 27 Jan 2003
Posts: 61

PostPosted: Fri Nov 11, 2005 2:05 pm    Post subject: Reply with quote

First, I want to thank VinzC for all the effort that was put into this. I learned something that I really wanted to know how to do - Portage Overlays - and that itself made the effort worthwhile.

Unfortunately, this patch is not working for me. I have verified that the patch applies correctly (I looked at lnx_agp.c and saw the date was changed and the patchcode was added to the file. Before I applied the patch I was getting 805-815fps in glxgears, after I'm getting .... 805-815. Absolutely no change, unfortunately.

I have a Dell D410 with 915GM, running at 1024x768x24 (yes, 24). When I first built this system I was able to get 1500-ish fps in glxgears 1024x768x24 with only manipulation to Xorg and x11-drm, but then I did an emerge -up world at some point and it all broke. I've since rebuilt (another story, moving on :oops: ), and still have the same problem.

I don't have the laptop here, so I'll pose some questions and ask that if there is specific documentation from the laptop anyone would like to see. I'll be happy to post tonight.

Some specifics:
Dell D410, 2GB RAM, i915GM Video, using integrated LCD 1024x768.
Profile: 2005.1
Kernel: 2.6.12-gentoo
X: 6.8.99.15-r4
x11-drm: not installed; previously installed but removed
i915 DRM: module, loaded
Misc Modules: agpgart, intel_agp both loaded.
Not running FB, 80x25 standard only.

Prior to trying these steps last night I was getting the same memory problems indicated by others previously: only about 8MB allocated (which I see in the BIOS, but can't change), -5millionsomething memory available (the laptop has 2GB), DRI disabled because of a lack of memory.

a) Has anyone else seen this problem, particularly with a Dell D410 or perhaps the D610?
b) Should I be using x11-drm? I don't see this in the documentation so I removed it and removed the driver from /lib/modules, depmod -ae.
c) Has anyone tried the 7.00-rc1 (or similar) Xorg package? It's hard-masked, I've not taken the time to unmask and test it yet.
d) Anything else I should be looking for/at?

Thanks,

Kal.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Fri Nov 11, 2005 3:13 pm    Post subject: Reply with quote

@Kalmairn:
You should first check whether DRI is enabled or not.
Code:
grep dr[im] /var/log/Xorg.0.log

Post the results and we'll check.

b) x11-drm is only for ATI hence useless here.
c) sepperockt has successfully tried xorg 7. You have to put the same packages in /etc/portage/package.keywords (with ~ARCH flag) and /etc/portage/package.unmask.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Kalmairn
n00b
n00b


Joined: 27 Jan 2003
Posts: 61

PostPosted: Fri Nov 11, 2005 8:14 pm    Post subject: Reply with quote

I'll get the output on the grep this evening, thanks for the reply.

b) x11-drm does have i915 drivers in it - as well as i810 drivers. I've never compared them to those included in 2.6.12, and I am wondering if the kernel-sources are at least as current as x11-drm.
c) There appears to be a long list of dependencies for Xorg7. I actually started to add packages to /etc/portage/package.keywords and /etc/portage/package.unmask, but since I'm not smart enough with emerge (and consistently fail to read manpages closely enough :) ) I've not managed to produce a full list of masked dependencies with just one command for easy handling, so I run an emerge, add the package to package.keywords and package.unmask, rinse, repeat.

Kal.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Fri Nov 11, 2005 8:55 pm    Post subject: Reply with quote

Kalmairn wrote:
I'll get the output on the grep this evening, thanks for the reply.

b) x11-drm does have i915 drivers in it - as well as i810 drivers. I've never compared them to those included in 2.6.12, and I am wondering if the kernel-sources are at least as current as x11-drm.

When I read Gentoo DRI guide it was only for ATI. It seems the guide has been updated since then. It was a couple of months ago. Anyway I've looked up at DRI web site and the status of i915 support is unknown as per the FeatureMatrix.

Kalmairn wrote:
c) There appears to be a long list of dependencies for Xorg7. I actually started to add packages to /etc/portage/package.keywords and /etc/portage/package.unmask, but since I'm not smart enough with emerge (and consistently fail to read manpages closely enough :) ) I've not managed to produce a full list of masked dependencies with just one command for easy handling, so I run an emerge, add the package to package.keywords and package.unmask, rinse, repeat.

Didn't you paste seppelrockt list from his post?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Kalmairn
n00b
n00b


Joined: 27 Jan 2003
Posts: 61

PostPosted: Sat Nov 12, 2005 12:07 am    Post subject: Reply with quote

First, the good news. DRI is working on the laptop, I'm getting 1100fps. Not a huge gain, but DVDs play smoothly now so I'm happy.

This is what the problem appears to have been: /dev/dri/card0 didn't exist. Unloading/reloading the drm and i915 modules didn't help, so I finally (gasp!) rebooted - and suddenly I saw /dev/dri/card0. I had uninstalled the x11-drm package, so I wonder if unloading that module b0rk3d things up to the point that the kernel i915 driver couldn't recover. Whatever the case, life is good.

Quote:
When I read Gentoo DRI guide it was only for ATI. It seems the guide has been updated since then.


I was using the x11-drm package in my previous install; I'm not sure which version I used, but I did achieve happiness somehow - hence the repeated effort. Regardless, your instructions actually worked and function today is much more important than some memory of function. Once again, thanks for your efforts.

Quote:
Didn't you paste seppelrockt list from his post?


No, I hadn't gone home to try it in that interceding time and hadn't tried to find a list last night when I worked on it. Now that you've kindly provided the link, I may well upgrade to Xorg7 here over the weekend. It depends on how brave I am - I'm about to go on travel and need this baby to work! :)

Thanks again!

edit: :oops:
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sat Nov 12, 2005 9:09 am    Post subject: Reply with quote

OK, xorg-x11 -7.0.0_RC2 is out (so good time to move ;-)).

And kernel 2.6.15_rc1 (which is out today) might solve our MTRR error messages:

Quote:
[PATCH] vesafb: Disable mtrr as the default

vesafb occassionally gets the size wrong when setting the mtrr. When X or DRI
attempts to set the mtrr, it will fail due to range overlap significantly
affecting their performance. Disable mtrr and let the user explicitly enable
it with the mtrr:n option.


[OT] Given the fact that KDE 3.5 RC1 is out, too - what a perfect Open Source Weekend!
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Nov 13, 2005 10:39 am    Post subject: Reply with quote

seppelrockt wrote:
...
And kernel 2.6.15_rc1 (which is out today) might solve our MTRR error messages:

Quote:
[PATCH] vesafb: Disable mtrr as the default

vesafb occassionally gets the size wrong when setting the mtrr. When X or DRI
attempts to set the mtrr, it will fail due to range overlap significantly
affecting their performance. Disable mtrr and let the user explicitly enable
it with the mtrr:n option.

Well it might explain why I'm getting so many problems with suspend2-sources-2.6.14, especially with Xorg. No display, black screen, X restarting for ever... PIA! Got back to my good ol' 2.6.12-suspend2-r5.

BTW, seppelrockt, does the modular XOrg still use VESA with i915?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
Burkey
n00b
n00b


Joined: 20 Aug 2004
Posts: 40

PostPosted: Wed Nov 30, 2005 5:38 am    Post subject: Reply with quote

Is this thread still the right way for me to get my Dell D410 to run X right?

I just installed and have no unmasked packages (except ndiswrapper) on and x.Org cannot start with an error "no valid fb address in pci config space".

I am intererested to know if it works right on 2.6.15 and Modular X?
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Wed Nov 30, 2005 10:38 am    Post subject: Reply with quote

Burkey wrote:
Is this thread still the right way for me to get my Dell D410 to run X right?

I just installed and have no unmasked packages (except ndiswrapper) on and x.Org cannot start with an error "no valid fb address in pci config space".

I am intererested to know if it works right on 2.6.15 and Modular X?


Yes, linux-2.6.15-rcX + modular X works here on Dell I6000 without patching. Your error message seams to be caused by slightly wrong kernel config regarding PCI or framebuffer device.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Page 5 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum