Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iBook: slow text terminal
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Sun Jul 31, 2005 8:21 pm    Post subject: iBook: slow text terminal Reply with quote

Hello.

I noticed that the terminal (without X) behaves quite slow with scrolling text. Is little bit annoying when I browse trough logs and mans.
But not that evil because X works well.

I tried different console fonts. Any suggestions?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
nephros
Advocate
Advocate


Joined: 07 Feb 2003
Posts: 2139
Location: Graz, Austria (Europe - no kangaroos.)

PostPosted: Mon Aug 01, 2005 1:51 pm    Post subject: Reply with quote

Using framebuffer, eh?

If you can live without high resolution and flashy boot images, try running pure text console.

Or, if using vesafb, read /usr/src/linux/Documentation/fb/veesafb.txt for the ywrap and other parameters if you don't already use them.

HTH..
_________________
Please put [SOLVED] in your topic if you are a moron.
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Mon Aug 01, 2005 3:05 pm    Post subject: Reply with quote

Yes I should be using framebuffer because I set up bootsplash successfully and I have a high res console. I need both :)
Is the framebuffer for the ATI too slow? I think the ATI should have 16MB, it's an G3 600.
Maybe I am using the wrong framebuffer?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
nephros
Advocate
Advocate


Joined: 07 Feb 2003
Posts: 2139
Location: Graz, Austria (Europe - no kangaroos.)

PostPosted: Mon Aug 01, 2005 3:45 pm    Post subject: Reply with quote

Paolope wrote:
Is the framebuffer for the ATI too slow? I think the ATI should have 16MB, it's an G3 600.
Maybe I am using the wrong framebuffer?

Well I can't tell. Which one are you using?
You could try the options in /usr/src/linux/Documentation/fb/<yourfb>.txt

For aty12fb there is the "accel" option, which is off by default.
For vesafb there's ywrap, ypan and mtrr.

You can try those; for high resolutions though framebuffer tends to scroll slowly, that's the price you pay...
_________________
Please put [SOLVED] in your topic if you are a moron.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Aug 01, 2005 4:39 pm    Post subject: Reply with quote

nephros:
On ppc, a framebuffer device is required.

paolope:
Emerge fbset and give us the output of
Code:
# fbset -i

You can also try enabling framebuffer acceleration with
Code:
# fbset -accel true

_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nephros
Advocate
Advocate


Joined: 07 Feb 2003
Posts: 2139
Location: Graz, Austria (Europe - no kangaroos.)

PostPosted: Mon Aug 01, 2005 4:56 pm    Post subject: Reply with quote

JoseJX wrote:
nephros:
On ppc, a framebuffer device is required.

*glances up at Forum title for the first time* *blinks*
Whoops. Sorry. I have strolled from the path. Shutting up now.
_________________
Please put [SOLVED] in your topic if you are a moron.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Aug 01, 2005 5:11 pm    Post subject: Reply with quote

hehe, no worries :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Mon Aug 01, 2005 8:59 pm    Post subject: Reply with quote

JoseJX wrote:
Code:
# fbset -i
Code:
# fbset -i

mode "1024x768-85"
    # D: 94.500 MHz, H: 68.677 kHz, V: 84.997 Hz
    geometry 1024 768 1024 768 32
    timings 10582 208 48 36 1 96 3
    hsync high
    vsync high
    rgba 8/16,8/8,8/0,0/0
endmode

Frame buffer device information:
    Name        : ATI Radeon LY
    Address     : 0x98000000
    Size        : 16777216
    Type        : PACKED PIXELS
    Visual      : DIRECTCOLOR
    XPanStep    : 8
    YPanStep    : 1
    YWrapStep   : 0
    LineLength  : 4096
    MMIO Address: 0x90000000
    MMIO Size   : 16384
    Accelerator : No

-accel true makes no difference. Does this mean there's no acceleration available?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum