Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FATAL: Error inserting nvidia --> no such device
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Mon Aug 01, 2005 8:12 am    Post subject: FATAL: Error inserting nvidia --> no such device Reply with quote

Hallo,

Mijn eerste probleem is net opgelost, loop ik tegen de volgende aan.8O

Het is de bedoeling dat ik de nvidia settings voor gentoo ga installeren.
Alles gaat goed, tot ik bij de volgende opdracht kom:
Code:
modprobe nvidia


Als ik dan vervolgens op enter druk verschijnt er de volgende foutmelding.

Code:
Fatal: Error inserting nvidia (/lib/modules/2/6/12-gentoo-r6/video/nvidia.ko): No such device.


Ik heb het forum al doorzocht op gelijke problemen maar kom er niet uit.

mvg,
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Mon Aug 01, 2005 12:05 pm    Post subject: Reply with quote

bestaat het apparaat?

je zou /dev/nvidia0 en /dev/nvidiactl moeten hebben. Zo niet:

mknod /dev/nvidia0 c 195 0
mknod /dev/nvidiactl c 195 255
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Mon Aug 01, 2005 1:55 pm    Post subject: Reply with quote

Rainmaker wrote:
bestaat het apparaat?

je zou /dev/nvidia0 en /dev/nvidiactl moeten hebben. Zo niet:

mknod /dev/nvidia0 c 195 0
mknod /dev/nvidiactl c 195 255


als ik in console /dev/ in typ en vervolgens tab, dan komt er dit te staan: /dev/net, en geen andere keuze's, met iets in de richting van nvidia.

Vervolgens heb ik die "mknod" opdrachten uitgevoerd. Waarna ik de
Code:
modprobe nvidia
commado heb uit gevoerd.
Helaas blijft de foutmelding als volgt:

Code:
[code]Fatal: Error inserting nvidia (/lib/modules/2/6/12-gentoo-r6/video/nvidia.ko): No such device.[/code]
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Mon Aug 01, 2005 3:17 pm    Post subject: Reply with quote

Je hebt de manual gelezen en zaken als "nvidia-kernel" geinstalleerd?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Mon Aug 01, 2005 3:31 pm    Post subject: Reply with quote

Deze al gezien?
https://forums.gentoo.org/viewtopic-t-361247-highlight-fatal+error+inserting+nvidia+device.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Tue Aug 02, 2005 7:39 am    Post subject: Reply with quote

@ Q-collective

Ja ik heb die manual meerdere malen geprobeert.

@ Nixnut

Die heb ik gelezen, ik heb ook alles geprobeert wat er in dat topic voorkwam,
maar dit werkt helaas niet.

is het ook mogelijk dat ik in een later stadium verder ga het met installeren en configureren van Nvidia drivers.
Zodat ik nu eerst verder kan met het de rest, zoals gnome e.d installeren ?

mvg,

-- EDIT --

zodra ik vanuit X terug ga na de console, verschijnt de volgende (fout)melding

Code:
Symbel --glXgetactiveScreen from module /usr/lib64/modules/extensions/libdri.a is unresolved

(EE) failed to initialize GLX extensions ( Nvidia X driver not found )


misschien dat dit wat voor opheldering zorgt. :)
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Wed Aug 10, 2005 1:39 pm    Post subject: Reply with quote

HI

Iemand nog een idee of dit kan worden op gelost? :D

Of is het ook mogelijk om dit later te installeren.


mvg,
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Aug 10, 2005 4:14 pm    Post subject: Reply with quote

Heb je andere FB drivers in je kernel aangezet? Als je de nvidia driver van nvidia zelf wilt gebruiken moet je alle andere Framebuffer drivers uit zetten.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Wed Aug 10, 2005 8:25 pm    Post subject: Reply with quote

Ja ik heb alle FB in de kernel uit geschakeld, inclusief die van Nvidia.

Maar is het dus ook mogelijk dat ik later het Nvidia gebeuren ga installeren. ?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Aug 11, 2005 5:52 pm    Post subject: Reply with quote

Ja, je kan het nvidia gebeuren later installeren.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Thu Aug 11, 2005 8:56 pm    Post subject: Reply with quote

Ik heb nu gnome draaiende gekregen en laat nvidia even links ( of rechts ) liggen.

helaas is gnome niet met de nederlandse taal geinstalleerd. Ik ben bang dat ik gnome op nieuw moet installeren met een nederlands uitgave..8O

Of is hier nog een andere manier voor.

mvg,
Back to top
View user's profile Send private message
-Rick-
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2004
Posts: 77
Location: Holland

PostPosted: Thu Aug 11, 2005 10:39 pm    Post subject: Reply with quote

Heb je een wat oudere kaart?
Ik had dit probleem met een nvidia tnt2. De nieuwste drivers ondersteunen 'legacy' kaarten niet meer en dus moest ik een oude driver gebruiken.
_________________
Cube bots
Nixstaller - Easy creatable installers for *nix
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Fri Aug 12, 2005 3:33 am    Post subject: Reply with quote

hannesz112 wrote:
Ik heb nu gnome draaiende gekregen en laat nvidia even links ( of rechts ) liggen.

helaas is gnome niet met de nederlandse taal geinstalleerd. Ik ben bang dat ik gnome op nieuw moet installeren met een nederlands uitgave..8O

Of is hier nog een andere manier voor.

mvg,


voeg "nls" toe aan de useflags in make.conf.

Maak een bestand aan:

/etc/env.d/02locale
met als inhoud:
LC_ALL=nl_NL@euro
LANG=nl_NL@euro
LANGUAGE=nl_NL@euro
LINGUAS="nl"

env-update en rebooten

dan

emerge -Dv --newuse world

Dan zou bijna je hele systeem in het nederlands moeten zijn, in ieder geval gnome.
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
hannesz112
n00b
n00b


Joined: 27 Jul 2005
Posts: 18

PostPosted: Fri Aug 12, 2005 10:51 am    Post subject: Reply with quote

Hey geweldig. Dit werkte in 1x:D


Heb nog 1 klein vraagje. Zodra ik op start kom ik constant weer in de console in plaats van het inlogscherm van Gnome.
Ik heb die handleiding meerdere malen overnieuw gedaan, en gekeken of er ook een eventuele foutmelding verscheen maar dit is niet het geval.

Ik heb dus xdm teogevoegt aan de default runlevel, maar als ik dat doe kom ik in een andere en zeer kale GUI, waar alleen een console aan wezig is.
Zodra ik dus die xdm weer uit de default runlevel haal dan kan ik gewoon startx in typen en kom ik in de gnome om gegeving terecht.

Ik denk dat er iets anders moet staan ipv " xdm".

mvg,
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Fri Aug 12, 2005 3:01 pm    Post subject: Reply with quote

Rainmaker wrote:

voeg "nls" toe aan de useflags in make.conf.

Maak een bestand aan:

/etc/env.d/02locale
met als inhoud:
LC_ALL=nl_NL@euro
LANG=nl_NL@euro
LANGUAGE=nl_NL@euro
LINGUAS="nl"

env-update en rebooten

dan

emerge -Dv --newuse world

Dan zou bijna je hele systeem in het nederlands moeten zijn, in ieder geval gnome.

Werkt voor geen meter bij mij :?
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Fri Aug 12, 2005 3:03 pm    Post subject: Reply with quote

hannesz112 wrote:

Heb nog 1 klein vraagje. Zodra ik op start kom ik constant weer in de console in plaats van het inlogscherm van Gnome.
Ik heb die handleiding meerdere malen overnieuw gedaan, en gekeken of er ook een eventuele foutmelding verscheen maar dit is niet het geval.

Ik heb dus xdm teogevoegt aan de default runlevel, maar als ik dat doe kom ik in een andere en zeer kale GUI, waar alleen een console aan wezig is.
Zodra ik dus die xdm weer uit de default runlevel haal dan kan ik gewoon startx in typen en kom ik in de gnome om gegeving terecht.

Ik denk dat er iets anders moet staan ipv " xdm".

mvg,

Lees de manual eens?
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Fri Aug 12, 2005 11:24 pm    Post subject: Reply with quote

Q-collective wrote:
Werkt voor geen meter bij mij :?


Hoezo niet? Wat gaat er mis? Praat ie nog steeds geen nederlands?

Niet alle paketten hebben een specifieke "nls" flag, sommige pakken tijdens de compile de waarde van LINGUAS / LANG.

Als je echt alles in het nederlands wil, zal je emerge -eD world moeten draaien...

Gnome paketten hebben echter bijna allemaal de nls flag, en spreken bij mijn weten ook altijd fatsoenlijk nederlands... Heb je toevallig gnome .11 van bmg?
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
ruben
Guru
Guru


Joined: 04 Jul 2003
Posts: 462

PostPosted: Sat Aug 13, 2005 10:18 am    Post subject: Reply with quote

@hannesz112:

Wat ik niet goed snap is dat je die nvidia niet draaiend krijgt, maar je hebt wel een werkende X? (aangezien je zegt dat gnome draait) Je gebruikt momenteel gewoon de "nv" of de "vesa" driver ipv "nvidia" dan of zo?

Welke grafische kaart gebruik je juist? Wijst "/usr/src/linux" naar de kernel source van de kernel die op dat moment aan het draaien is (kun je zien met "uname -a") ? Is je huidige gcc-versie dezelfde als de gcc-versie waarmee je je kernel gecompileerd hebt?

Voor die xdm, moet je "xdm" in je runlevel hebben, en waarschijnlijk gebruik je ook "gdm", daarvoor moet je in "/etc/rc.conf" de lijn DISPLAYMANAGER="gdm" staan hebben. Als je dat goed ingesteld hebt, dan moet je waarschijnlijk eerst je login tikken, dan je paswoord en vooraleer [return] te tikken, klik je nog eens op "Session" en kies je daar "Gnome", dan zou het normaal moeten werken.

@Q-collective:

Je hebt toch wel de locale voor nl_NL@euro? (kun je zien met de output van "locale -a". Anders moet je in je normale gnome-sessie eens hetvolgende commando proberen:
Code:
LC_ALL="nl_NL@euro" LANG="nl_NL@euro" gedit

Krijg je dan een Nederlandstalige Gedit ?
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Sat Aug 13, 2005 11:05 pm    Post subject: Reply with quote

ruben wrote:
@Q-collective:

Je hebt toch wel de locale voor nl_NL@euro? (kun je zien met de output van "locale -a". Anders moet je in je normale gnome-sessie eens hetvolgende commando proberen:
Code:
LC_ALL="nl_NL@euro" LANG="nl_NL@euro" gedit

Krijg je dan een Nederlandstalige Gedit ?

Ah, dat levert een mooie error op:
Code:
$ LC_ALL="nl_NL@euro" LANG="nl_NL@euro" gedit

(gedit:12656): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

(gedit:12656): Gdk-WARNING **: locale not supported by C library
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 14, 2005 2:40 pm    Post subject: Reply with quote

glibc maar even remergen dan met USE="userlocales" en de gewenste locales in /etc/locales.build
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Parasietje
Apprentice
Apprentice


Joined: 25 Jan 2004
Posts: 194

PostPosted: Thu Aug 18, 2005 8:47 pm    Post subject: Reply with quote

Toevallig rivatv geinstalleerd? Die neemt je videokaart helemaal in beslag.

Toon eens de output van lspci. Zo zie je meteen zelke kaart je hebt.
Back to top
View user's profile Send private message
Po0ky
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2005
Posts: 142
Location: Belgium

PostPosted: Tue Sep 13, 2005 11:42 am    Post subject: Reply with quote

hannesz112 wrote:
Hey geweldig. Dit werkte in 1x:D


Heb nog 1 klein vraagje. Zodra ik op start kom ik constant weer in de console in plaats van het inlogscherm van Gnome.
Ik heb die handleiding meerdere malen overnieuw gedaan, en gekeken of er ook een eventuele foutmelding verscheen maar dit is niet het geval.

Ik heb dus xdm teogevoegt aan de default runlevel, maar als ik dat doe kom ik in een andere en zeer kale GUI, waar alleen een console aan wezig is.
Zodra ik dus die xdm weer uit de default runlevel haal dan kan ik gewoon startx in typen en kom ik in de gnome om gegeving terecht.

Ik denk dat er iets anders moet staan ipv " xdm".

mvg,


/etc/rc.conf
DISPLAYMANAGER="gdm"

En voor uw nvidia gedoe
Staat de juiste (in gebruik) kernel gelinkt in /usr/src/linux?
Anders es opnieuw compilen, make modules_install en dan es uw nvidia-kernel opnieuw compilen
_________________
-- I'll eat it--
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum