Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Using the Airport Extreme in Linux (via MOL)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 7:17 am    Post subject: Re: mol Reply with quote

raimundex wrote:
add this lines on /etc/mol/molrc.osx
enable_pciproxy: yes
pci_proxy_device: 0001:10:12.0
and startmol.
i have this error
PCIPROXY: warning: PCI bus mastering not working with MOL
As JoseJX told you, this is not a "error".
You should post in the forum all the messages you see when you start mol in a terminal.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 5:30 pm    Post subject: mol Reply with quote

Hi, i solved the problem, the MacOSX starts normally, it connects by the Airport. Then I set the sharing with the en2. When i go to linux and ping the en2's IP it answer normally, but linux is without internet access.
What would be the problem, then?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 5:52 pm    Post subject: Reply with quote

If you are running the built-in OSX firewall, stop it.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 6:11 pm    Post subject: firewall Reply with quote

the firewall is disabled
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 6:22 pm    Post subject: mol Reply with quote

root@ubuntu:~# ping 192.168.41.2
PING 192.168.41.2 (192.168.41.2) 56(84) bytes of data.
64 bytes from 192.168.41.2: icmp_seq=1 ttl=64 time=1.01 ms
64 bytes from 192.168.41.2: icmp_seq=2 ttl=64 time=0.369 ms
64 bytes from 192.168.41.2: icmp_seq=3 ttl=64 time=0.361 ms
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 6:30 pm    Post subject: Reply with quote

stop and restart interface tun0 (it's tun0 for me):
For debian, it's :
ifdown tun0
ifup tun0

You should also disable your linux firewall if necessary.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 6:48 pm    Post subject: mol Reply with quote

tun0 Encapsulamento do Link: Ethernet Endereço de HW 72:C9:6E:EF:0E:B0
inet end.: 192.168.41.1 Bcast:192.168.41.255 Masc:255.255.255.0
endereço inet6: fe80::70c9:6eff:feef:eb0/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
RX packets:88 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:500
RX bytes:10929 (10.6 KiB) TX bytes:2468 (2.4 KiB)

# ifdown tun0
ifdown: interface tun0 not configured
# ifup tun0
Ignoring unknown interface tun0=tun0.
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 7:00 pm    Post subject: Reply with quote

Sorry.
First add this line in your /etc/network/interfaces
Code:
iface tun0 inet dhcp

(If necessary, restart network intefaces:
# /etc/init.d/networking restart)
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 7:16 pm    Post subject: mol Reply with quote

# ifdown tun0
ifdown: interface tun0 not configured
# ifconfig
eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:11:24:30:BD:32
inet end.: 192.168.1.5 Bcast:192.168.1.255 Masc:255.255.255.0
endereço inet6: fe80::211:24ff:fe30:bd32/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
RX packets:760 errors:0 dropped:0 overruns:0 frame:0
TX packets:756 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:116983 (114.2 KiB) TX bytes:69904 (68.2 KiB)
IRQ:41 Endereço de E/S:0xd000

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACK RUNNING MTU:16436 Métrica:1
RX packets:791 errors:0 dropped:0 overruns:0 frame:0
TX packets:791 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:69045 (67.4 KiB) TX bytes:69045 (67.4 KiB)

tun0 Encapsulamento do Link: Ethernet Endereço de HW EA:85:82:9A:2A:4C
inet end.: 192.168.41.1 Bcast:192.168.41.255 Masc:255.255.255.0
endereço inet6: fe80::e885:82ff:fe9a:2a4c/64 Escopo:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Métrica:1
RX packets:99 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:500
RX bytes:12218 (11.9 KiB) TX bytes:261 (261.0 b)
192.168.41.2 is en2
# ping 192.168.41.2
PING 192.168.41.2 (192.168.41.2) 56(84) bytes of data.
64 bytes from 192.168.41.2: icmp_seq=1 ttl=64 time=76.6 ms
# cat /etc/resolv.conf
search debian.org
nameserver 192.168.41.2
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 7:20 pm    Post subject: Reply with quote

Try "iface tun0 inet dhcp" in /etc/network/interfaces before running ifup tun0.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 7:44 pm    Post subject: mol Reply with quote

When i ping the MACOSX IP running with "mol"... which would be 192.168.41.2 it answer, but linux cant get the connection. I set the sharing of airport ok, the MACOSX is connected to the internet, only linux is not. I added the line you told me to, but the internet in linux doesnt work.. how can you help?
$ startmol -X
Mac-on-Linux 0.9.71-pre4 [Out 23 2005 22:07]
Copyright (C) 1997-2004 Samuel Rydh
Starting MOL session 1
Removing stale lockfile /var/lock/mol-1
Running in PowerPC 7400 mode, 96 MB RAM
Timebase: 18.43 MHz, Bus: 73.72 MHz, Clock: 666 MHz
Using USB mouse on /dev/input/mice
OHCI USB controller registered
Fullscreen video on VT 9.
Could not open '/var/local/mol/console.kbd'
Video driver(s): [console_video]

640* 480, depth 8,15,32 { 59.9, 72.1, 74.9, 89.9, 99.7, 116.6 } Hz
1024* 768, depth 8,15,32 { 0.0 } Hz

Autoswitching to console
DHCP nameserver exported: 192.168.41.2
Initializing IP Masquerading...done.
Restarting DNS forwarder and DHCP server: dnsmasq.
Ethernet Interface 'tun-<tun0>' @ 00:00:0D:EA:DB:EE

ip/mask: 192.168.41.2/255.255.255.0 gw: 192.168.41.1
broadcast: 192.168.41.255 nameserver: 192.168.41.1

gw and nameserver shouldnt be 192.168.41.2?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 8:22 pm    Post subject: Reply with quote

I am not sure what I'll write below. Sorry for my poor English.

I take my installation for an example :

I have the network interfaces eth0, tun0, en3, en1 (airport extreme).
When using mol 0.9.70, I had only eth0, tun0, en3.

When I start mol 0.9.70 or 0.9.71_pre4, the default setting for tun0 and en3 is for en3 --> tun0, that is OSX_applications/MOL ---> en3 ---> tun0 ---> eth0 ---> Internet. I have a dhcp server at tun0 configured by mol, en3 is dhcp client. I must setup a NAT tun0 --> eth0 for this.

When I want Linux_applications ---> tun0 ---> en3 ---> en1 (airport) ---> Internet, I must re-configure my tun0 (That's why my previous messages). Now I have a dhcp server at en3, and tun0 is a dhcp client. I must setup a NAT en3-->en1 (OSX Internet Sharing in System Preferences) for this.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 10:13 pm    Post subject: error Reply with quote

hi..look this
# insmod /usr/local/lib/mol/0.9.71/modules/2.6.12-9-powerpc/tun.ko
insmod: error inserting '/usr/local/lib/mol/0.9.71/modules/2.6.12-9-powerpc/tun.ko': -1 Unknown symbol in module
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 10:38 pm    Post subject: Reply with quote

You must use the same version of gcc for building your mol-0.9.71_pre4 and your kernel.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Tue Oct 25, 2005 11:07 pm    Post subject: gcc Reply with quote

hi..
gcc version 3.3.6 (Ubuntu 1:3.3.6-8ubuntu1)
this is compatible with mol-0.9.71_pre4?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Tue Oct 25, 2005 11:43 pm    Post subject: Reply with quote

"less /var/log/dmesg" and "gcc --version" give you the same version 3.3.6 ? (I don't use ubuntu, but it seems that the packages gcc installed are not version 3.3.6)
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Wed Oct 26, 2005 12:21 am    Post subject: mol Reply with quote

$ less /var/log/dmesg
[ 0.000000] Total memory = 256MB; using 512kB for hash table (at c0380000)
[ 0.000000] Linux version 2.6.12-9-powerpc (buildd@adare) (gcc version 3.4.5
20050809 (prerelease) (Ubuntu 3.4.4-6ubuntu8)) #1 Mon Oct 10 15:26:45 BST 2005
$ gcc --version
gcc (GCC) 3.3.6 (Ubuntu 1:3.3.6-8ubuntu1)
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
$
whats version of gcc and mol do you use?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Wed Oct 26, 2005 12:35 am    Post subject: Reply with quote

Your kernel was built using gcc-3.4.4. If you use gcc-3.3.6 for building mol, you may have problem.
I use gcc 4.0.2, and I build kernel and mol from source, so I don't have this problem. You can also use gcc 3.4.

If you already have the packages mol-* (version 0.9.70) installed, maybe you should remove all of them. Running two versions of mol is not a good idea.
Back to top
View user's profile Send private message
fuoco
Guru
Guru


Joined: 23 May 2004
Posts: 386
Location: Israel

PostPosted: Wed Oct 26, 2005 10:22 am    Post subject: Reply with quote

I'm trying this method but I'm stuck at the stage of patching the driver. Even the driver from the install disc don't patch because they are too new or something. It's Tiger 10.4.2. What can I do ?
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Thu Oct 27, 2005 5:25 pm    Post subject: mol Reply with quote

Hi, I rebuilt "mol" again, now its starting with no errors. I defined the nameserv in /etc/resolv.conf to 192.168.41.2 (en2 board's IP). Then i shared the internet of airport with the en2, but when I go to linux and try "host www.google.com", it can't resolve the host. Can you help?
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Thu Oct 27, 2005 5:48 pm    Post subject: Reply with quote

I have
nameserver 192.168.2.1
in my /etc/resolve.conf which is automatically generated by resolvconf
(I use resolvconf. For ubuntu, you have http://packages.ubuntu.com/breezy/net/resolvconf )
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Thu Oct 27, 2005 6:39 pm    Post subject: mol Reply with quote

I changed to debian now :)..
my ips are the following:
192.168.1.1 router
192.168.1.3 my windowns
192.168.1.7 airport (macosx)
192.168.41.2 en2
192.168.41.1 tun0
in linux i put in /etc/resolv.conf:
nameserver 192.168.41.2
is it ok? why isnt it working? i think im not doing anything wrong
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Thu Oct 27, 2005 6:48 pm    Post subject: ipwf Reply with quote

in ipfw of macosx its like this:
root# ipfw list
00010 divert 8668 ip from any to any via en1
65535 allow ip from any to any
root#
Back to top
View user's profile Send private message
bz31
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2005
Posts: 108

PostPosted: Thu Oct 27, 2005 6:49 pm    Post subject: Reply with quote

Can you post your "$ sudo ifconfig" under OSX and "# ifconfig" under linux ?

Your ipfw is ok.
Back to top
View user's profile Send private message
raimundex
n00b
n00b


Joined: 24 Oct 2005
Posts: 18

PostPosted: Thu Oct 27, 2005 7:12 pm    Post subject: ifconfig Reply with quote

ifconfig mac
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en2: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::200:dff:feea:dbee%en2 prefixlen 64 scopeid 0x4
inet 192.168.41.2 netmask 0xffffff00 broadcast 192.168.41.255
inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
ether 00:00:0d:ea:db:ee
media: autoselect (100baseTX <full-duplex>) status: active
supported media: none autoselect 100baseTX <full-duplex>
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::211:24ff:fe22:315f%en1 prefixlen 64 scopeid 0x5
inet 192.168.1.7 netmask 0xffffff00 broadcast 192.168.1.255
ether 00:11:24:22:31:5f
media: autoselect status: active
supported media: autoselect
-----------------------------------------------------------------------------------
ifconfig debian

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
endereço inet6: ::1/128 Escopo:Máquina
UP LOOPBACKRUNNING MTU:16436 Métrica:1
RX packets:201 errors:0 dropped:0 overruns:0 frame:0
TX packets:201 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:15272 (14.9 KiB) TX bytes:15272 (14.9 KiB)
tun0 Encapsulamento do Link: Ethernet Endereço de HW 00:FF:F8:59:DD:EF
inet end.: 192.168.41.1 Bcast:192.168.41.255 Masc:255.255.255.0
endereço inet6: fe80::2ff:f8ff:fe59:ddef/64 Escopo:Link
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:76 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:10141 (9.9 KiB) TX bytes:47 (47.0 b)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 5 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum