Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
login problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
iandow
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jul 2004
Posts: 135
Location: Washington, DC

PostPosted: Fri Aug 05, 2005 3:03 pm    Post subject: login problems Reply with quote

I just did an emerge world, and rebooted. Now, whenever I log in, I get the following errors:
    configuration error - unknown item 'FAILLOG_ENAB' (notify administrator)
    configuration error - unknown item 'LASTLOG_ENAB' (notify administrator)
    configuration error - unknown item 'MOTD_FILE' (notify administrator)
    configuration error - unknown item 'FTMP_FILE' (notify administrator)
    configuration error - unknown item 'ENV_PATH' (notify administrator)
    configuration error - unknown item 'ENV_ROOTPATH' (notify administrator)
    configuration error - unknown item 'ENV_SUPATH' (notify administrator)
    configuration error - unknown item 'PASS_MIN_LEN' (notify administrator)
    configuration error - unknown item 'CHFN_AUTH' (notify administrator)


Does anyone know how to fix this?

Some people have reccommended reemerging sys-apps/baselayout, sys-apps/shadow, and sys-apps/pam-login-4.0.11.1-r1. But I did that, and it didn't fix my problem.

Thanks,
Ian
Back to top
View user's profile Send private message
TheRAt
Veteran
Veteran


Joined: 03 Jun 2002
Posts: 1580
Location: Salt Spring Island, BC, Canada

PostPosted: Fri Aug 05, 2005 3:09 pm    Post subject: Reply with quote

Have you run dispatch-conf or etc-update?
What version of sys-apps/baselayout do you have?
_________________
All reality is the construct of the observer.

Get Firefox and rediscover the web!

BOFH Excuse #295:
The Token fell out of the ring. Call us when you find it.
Back to top
View user's profile Send private message
iandow
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jul 2004
Posts: 135
Location: Washington, DC

PostPosted: Fri Aug 05, 2005 6:31 pm    Post subject: Reply with quote

Ah, yes. I ran etc-update and that fixed it.

I sure wish updateing ebuilds was a little less manually intensive. Etc-update is not quite a nightmare, but close.

Thanks for the help.
-ian
Back to top
View user's profile Send private message
TheRAt
Veteran
Veteran


Joined: 03 Jun 2002
Posts: 1580
Location: Salt Spring Island, BC, Canada

PostPosted: Fri Aug 05, 2005 10:47 pm    Post subject: Reply with quote

Try dispatch-conf... You can use rcs to have backups and rollback feature, etc..
Look at man dispatch-conf for more info...
I find this a little more sane than etc-update
_________________
All reality is the construct of the observer.

Get Firefox and rediscover the web!

BOFH Excuse #295:
The Token fell out of the ring. Call us when you find it.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Oct 16, 2005 7:40 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads.
See here: https://forums.gentoo.org/viewtopic-t-366499.html
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum