Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Checking root filesystem-error after install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
peverix
n00b
n00b


Joined: 07 Aug 2005
Posts: 8

PostPosted: Sun Aug 07, 2005 2:03 pm    Post subject: Checking root filesystem-error after install Reply with quote

Hello,

I'm new to linux and gentoo and installing for the first time gentoo on my machine.

I followed the Gentoo linux x86 handbook ( except is used all ext2 filesystems for the /boot and /root partition ) and used a stage1 installation and everything went well until the magic word 'reboot'.

I'm getting the grub menu and gento start to boot . After a few seconds it say 'Checking root filesystem' and at this stage it give a error :
"fsck.ext2: No such file or directory while trying to open /dev/hda3
/dev/hda3: The superblock could not be read......... Filesystem couldn't be fixed :("


I've started already again with the universial boot-cd gentoo 2005.0 , and can mount the /dev/hda3 partition and evrything seems to bee there.
I've also checked my fstab file , and tht seems to bee correct . Only gentoo won't boot.

Now i'm stucked , have now idea what to do next :(

Any help or do i need to do the thing over again ?

TIA,
Peter
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 2:24 pm    Post subject: Reply with quote

What type of filesystem did you create on hda3? Make sure you specify the same type for it in fstab.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
peverix
n00b
n00b


Joined: 07 Aug 2005
Posts: 8

PostPosted: Sun Aug 07, 2005 2:28 pm    Post subject: Reply with quote

The handbook use ext3 , but i used ext2 both for /dev/had1 and /dev/hda3
Can i check this ?
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 2:31 pm    Post subject: Reply with quote

cfdisk /dev/hda will show you what partitions you made and make a good guess as to what filesystems are on them. Compare that to what you set in fstab.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
peverix
n00b
n00b


Joined: 07 Aug 2005
Posts: 8

PostPosted: Sun Aug 07, 2005 2:35 pm    Post subject: Reply with quote

cfdisk say
hda1 linux ext2
hda2 linux natice swap
hda3 linux ext2
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 2:39 pm    Post subject: Reply with quote

Ok, now see what fstab says.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
peverix
n00b
n00b


Joined: 07 Aug 2005
Posts: 8

PostPosted: Sun Aug 07, 2005 2:46 pm    Post subject: Reply with quote

this i my fstab file
/dev/hda1 /boot ext2 defaults,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / ext2 noatime 0 1
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto, ro 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 3:02 pm    Post subject: Reply with quote

Ok, fstab is as should be. Try adding devfs=nomount gentoo=udev to the kernel line in grub.conf.
Something like this:
Quote:
kernel (hd0,0)/kernel-2.6.11-gentoo-r9 root=/dev/hda3 devfs=nomount gentoo=udev

If that works you should check that you didn't enable devfs in the kernel config.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
peverix
n00b
n00b


Joined: 07 Aug 2005
Posts: 8

PostPosted: Sun Aug 07, 2005 3:11 pm    Post subject: Reply with quote

Now my gentoo is starting.
Thank you very much .
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 07, 2005 3:15 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
Dupe of https://forums.gentoo.org/viewtopic-t-345704.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum