Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Install help [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
jimp
n00b
n00b


Joined: 09 Aug 2005
Posts: 69

PostPosted: Wed Aug 10, 2005 5:31 pm    Post subject: Install help [solved] Reply with quote

I am trying to install Gentoo from the universal ppc install disk. I have followed the handbook step-by-step but I seem to keep running into a dead end at the kernel compile process. I tried to compile my own kernel and when that didnt work I reverted to the genkernel option but that to isnt working. when I get to the
Code:
genkernel --udev all
part that I get errors
Code:
Compiling linux kernel 2.6.10-gentoo-r8 for ppc
Mount: special device /dev/BOOT does not exist
Warning failed to mount /boot!
Error no kernel .config specified, or file not found
now for some history, this G4 originaly had 0S9 on it but I formated and installed yellow dog on it, and had it working fine but someone sugested I should try gentoo instead so here I am. While running mac-fdisk it wont let me delete the /dev/hda1 apple_partition_map Apple & /dev/hda2 Apple_Boostrap untitled.
I have, after the advice of some helpful people in the instalation forum, edited my /etc/fstab file and no longer have the mount boot failure error but the kernel .config error is still there stopping me
any sugestions would be appreciated


Last edited by jimp on Fri Aug 12, 2005 1:31 am; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Aug 10, 2005 5:35 pm    Post subject: Reply with quote

Did you emerge gentoo-sources? It looks like genkernel can't find the kernel sources.

BTW you can't delete those apple partitions because they are needed to be able to boot the system.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
jimp
n00b
n00b


Joined: 09 Aug 2005
Posts: 69

PostPosted: Thu Aug 11, 2005 1:45 pm    Post subject: Reply with quote

well I have tried to continue with my install but got nowhere, dont know how or why but at one point it found the config but errored with
Code:
failed to compile the "prepare' target...
I gave up and deleted all the partitions and started over, again following the handbook that I printed directly off the cd that I burnt from the ISO image I downloaded 3 days ago "install-ppc-universal-2005.0.iso". once again I followed this step-by-step
(if the handbook would have told me to "hop around the room on 1 foot 3 times" I would have done it so many times by now one leg would be 6" shorter than the other!)
Only to get to the same spot,

when I run
Code:
genkernel --udev all
I get the
Code:
* Gentoo Linux Genkernel; Version 3.1.5
* Compiling Linux Kernel 2.6.10-gentoo-r8 for ppc...

* ERROR: Error: No kernel .config specified, or file not found!


where should the kernel config be located? I am guessing it should be in" /usr/share/genkernel/ppc" directory.
and that it is put there from the cd by this command
Code:
zcat /proc/config.gz > /usr/share/genkernel/ppc/kernel-2.6


(and to think- I've gone through all this because I couldnt find a clam av rpm for yellow dog and didn't think I wanted to go thru the process of compiling it from source or however you linux gurus' do it, and was told "there isan ebuild for clam av for gentoo!!!!)

Well anyway what do I look for here?
thanks again
Back to top
View user's profile Send private message
jimp
n00b
n00b


Joined: 09 Aug 2005
Posts: 69

PostPosted: Thu Aug 11, 2005 5:58 pm    Post subject: Reply with quote

ok not only is there no kernel-config-2.6 in the /usr/share/genkernel/ppc
but there is no ppc directory in that path either, the genkernel directory is empty???
did I get a bum ISO ?
Back to top
View user's profile Send private message
jimp
n00b
n00b


Joined: 09 Aug 2005
Posts: 69

PostPosted: Fri Aug 12, 2005 1:34 am    Post subject: Reply with quote

Solved by reinstalling yellow dog

I decided I am obviously way to stupid to try and use Gentoo Linux after all i can't even compile a kernel the "EASY" way well thanks for all your help everyone .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum