Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Another GRUB issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
canadian_coder
n00b
n00b


Joined: 07 Jun 2005
Posts: 58

PostPosted: Mon Aug 15, 2005 11:42 pm    Post subject: Another GRUB issue Reply with quote

I've been forced to resort to the manual configuration for grub. My grub.conf looks like

default 0
timeout 0
splashimage=(sd0,0)...
title=title
root (sd0,0)
kernel /kernel-2.6.12-gentoo-r6 root=/dev/sda3

So when I do GRUB I use the command grub --no-floppy followed by root (sd0,0) but I get the following error:

Error 23: Error while parsing number

***Note that I'm using sd instead of hd

So if anyone can give some advice on this matter I'd be very appreciative!
_________________
"If at first you do succeed try not to look astonished" -- Something for all computer programmers to live by
Back to top
View user's profile Send private message
JTHM
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 115
Location: South Farms

PostPosted: Mon Aug 15, 2005 11:45 pm    Post subject: Reply with quote

Even if the kernel refers to your drives as sda, sdb, etc, it will still be called hd0 in grub. Assuming that you have one SATA drive and no IDE ones, just replace sd0 with hd0 and you should be ok.

Note that the "root=" part will still be sda3
_________________
Any problem can be solved. You just need to throw enough time and ninjas at it.
Back to top
View user's profile Send private message
canadian_coder
n00b
n00b


Joined: 07 Jun 2005
Posts: 58

PostPosted: Tue Aug 16, 2005 12:08 am    Post subject: Reply with quote

That did the trick!

Thanks
_________________
"If at first you do succeed try not to look astonished" -- Something for all computer programmers to live by
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Aug 16, 2005 7:30 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See here: https://forums.gentoo.org/viewtopic-t-60261-highlight-grub+error+parsing+number.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum