Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to mount partitions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
drknexus
n00b
n00b


Joined: 16 Aug 2005
Posts: 3

PostPosted: Tue Aug 16, 2005 11:27 pm    Post subject: Unable to mount partitions Reply with quote

I am trying to mount a ide hd partition after booting from the gentoo 2005.1 livcd. After doing a mkdir /mnt/new, I do mount /dev/hdb5 /mnt/new. After doing this I get a "mount: /dev/hdb5 already mounted or /mnt/new busy". Checking mount to see what is mounted shows that none of my hd partitions are mounted so what gives? : ( I have tried to mount other partitions of various filesystem types wich all result in the same error. I have installed gentoo on this computer before long ago on a 2004 cd wich i no longer have and never had any problem mounting. Hopefully I am just being a bit slow and missing something obvious, any help is appreciated.

P4 2.0ghz
MSI 845E Max2 (MS-6398E) mobo
2 20gig ide hd's
Back to top
View user's profile Send private message
nahpets
Veteran
Veteran


Joined: 05 Oct 2003
Posts: 1178
Location: Montreal, Canada

PostPosted: Wed Aug 17, 2005 6:16 am    Post subject: Reply with quote

Not sure if this is your problem, but shouldn't you by using the '-t' option to mount when mounting a filesystem? ie.
Code:

# mount -t ext3 /dev/hdb5 /mnt/new


Replace 'ext3' with whatever you're using.
_________________
Let me guess, you picked out yet another colorful box with a crank that I'm expected to turn and turn until OOP! big shock, a jack pops out and you laugh and the kids laugh and the dog laughs and I die a little inside.
Back to top
View user's profile Send private message
adnoh
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jul 2005
Posts: 120

PostPosted: Wed Aug 17, 2005 6:41 am    Post subject: Reply with quote

type in
Code:
mount
cat /proc/mounts

and post the output.
have you tried a new mountpoint - like
Code:

mkdir /newmount
mount /dev/hdx /newmount


or maybe try booting of a KNOPPIX live-cd or s.th. like that.
_________________
the german dude with the broken english
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Aug 17, 2005 8:17 am    Post subject: Reply with quote

nahpets wrote:
Not sure if this is your problem, but shouldn't you by using the '-t' option to mount when mounting a filesystem?

This is no longer necessary with 2005.1 installation CDs.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5673
Location: Removed by Neddy

PostPosted: Wed Aug 17, 2005 8:46 am    Post subject: Reply with quote

kimchi_sg wrote:
nahpets wrote:
Not sure if this is your problem, but shouldn't you by using the '-t' option to mount when mounting a filesystem?

This is no longer necessary with 2005.1 installation CDs.


That is more of a "mount" command upgrade to auto-detect the filesystem by default, not really some magical advancement with the GEntoo LiveCD above packaging the LiveCD with that version...
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
drknexus
n00b
n00b


Joined: 16 Aug 2005
Posts: 3

PostPosted: Wed Aug 17, 2005 8:50 am    Post subject: Reply with quote

Ok heres mounts output:

tmpfs on / type tmpfs (rw)
/newroot/dev/cdroms/cdrom0 on /mnt/cdrom
/dev/loop/0 on /mnt/livecd type squashfs (ro)
none on /proc type proc (rw,nodiratime)
none on /sys type sysfs (rw)
none on /dev type ramfs (rw)
none on /dev/pts type devpts (rw)
tmpfs on /lib/firmware type tmpfs (rw)
none on /proc/bus/usb type usbfs (rw)

and cat /proc/mounts:

rootfs / rootfs rw 0 0
tmpfs / tmpfs rw 0 0
/newroot/dev/cdroms/cdrom0 /mnt/cdrom iso9660 ro 0 0
/dev/loop/0 /mnt/livecd squashfs no 0 0
none /proc proc rw,nodiratime 0 0
none /sys sysfs rw 0 0
none /dev ramfs rw 0 0
none /dev/pts devpts rw 0 0
tmpfs /mnt/livecd/lib/firmware tmpfs rw 0 0
none /proc/bus/usb usbfs rw 0 0


Using the -t option and different mountpoints still gives the same error. Thnx for help.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Aug 17, 2005 8:54 am    Post subject: Reply with quote

Naib wrote:
kimchi_sg wrote:
nahpets wrote:
Not sure if this is your problem, but shouldn't you by using the '-t' option to mount when mounting a filesystem?

This is no longer necessary with 2005.1 installation CDs.

That is more of a "mount" command upgrade to auto-detect the filesystem by default

I wouldn't call that an "upgrade":
2005.0 Gentoo handbook wrote:

Warning: Due to a bug in the e2fsprogs package, you need to explicitly use the mount -t ext3 option if you are using an ext3 filesystem.

That's where the -t came in.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5673
Location: Removed by Neddy

PostPosted: Wed Aug 17, 2005 8:58 am    Post subject: Reply with quote

so it was a bug being closed in the "e2fsprogs" w.r.t to the version of mount being used,

either way it is more a specific package problem then a LiveCD feature
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Aug 17, 2005 8:58 am    Post subject: Re: Unable to mount partitions Reply with quote

drknexus wrote:
I am trying to mount a ide hd partition after booting from the gentoo 2005.1 livcd. After doing a mkdir /mnt/new, I do mount /dev/hdb5 /mnt/new. After doing this I get a "mount: /dev/hdb5 already mounted or /mnt/new busy". Checking mount to see what is mounted shows that none of my hd partitions are mounted

Try booting the install CD with the "noevms" and "nolvm2" kernel options.

For example, assuming that you previously needed no other kernel options to boot the CD, enter the following at the boot: prompt.
Quote:
boot: gentoo noevms nolvm2
Back to top
View user's profile Send private message
drknexus
n00b
n00b


Joined: 16 Aug 2005
Posts: 3

PostPosted: Wed Aug 17, 2005 7:56 pm    Post subject: Reply with quote

Sweet, the noevms and novlm2 fixed the problem, thnx for the help.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Aug 17, 2005 11:58 pm    Post subject: Reply with quote

I thought this bug had been killed in 2005.1 installCDs, but hey, it lived to die another release.

(It surfaced in 2005.0 when they made the CD do all the LVM2 and EVMS module loading automatically. That snarfed up the handling of the partitions in some way.) :(
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Aug 18, 2005 7:05 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.
See here instead: https://forums.gentoo.org/viewtopic-t-319261-highlight-nolvm2+mounted.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum