Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Digest verification Failed on mozilla ebuild, [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
rsa4046
l33t
l33t


Joined: 07 Feb 2005
Posts: 660
Location: The Big H, a bit SSW

PostPosted: Wed Aug 17, 2005 3:10 am    Post subject: Digest verification Failed on mozilla ebuild, [SOLVED] Reply with quote

Hi,
Am trying to get this new laptop set up, tried to emerge gnome for the first time, ran into a snag, don't understand how to get out. After having sync'd, I did
Code:
# emerge gnome
Calculating dependencies ...done!
>>> emerge (1 of 1) www-client/mozilla-1.7.11 to /

!!! Digest verification Failed:
!!!    /usr/portage/www-client/mozilla/mozilla-1.7.11-r2.ebuild
!!! Reason: Filesize does not match recorded size

>>> Please ensure you have sync'd properly. Please try 'emerge sync' and
>>> optionally examine the file(s) for corruption. A sync will fix most cases.

But resync'ing doesn't solve the problem. I'm stuck here - should I just manually wipe the /usr/portage/www-client/mozilla? Don't want todo womething that cripples things and have to start over here, been working on this for a few days.
Thanks :cry:

EDIT:
Ok, from the MANIFEST, this file should have md5sum of
689b65afc51513a34fa88d221e78bee4 mozilla-1.7.11-r2.ebuild 12252
md5sum on this file gives
efb11836f2b5c8f484f743a401229c53 mozilla-1.7.11-r2.ebuild
The file should have a size of 12252 not 12246, so it's apparently short. But looking over the file itself there isn't any obvious corruption, so ... ?

Okay, sorry for asnwering editing own posts ... a check on portage reveals this release is hard-masked, but I have no keywords declared in /etc/portage ... is my portage tree screwed up?


Last edited by rsa4046 on Wed Aug 17, 2005 4:31 am; edited 1 time in total
Back to top
View user's profile Send private message
rsa4046
l33t
l33t


Joined: 07 Feb 2005
Posts: 660
Location: The Big H, a bit SSW

PostPosted: Wed Aug 17, 2005 4:24 am    Post subject: Reply with quote

Okay, guess I'm the only responder to this:
Code:
ebuild mozilla-1.7.11-r2.ebuild digest

rebuilds the digest and fixes the bad checksum, but doesn't this action essentially defeat the protection that portage is designed to supply? Just checking ..
Back to top
View user's profile Send private message
rOss^64
n00b
n00b


Joined: 19 Dec 2004
Posts: 32

PostPosted: Wed Aug 17, 2005 6:54 am    Post subject: Reply with quote

Just wanted to thank you for your question and posting the answer.
not many people do that. saved me from pulling my hairout.

always seem the simple things are forgotten .. never remember to digest.
_________________
==< Linux brownstar 2.6.17-gentoo-r4 #1 PREEMPT Thu Jul 27 00:09:38 MDT 2006 i686 AMD Athlon(tm) 64 FX-55 Processor GNU/Linux >==
Back to top
View user's profile Send private message
m0rd0
n00b
n00b


Joined: 15 Feb 2005
Posts: 40
Location: Bristol, UK

PostPosted: Wed Aug 17, 2005 7:10 am    Post subject: Reply with quote

Just encountered exactly the same problem with www-client/mozilla-1.7.11-r2. Rebuilding the digest worked for me too. Thanks.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Wed Aug 17, 2005 7:16 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of rsync mirrors out of date / gcc and libIDL manifests broken.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum