Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Get DRI working with Radeon 9600/M10 (deprecated)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 7:50 pm    Post subject: Reply with quote

Code:
DarkThunder silian87 # grep glx /var/log/Xorg.0.log
(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)


I have not glx, don't know why! can someone help me?:?
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 8:02 pm    Post subject: Reply with quote

silian87 wrote:
Code:
DarkThunder silian87 # grep glx /var/log/Xorg.0.log
(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)


I have not glx, don't know why! can someone help me?:?


Are you running the latest portage beta of xorg? as glx is from that;

Quote:

(II) LoadModule: "glx"
(II) Loading /usr/lib/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"

_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 8:07 pm    Post subject: Reply with quote

Code:
*  x11-base/xorg-x11
      Latest version available: 6.8.99.15
      Latest version installed: 6.8.99.15
      Size of downloaded files: 46,041 kB


Seem to be the last...

Use flags seems good:
Code:

DarkThunder xorg-x11 # emerge -vp xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] x11-base/xorg-x11-6.8.99.15  (-3dfx) +bitmap-fonts -cjk -debug -doc -font-server +insecure-drivers +ipv6 -minimal -nls -nocxx +opengl +pam -sdk -static +truetype-fonts +type1-fonts (-uclibc) +xprint +xv 0 kB

Total size of downloads: 0 kB

_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 8:10 pm    Post subject: Reply with quote

Wierd; does /usr/lib/modules/extensions/libglx.so exist?

Surely this update has no effect on xorg ... did xorg work before??
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 8:13 pm    Post subject: Reply with quote

Xorg work before with glx too.

see:
Code:
silian87@DarkThunder ~ $ ls /usr/lib/modules/extensions/libglx.so
ls: /usr/lib/modules/extensions/libglx.so: No such file or directory
silian87@DarkThunder ~ $ ls /usr/lib/modules/extensions/lib
libGLcore.so  libdri.so     libglx.a      libxtrap.so   
libdbe.so     libextmod.so  librecord.so 
silian87@DarkThunder ~ $ ls /usr/lib/modules/extensions/libglx.a


I have only the .a files.
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 8:15 pm    Post subject: Reply with quote

Code:
lrwxrwxrwx  1 root root      44 Jul 25 13:47 libglx.a -> /usr/lib/opengl/xorg-x11/extensions/libglx.a


And it is a broken link!!!
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 8:16 pm    Post subject: Reply with quote

I find this! I do a link, now I Try.
Code:
libglx.so
DarkThunder extensions # rm libglx.a
DarkThunder extensions # ln -s /usr/lib/opengl/xorg-x11/extensions/libglx.so ./

_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Mon Aug 22, 2005 8:19 pm    Post subject: Reply with quote

Strange: I just commented out "glx" in the modules sections and everything works perfect! Have you tried glxgears or glxinfo? Any errors?

I don't even have a libglx.[so,a] anywhere

Have you done a "opengl-update mesa-cvs"?

Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 8:26 pm    Post subject: Reply with quote

Yes I done opengl, but now with the symbolic link and DISABLING Xinerama it works!

Code:
5070 frames in 5.0 seconds = 1013.944 FPS


Thank you! I will try it on dual screen soon :D
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 8:31 pm    Post subject: Reply with quote

silian87 wrote:
Yes I done opengl, but now with the symbolic link and DISABLING Xinerama it works!

Code:
5070 frames in 5.0 seconds = 1013.944 FPS


Thank you! I will try it on dual screen soon :D


Cool :)

btw what screen is it? cinema? whats your working xorg.conf for the external monitor? :wink:
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 9:29 pm    Post subject: Reply with quote

It is a 15'' lcd samsung.... I have a working xorg.conf for it (with xinerama), but I saw xinerama problem with this driver, So i will try, and i'll tell you.
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 9:40 pm    Post subject: Reply with quote

Ok, no problem :)

btw;

Just updated cvs and get the following error now :roll:

[quote
libGL: XF86DRIGetClientDriverName: 4.0.1 r300 (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r300_dri.so
libGL error: dlopen /usr/X11R6/lib/modules/dri/r300_dri.so failed (/usr/X11R6/lib/modules/dri/r300_dri.so: undefined symbol: drmCommandWriteRead)
libGL error: unable to find driver: r300_dri.so
[/quote]

Driver clearly exists :oops:

Going for my backup r300_dri.so now :wink:
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Mon Aug 22, 2005 9:44 pm    Post subject: Reply with quote

DRI is always disabled with Xinerama (regardless of the driver)! ;-)


Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 10:15 pm    Post subject: Reply with quote

Some games I tried:
- Tuxracer (textures problems)
- Neverball (not very very fast, but playable)
- Armagetron (all ok! very very faster)

I'll try other games as soon as possible... and now there are quek3 sources out... so when someone will be able to compile it, I will tray. Yay!
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 10:17 pm    Post subject: Reply with quote

Ok, back working again! remember to take a backup of the dri module! :wink:
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Mon Aug 22, 2005 10:19 pm    Post subject: Reply with quote

Miguel wrote:
Oh and MergedFB works better, because Xinerama disables DRI.


Just read that from 'man radeon' :)

Going to give MergedFB a try now thx.
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 10:46 pm    Post subject: Reply with quote

gl117 is too slow...

Now I try cube and flightgear :D
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 10:48 pm    Post subject: Reply with quote

HighOnBonsai wrote:
DRI is always disabled with Xinerama (regardless of the driver)! ;-)


Christopher


mmm but If I keep it anabled, all works, but I have 120fps on a single screen... seem to be enable... I will try.
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 11:21 pm    Post subject: Reply with quote

Cube give me an error...

- FooBillard works very nicely!

Now I try trigger and flightgears.

8)
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Mon Aug 22, 2005 11:31 pm    Post subject: Reply with quote

Trigger dont' works... the game, like cube, start, but when I start a race it exit and it give me:
Code:
r300SetupPixelShader: No valid fragment shader, exiting


:cry:
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Tue Aug 23, 2005 8:15 am    Post subject: Reply with quote

Quote:
mmm but If I keep it anabled, all works, but I have 120fps on a single screen... seem to be enable... I will try.


Seems to got indirect rendering. Thanks for the reports of software which works and does not (going to update the list in the howto).

Quote:
Trigger dont' works... the game, like cube, start, but when I start a race it exit and it give me:
...


Yeah, it seems that still not every single feature is implemented (reflection in neverball neither works)


Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Tue Aug 23, 2005 10:13 am    Post subject: Reply with quote

Flightgear works, but it is TOO slow to be playable.
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Tue Aug 23, 2005 10:25 am    Post subject: Reply with quote

Supertux with the opengl extension, work better than without, nice!
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
HighOnBonsai
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 260

PostPosted: Tue Aug 23, 2005 10:36 am    Post subject: Reply with quote

It seems that you have just done a:

Code:
emerge games-*/*



:-D


Christopher
_________________
Are YOU high - on bonsai?
Back to top
View user's profile Send private message
silian87
Advocate
Advocate


Joined: 06 Oct 2003
Posts: 2318
Location: Treviso, Italy

PostPosted: Tue Aug 23, 2005 10:53 am    Post subject: Reply with quote

muahhaha

No no... now I get relaxed :D
_________________
Musica che ascolto: http://www.last.fm/user/silian87/

Silian87 FAQs: http://marentax.homelinux.org/~silian87/silian87-faq.txt

GTalk: silian87@gmail.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum