Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
*I Hate ATI* 9700 ati drivers bomb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
marcus0263
Apprentice
Apprentice


Joined: 18 Mar 2005
Posts: 177
Location: Seattle

PostPosted: Fri Aug 19, 2005 4:59 am    Post subject: *I Hate ATI* 9700 ati drivers bomb Reply with quote

Ok I cannot seem to get the ATI drivers to work on my laptop

It's a Mobility Radeon 9700, Gentoo reads it
Code:
0000:01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]


Here's a section of my errors
Quote:
ymbol XAAGetPixmapIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAACheckTileReducibility from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetScreenIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol XAAGetPixmapIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol fbGetWinPrivateIndex from module /usr/lib/modules/drivers/fglrx_drv.o is unresolved!

Fatal server error:
Some required symbols were unresolved

I've used the stable driver and currently unmasked and using ati-drivers 8.14.13-r2

Currently my kernel is built with
Code:
 <*> Support for frame buffer devices
 <*>   VESA VGA graphics support
 VESA driver type (vesafb-tng)
 (1024x768@32) VESA default mode
<M> ATI Radeon display support
[*] Support for the framebuffer splash

And yes
Code:
 [*] MTRR (Memory Type Range Register) support


Ok where did I screw up besides having an ATI card?

I've tried every sort of variation while using fglrxconfig I could think of but I keep getting this unresolved module
_________________
Reject The Herd
"Where Thought Crime is Committed"
www.rejecttheherd.net
Gentoo Powered
Back to top
View user's profile Send private message
Mamizou
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2003
Posts: 101

PostPosted: Fri Aug 19, 2005 6:05 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-371529.html

We're having the same problems.

But here's a suggestion: I would not enable radeonfb in your kernel. Stick with vesafb alone, because radeonfb and ati-drivers may have a fight over who controls your videocard...

Well, maybe not if it's compiled as a module, and not loaded when you're using ati-drivers. Hmmm... well I dunno, radeonfb doesn't work with PCIe cards (and I have an X700 Pro...)... so I dunno what would happen.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Aug 19, 2005 7:09 am    Post subject: Reply with quote

Please follow up to the topic Arekku posted a link to.

Moved from Installing Gentoo to Duplicate Threads.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum