Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
e16 on a G3 -- no mouse clicky!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Hawklad
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2004
Posts: 87
Location: Broomfield, Colorado

PostPosted: Sun Aug 21, 2005 4:00 am    Post subject: e16 on a G3 -- no mouse clicky! Reply with quote

I was trying to add some more zip to an old beige G3 I'm using as computer for my classroom. I have it running XFCE4 but its a bit sluggish. I emerged E16 and got it up and running no problem...but, when I click on the desktop nothing happens. No menus, nothing. When I log out and go back into XFCE4 it works fine. Any idea why the mouse wouldn't work with E16? Obviously I'm using the same Xorg.conf so I'm baffled.

Thanks in advance.
Back to top
View user's profile Send private message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Sun Aug 21, 2005 12:51 pm    Post subject: Reply with quote

I saw this problem a very long time ago. I'm not running E16 any more ( E17 for me ), so I can't be particularly precise, but there's a menu generation command somewhere that you have to run. e16_gen_menu? Like I said, it's been quite a while, so I might be way off. Anyway, from memory, my menu generation was failing because I didn't have imagemagick installed. The menu generation script converts icons into little icons, or something. I can't really remember.

Try going to a box with E16 running, and selecting the menu item to regenerate menus. Then open an Eterm, and find out what command is running. Then go to your box which is giving you problems, and edit your .xinitrc ... add a line:

Eterm & immediately before the command to start E16, so you get an Eterm when you log in. Then when you start Enlightenment, run the command to generate the menus, and see what happens.

Good luck. Also keep in mind that E17 is fast approaching the usefulness as E16, and has even better eye candy :) I've got it running on a 350Mhz G3 PowerMac, and it runs great :)
Back to top
View user's profile Send private message
llywelyn
n00b
n00b


Joined: 30 Sep 2004
Posts: 45

PostPosted: Sun Aug 21, 2005 6:02 pm    Post subject: Reply with quote

Can you middle-click?

On my box, when running e16 for the first time, I had to middle-click on the desktop, change themes, and then change back before the menu-generation would finish. When the menu-genteration finished left-clicking would work fine.

Crazy I know, but I did some testing and it consistently required me to change themes before the menu-generation would finish.
_________________
Estoy apesadumbrado para mi Español ... estoy practicando ...
iBook Dual-USB G3/800MHz 640 MB RAM
OS 10.4 / Gentoo 2005.0 / NetBSD 2.1
Back to top
View user's profile Send private message
Hawklad
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2004
Posts: 87
Location: Broomfield, Colorado

PostPosted: Mon Aug 22, 2005 1:42 am    Post subject: Reply with quote

Huh. Those are both interesting ideas. I'll give them a shot when I get back to my classroom tomorrow.

Thanks for the feedback. Maybe I'll upgrade to E17 if all else fails!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum